Jump to content
Калькуляторы

Настройка MVR на Орионах

Подскажите, как мне его правильно сконфигурировать?

 

Конфигурация SNR-S2960 такая:

vlan 10,60,400-499
int vlan 10
ip address 10.1.10.1 255.255.255.0
exit
ip default-gateway 10.1.10.250
vlan 10
name MGMT
exit
vlan 60
name IPTV
multicast-vlan
multicast-vlan association 400-499
exit
ip dhcp snooping enable
ip dhcp snooping vlan 400-499
isolate-port group ACCESS switchport int eth 1/1-24,26-28
loopback-detection interval-time 60 5
loopback-detection control-recovery timeout 60
loopback-detection trap enable
access-list 6010 permit ip any 224.0.0.0 0.0.0.255
access-list 6010 permit ip any 239.0.0.0 0.0.255.255
access-list 6010 permit ip any 239.195.0.0 0.0.255.255
access-list 6010 deny ip any any
int eth 1/25-28
switchport mode trunk
switchport trunk allowed vlan 10;60;400-499
ip dhcp snooping trust
pppoe intermediate-agent
pppoe intermediate-agent trust
ip multicast destination-control access-group 6010
exit
int eth 1/1-24
switchport mode access
switchport access vlan 400
switchport association multicast-vlan 60
loopback-detection control block
loopback-detection specified-vlan 400-499
ip dhcp snooping action blackhole recovery 60
pppoe intermediate-agent
pppoe intermediate-agent vendor-tag strip
ip multicast destination-control access-group 6010
igmp snooping drop query
exit
pppoe intermediate-agent
pppoe intermediate-agent format circuit-id ascii
pppoe intermediate-agent format remote-id ascii
multicast destination-control
ip igmp snooping
ip igmp snooping vlan 60
ip igmp snooping vlan 60 immediately-leave
ip igmp snooping vlan 60 query-interval 60

 

Краткое описание:

VLAN 10 - управление

VLAN 60 - IPTV (мультикаст)

VLAN 4xx — абонентский VLAN (DHCP, PPPoE)

порты 1-24 - абонентские

порт 25 - аплинк

порты 26-28 - даунлинки (к ним могут цепочкой подключаться такие же коммутаторы)

 

Нужно получить аналогичную конфигурацию для Orion A28F.

 

Сейчас сделал так (порты 1-24, 27-28 - абонентские, порт 25 аплинк, порт 26 даунлинк):

create vlan 10,60,400-499 active
mvr enable
mvr vlan 60
int range 1-24,27-28
switchport mode access
switchport access vlan 400
switchport protect
pppoeagent enable
pppoeagent vendor-spevific-tag overwrite enable
mvr type receiver
exit
int range 25-26
switchport mode trunk
switchport trunk allowed vlan 10,60,400-499
switchport trunk untagged vlan remove 1
pppoeagent enable
pppoeagent trust
pppoeagent vendor-spevific-tag overwrite disable
exit
int ip 0
ip address 10.1.10.1 255.255.255.0 10
exit
ip default-gateway 10.1.10.250

 

Но IPTV не работает.

И при включении mvr получаю сообщение, что нужно сконфигурировать multicast vlan и userdata vlan на портах получателей.

Share this post


Link to post
Share on other sites

1. Нужно указать порт источник: mvr type source

2. Определить группы: mvr vlan 60 group 239.192.10.1 170 или какие там у вас

3. На портах клиентов поставить switchport access egress-allowed vlan 60

Share this post


Link to post
Share on other sites

1. Само собой.

2. Не подходит, у меня групп слишком много.

3. Да, и это в том числе. Вопрос уже решил, завтра конфиг покажу.

Share this post


Link to post
Share on other sites

2. Не подходит, у меня групп слишком много.

 

В смысле? Второй параметр - это количество групп от указанного адреса. Одной строкой хоть 4000 задать можно.

Share this post


Link to post
Share on other sites

Одной строкой хоть 4000 задать можно.

А 100000 (два блока по /16) можно?

Кроме того, задать можно одной строкой, но в конфигурации они сохраняются по одному.

 

У меня работает такая конфигурация:

create vlan 10,60,400 active
create vlan 1000 suspend
ip igmp snooping
mvr enable
mvr vlan 60
mvr vlan 60 group any
!
interface port 1
switchport access vlan 400
switchport access egress-allowed vlan 60,400
switchport access egress-allowed vlan remove 1 
switchport protect 
mvr type receiver
mvr immediate
pppoeagent enable
pppoeagent vendor-specific-tag overwrite enable
!
interface port 25
switchport trunk allowed vlan 10,60,400
switchport trunk untagged vlan remove 1 
switchport mode trunk
ip dhcp snooping trust
mvr type source
pppoeagent trust
!
filter enable
ip igmp snooping mrouter vlan 60 port-list 25
mac-address-table multicast filter-mode filter-all

Share this post


Link to post
Share on other sites

А 100000 (два блока по /16) можно?

 

У вас 100000 телеканалов? :) Да и сам девайс-то держит только "1K multicast addresses"

 

Кроме того, задать можно одной строкой, но в конфигурации они сохраняются по одному.

 

Да одной строчкой так и сохраняется. По крайней мере на A28F

Edited by grfmaniak

Share this post


Link to post
Share on other sites

Каналов конечно меньше.

Но 239/8 зарезервированы для приватного использования, зачем тесниться?

Share this post


Link to post
Share on other sites

У меня работает такая конфигурация:

create vlan 10,60,400 active

create vlan 1000 suspend

ip igmp snooping

mvr enable

mvr vlan 60

mvr vlan 60 group any

!

interface port 1

switchport access vlan 400

switchport access egress-allowed vlan 60,400

switchport access egress-allowed vlan remove 1

switchport protect

mvr type receiver

mvr immediate

pppoeagent enable

pppoeagent vendor-specific-tag overwrite enable

!

interface port 25

switchport trunk allowed vlan 10,60,400

switchport trunk untagged vlan remove 1

switchport mode trunk

ip dhcp snooping trust

mvr type source

pppoeagent trust

!

filter enable

ip igmp snooping mrouter vlan 60 port-list 25

mac-address-table multicast filter-mode filter-all

 

Сделал также - видит маки с access порта в влане инета, iptv мультикаста нет, что делаю не так?

Alpha-A28E(config)#show mac-address-table multicast
Multicast filter mode: Forward-all
Vlan  Group Address    Ports[static](Hardware)
-------------------------------------------------------
2035  0100.5E7F.0074   1[n/a](1)
2035  0100.5E7F.0065   1[n/a](1)
2035  0100.5E7F.FFFA   1[n/a](1)

 

!NOS  Version NOS_4.14.1967.Alpha-A28E.002.20140808
!command in view_mode
!
!command in config_mode first-step
create vlan 699,2035,3333 active
ip igmp snooping
mvr enable
mvr vlan 3333
mvr vlan 3333 group any
!
interface port 1
switchport access vlan 2035
switchport access egress-allowed vlan 2035,3333
switchport protect
mvr type receiver
mvr immediate
!
interface port 26
switchport trunk allowed vlan 699,2035,3333
switchport mode trunk
ip dhcp snooping trust
mvr type source
!
!command in vlan configuration mode
!
!command in ip interface mode
interface ip 0
ip vlan 699
ip address 10.7.99.7 255.255.255.0 699
!
!command in cmap_mode
!
!command in pmap_mode
!
!command in config_mode
ip default-gateway 10.7.99.1
filter enable
ip igmp snooping mrouter vlan 3333 port-list 26
!

Edited by meeze

Share this post


Link to post
Share on other sites

Сделал также - видит маки с access порта в влане инета, iptv мультикаста нет, что делаю не так?

Alpha-A28E(config)#show mac-address-table multicast
Multicast filter mode: Forward-all
Vlan  Group Address    Ports[static](Hardware)
-------------------------------------------------------
2035  0100.5E7F.0074   1[n/a](1)
2035  0100.5E7F.0065   1[n/a](1)
2035  0100.5E7F.FFFA   1[n/a](1)

 

!NOS  Version NOS_4.14.1967.Alpha-A28E.002.20140808
!command in view_mode
!
!command in config_mode first-step
create vlan 699,2035,3333 active
ip igmp snooping
mvr enable
mvr vlan 3333
mvr vlan 3333 group any
!
interface port 1
switchport access vlan 2035
switchport access egress-allowed vlan 2035,3333
switchport protect
mvr type receiver
mvr immediate
!
interface port 26
switchport trunk allowed vlan 699,2035,3333
switchport mode trunk
ip dhcp snooping trust
mvr type source
!
!command in vlan configuration mode
!
!command in ip interface mode
interface ip 0
ip vlan 699
ip address 10.7.99.7 255.255.255.0 699
!
!command in cmap_mode
!
!command in pmap_mode
!
!command in config_mode
ip default-gateway 10.7.99.1
filter enable
ip igmp snooping mrouter vlan 3333 port-list 26
!

Здравствуйте.

 

В конфигурацию необходимо добавить команду:

mac-address-table multicast filter-mode filter-all

Share this post


Link to post
Share on other sites

В конфигурацию необходимо добавить команду:

mac-address-table multicast filter-mode filter-all

 

Здравствуйте. Спасибо, пробовал - разницы никакой нет

Share this post


Link to post
Share on other sites

здравствуйте,

сделайте команду no ip igmp snooping

 

Прилетели группы с аплинка и сабскрайбера, на вышестоящем l3 вижу подписку, но не работает

Share this post


Link to post
Share on other sites

здравствуйте,

сделайте команду no ip igmp snooping

 

Прилетели группы с аплинка и сабскрайбера, на вышестоящем l3 вижу подписку, но не работает

Здравствуйте.

Напишите нам на support@nag.ru.

Share this post


Link to post
Share on other sites

Добрый вечер,

 

Подскажите , сконфигурировал MVR по примеру статьи http://shop.nag.ru/article/mvr-na-kommutatorah-orion-a10ea18ea28e .

На приставке канал включается поток идет , но отваливается через 10 секунд(таймер четко совпадает с Live timer в sh mvr vlan member), затем через промежуток времени , приставка снова цепляет канал , но через те же 10 секунд отваливается . Так повторяется 3 раза , затем приставка уже не может подцепиться к потоку.

 

В чем может быть проблема?

 

 

Alpha-A28E#sh mvr vlan 123 member 
MVR Multicast VLAN    Group IP         User VLAN   Live Time    Join Port
-------------------------------------------------------------------------
123                   230.200.201.175  123         6            25-28

 

Приставка в этот момент в 7 порту коммутатора

 

 

Конфигурация:

 System current configuration:
!NOS  Version NOS_4.14.1968.Alpha-A28E.002.20150608 
!command in view_mode

mvr enable
mvr vlan 123
mvr vlan 123 group any


interface port 7 
switchport access vlan 1611 
switchport access egress-allowed vlan 123
mvr type receiver
lldp disable
spanning-tree disable 

interface port 25 
switchport trunk allowed vlan 665,123,1611,3638
switchport mode trunk
mvr type source
!
interface port 26 
switchport trunk allowed vlan 665,123,1611,3638
switchport mode trunk
mvr type source

 

Коммутатор установлен между двумя Dlink с multicast vlan.

Share this post


Link to post
Share on other sites

Ты же сам ответил на свой вопрос, увеличь live time на орионе до пары минут, чтобы приставка успевала подтверждать подписку до его окончания.

Share this post


Link to post
Share on other sites

Столкнулся с аналогичной проблемой, есть решение?

Share this post


Link to post
Share on other sites

Здравствуйте!

Установите значение параметра mvr timeout больше 10.

Значение зависит от используемого на вашей сети IGMP query interval.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this