Jump to content
Калькуляторы

SNR-S3750G-24S-E и QinQ SNR-S3750G-24S-E и QinQ

Доброго времени суток.

Столкнулся с такой проблемой.

Есть 2 коммутатора SNR-S3750G-24S-E и канал L2 между ними, оргинизованный провайдером. Провайдер выделил vlan с номером 2000 для трафика.

Со стороны прова на мои свичи смотрят транковые порты, у меня соответсвенно тоже самое

switch1:

#interface ethernet1/0/25                
#switchport mode trunk 
#Set the port Ethernet1/0/25 mode Trunk successfully
#switchport trunk allowed vlan 2000

на втором свиче тоже самое.

На порту 26 (switch1) я грубо говоря "беру" Интернет у другого провайдера:

#interface ethernet1/0/26                
#switchport mode access 
#switchport access vlan 2000

И отправляю на switch2 через 25-й порт и далее на порграничный рутер. Конфиг на switch2 точно такой же.

Задача - организовать прозрачный канал L2 от switch1 до switch2 для двух клиентов. Чтобы не пробрасывать еще один vlan между свичами (нужно договариваться с провом платить денежку) я решил использвать QinQ и навешивать метку уже существующего vlan 2000. Делал по мануалу на сайте. Для одного клиента все прошло удачно (для клиента выделен vlan c №900, в мою сторону от клиента смотрит транковый порт и идет тегированный трафик). Запаковываю клиентский трафик на switch1:

#vlan 2000
#switchport interface ethernet1/0/10
#interface ethernet1/0/10
#dot1q-tunnel enable

На switch2 снимаю метку:

#vlan 2000
#switchport interface ethernet1/0/14
#interface ethernet1/0/14
#dot1q-tunnel enable

Где 14-й порт смотрит на железку клиента. Все работает замечательно. Пакеты запаковываются на swith1 и распаковываются на switch2 на 14 порту. И к клиенту идет тегированный трафик с vlan 900.

А вот со вторым клиентом ничего не получилось, хотя делал все также. Конфиг не привожу так как отличаются номера портов (15 порт на обоих свичах) и номер vlan (901).

#show vlan
...   
2000 Abonents     Static     ENET      Ethernet1/0/10      Ethernet1/0/15    
                                      Ethernet1/0/25(T)      Ethernet1/0/26 
...

#show dot1q-tunnel 
Interface Ethernet1/0/10:
   dot1q-tunnel is enable
Interface Ethernet1/0/15:
   dot1q-tunnel is enable
Interface Ethernet1/0/26:
   dot1q-tunnel is enable

Повторю, порт 26 смотрит на провайдера, у которого беру контент. 25 - аплинк ко второму свичу, 10 - клиент1, 15 - клиент2

 

Конфиг switch2:

#show vlan
...   
2000 Abonents     Static     ENET      Ethernet1/0/14      Ethernet1/0/15    
                                      Ethernet1/0/25(T)      Ethernet1/0/26
...

#show dot1q-tunnel 
Interface Ethernet1/0/14:
   dot1q-tunnel is enable
Interface Ethernet1/0/15:
   dot1q-tunnel is enable
Interface Ethernet1/0/26:
   dot1q-tunnel is enable

порт 25 аплинк к первому свичу, 26 - на пограничник, 14 - клиент1, 15 - клиент2

Собственно вопрос, что сделано не правильно. Почему канал для клиента 1 работает нормально, а со вторым ничего не выходит. Ведь настариваю точно также. По идее на switch1 должна навесится метка 2000 (порт 15), а на switch2 метка снимается (также порт 15). И в сторону клиента должен идти трафик с тегом 901. Помогите пожалуйста!

Share this post


Link to post
Share on other sites

Если одно работает а второе нет - ищите различия.

Например величина MTU у оператора что даёт Вам транк.

Без приведения конфигов дальше помочь не получится.

Share this post


Link to post
Share on other sites

Если одно работает а второе нет - ищите различия.

Например величина MTU у оператора что даёт Вам транк.

Без приведения конфигов дальше помочь не получится.

Все оказалось куда проще чем я думал и дело вовсе не в qinq. Дело в том, что сервис для меня и клиента2 предоставляет один и тот же пров (у клиента1 своя железка и пользуется он исключительно L2). Так вот - мак адреса шлюзов для меня и клиента2 совпадают. Т.е ip разные, а mac - одинаковые. Т.к ко мне ходит довольно интенсивный трафик, то мак закреплен как правило за портом где я беру контент (заметил, что очень редно icmp для клиента2 все таки проскакивают и если заблокировать "мой" порт, то у клиента все - ок). Соответственно, пакеты клиента2 уходят не на тот порт. Подскажите, если пров не согласится сменить один из маков у себя, как мне можно поступить? К примеру статически с коммутировать, что то вроде если пришел пакет с мак адресом отправителя клиента2, то отпарвлять на порт 15, не зависимо от того, какой мак адрес назначения. Да и вобще реально ли так сделать?

Edited by greenfox82

Share this post


Link to post
Share on other sites

Так а причём тут маки шлюзов и L2 туннели?

Они как бы не должны пересекаться.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this