Jump to content
Калькуляторы

Ошибки на интерфейсах нужна помощь

Добрый день!

Нужна помощь.

Ошибки на интерфейсах, потеря пакетов.

 

if 0/0 смотрит в инет

 

5 minute input rate 40368000 bits/sec, 4952 packets/sec

5 minute output rate 8860000 bits/sec, 3604 packets/sec

1995053984 packets input, 3583324273 bytes, 0 no buffer

Received 83948 broadcasts, 0 runts, 0 giants, 154 throttles

128262 input errors, 0 CRC, 0 frame, 4456 overrun, 123806 ignored

 

if 1/0 смотрит в нашу сеть

 

5 minute input rate 9355000 bits/sec, 3480 packets/sec

5 minute output rate 34173000 bits/sec, 4007 packets/sec

1414355008 packets input, 1016738213 bytes

Received 2022878 broadcasts, 0 runts, 0 giants, 4 throttles

45437 input errors, 0 CRC, 0 frame, 4 overrun, 44865 ignored

 

нужен совет что делать?

Share this post


Link to post
Share on other sites

Router#show buffers

Buffer elements:

1117 in free list (1119 max allowed)

53328824 hits, 0 misses, 619 created

 

Public buffer pools:

Small buffers, 104 bytes (total 85, permanent 50, peak 133 @ 6d18h):

83 in free list (20 min, 150 max allowed)

22721877 hits, 2513 misses, 1773 trims, 1808 created

722 failures (0 no memory)

Middle buffers, 600 bytes (total 25, permanent 25, peak 65 @ 6d18h):

23 in free list (10 min, 150 max allowed)

5162158 hits, 433 misses, 250 trims, 250 created

216 failures (0 no memory)

Big buffers, 1536 bytes (total 50, permanent 50, peak 96 @ 4d02h):

49 in free list (5 min, 150 max allowed)

11223008 hits, 2267 misses, 432 trims, 432 created

1014 failures (0 no memory)

VeryBig buffers, 4520 bytes (total 10, permanent 10, peak 13 @ 4d23h):

9 in free list (0 min, 100 max allowed)

472 hits, 544 misses, 30 trims, 30 created

544 failures (0 no memory)

Large buffers, 5024 bytes (total 1, permanent 0, peak 4 @ 4d23h):

1 in free list (0 min, 10 max allowed)

51 hits, 493 misses, 86 trims, 87 created

493 failures (0 no memory)

Huge buffers, 18024 bytes (total 1, permanent 0, peak 3 @ 3d18h):

1 in free list (0 min, 4 max allowed)

29 hits, 464 misses, 72 trims, 73 created

464 failures (0 no memory)

 

Interface buffer pools:

IPC buffers, 4096 bytes (total 2, permanent 2):

2 in free list (1 min, 8 max allowed)

0 hits, 0 fallbacks, 0 trims, 0 created

0 failures (0 no memory)

 

Header pools:

Header buffers, 0 bytes (total 511, permanent 256, peak 511 @ 6d18h):

255 in free list (256 min, 1024 max allowed)

171 hits, 85 misses, 0 trims, 255 created

0 failures (0 no memory)

256 max cache size, 256 in cache

966516 hits in cache, 0 misses in cache

 

Particle Clones:

1024 clones, 286295 hits, 0 misses

 

Public particle pools:

F/S buffers, 128 bytes (total 512, permanent 512):

0 in free list (0 min, 512 max allowed)

512 hits, 0 misses, 0 trims, 0 created

0 failures (0 no memory)

512 max cache size, 512 in cache

286295 hits in cache, 0 misses in cache

Normal buffers, 512 bytes (total 2048, permanent 2048):

2048 in free list (1024 min, 4096 max allowed)

0 hits, 0 misses, 0 trims, 0 created

0 failures (0 no memory)

 

Private particle pools:

FastEthernet1/0 buffers, 512 bytes (total 400, permanent 400):

0 in free list (0 min, 400 max allowed)

400 hits, 0 fallbacks

400 max cache size, 271 in cache

2210215139 hits in cache, 0 misses in cache

14 buffer threshold, 0 threshold transitions

GigabitEthernet0/1 buffers, 768 bytes (total 2129, permanent 2000):

129 in free list (128 min, 6000 max allowed)

1957 hits, 43 fallbacks, 120 trims, 249 created

0 failures (0 no memory)

2000 max cache size, 1872 in cache

1460848 hits in cache, 0 misses in cache

14 buffer threshold, 0 threshold transitions

GigabitEthernet0/0 buffers, 768 bytes (total 2129, permanent 2000):

129 in free list (128 min, 6000 max allowed)

1957 hits, 43 fallbacks, 120 trims, 249 created

0 failures (0 no memory)

2000 max cache size, 1872 in cache

4275624899 hits in cache, 0 misses in cache

14 buffer threshold, 0 threshold transitions

 

 

Router#

Share this post


Link to post
Share on other sites

Помогите кто знает.

Share this post


Link to post
Share on other sites

Это значит что у вас на момент прихода пакета на интерфейс не нашлось свободного места в буфере.

Share this post


Link to post
Share on other sites

Диагноз ставить :)

 

Какой маршрутизатор?

IOS?

Конфиг?

Трафику сколько?

Share this post


Link to post
Share on other sites

Диагноз ставить :)

 

Какой маршрутизатор?

IOS?

Конфиг?

Трафику сколько?

 

 

7401ASR

12.4

in 50 out 15

cpu 40-50%

конфиг:

Building configuration...

 

Current configuration : 3811 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot system disk0:c7400-ik9o3s-mz.124-12.bin

boot-end-marker

!

no logging console

!

aaa new-model

aaa session-mib disconnect

!

!

aaa authentication login default local

aaa authentication ppp default group radius

aaa authorization network default group radius

aaa accounting delay-start

aaa accounting update periodic 5

aaa accounting network default start-stop group radius

!

aaa session-id common

clock timezone MSK 0

!

ip nbar pdlm disk0:bittorrent.pdlm

ip nbar pdlm disk0:directconnect.pdlm

ip nbar pdlm disk0:eDonkey.pdlm

!

ip cef

ip name-server 8.8.8.8

ip name-server 217.9.148.4

ip name-server 217.9.147.42

ip name-server 10.0.0.1

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.0.0 192.168.0.100

!

ip dhcp pool LOCAL

network 192.168.0.0 255.255.252.0

dns-server 10.0.0.1

default-router 192.168.0.1

!

!

no ip pxf

!

!

virtual-template 1 pre-clone 500

!

!

!

!

!

!

!

!

!

!

!

!

!

username ххххххххххх privilege 15 secret 5

archive

log config

logging enable

hidekeys

!

!

class-map match-any p2p

match protocol bittorrent

match protocol directconnect

match protocol edonkey

!

!

policy-map limit-torrents

class p2p

police 2560000 480000 960000 conform-action transmit exceed-action drop violate-action drop

!

!

!

!

!

bba-group pppoe global

virtual-template 1

sessions max limit 8000

ac name nas1

sessions per-mac limit 1

sessions per-vlan limit 500

sessions auto cleanup

!

!

interface GigabitEthernet0/0

description INTERNET

ip address ххх.ххх.40.210 255.255.255.252

ip nbar protocol-discovery

ip nat outside

ip virtual-reassembly

duplex full

speed auto

media-type gbic

no negotiation auto

!

interface GigabitEthernet0/1

description BILLING

ip address 10.0.0.2 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex full

speed auto

media-type rj45

no cdp enable

!

interface FastEthernet1/0

description LOCAL

ip address 192.168.0.1 255.255.252.0

duplex full

vlan-range dot1q 1 4048

pppoe enable group global

exit-vlan-config

!

pppoe enable group global

no cdp enable

!

interface Virtual-Template1

mtu 1492

ip unnumbered GigabitEthernet0/1

ip flow ingress

ip flow egress

ip virtual-reassembly

autodetect encapsulation ppp

peer default ip address pool PPPoE

ppp max-bad-auth 3

ppp authentication chap

ppp timeout retry 3

ppp timeout authentication 45

ppp timeout idle 3600

!

ip route 0.0.0.0 0.0.0.0 ххх.ххх.40.209

ip flow-export source Virtual-Template1

ip flow-export version 5

ip flow-export destination 10.0.0.1 9996

!

no ip http server

no ip http secure-server

!

ip nat inside source static 10.0.0.1 interface GigabitEthernet0/0

!

!

ip access-list standard RW3

access-list 114 remark ** Remix DAY-Time ACL

access-list 114 permit ip any any time-range DAY-REMIX

access-list 115 remark ** NIGHT-Time ACL

access-list 115 permit ip any any time-range NIGHT-REMIX

snmp-server community public RO

snmp-server community private RW

!

!

!

radius-server attribute 8 include-in-access-req

radius-server attribute nas-port format e UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU

radius-server attribute 31 mac format unformatted

radius-server host 10.0.0.1 auth-port 1812 acct-port 1813

radius-server retransmit 5

radius-server timeout 30

radius-server deadtime 1

radius-server key 7 03175E08140A35

radius-server vsa send accounting

radius-server vsa send authentication

!

control-plane

!

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

line aux 0

line vty 0 4

access-class 10 in

privilege level 15

!

ntp clock-period 17180125

ntp server 62.117.76.142

time-range DAY-REMIX

periodic daily 8:00 to 23:59

!

time-range NIGHT-REMIX

periodic daily 0:00 to 7:59

!

!

end

Share this post


Link to post
Share on other sites

Попробуйте убрать все что касается nbar и торрентов, есть мнение что это слабо помогает.

Возможно pfx включить стоит.

Share this post


Link to post
Share on other sites

Попробуйте убрать все что касается nbar и торрентов, есть мнение что это слабо помогает.

Возможно pfx включить стоит.

Убрал, загрузка цп снизилась на 5%

Share this post


Link to post
Share on other sites

включил pxf

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

5 минут полёт нормальный

Share this post


Link to post
Share on other sites

Рано радовался

 

Router>sh int gi 0/0

GigabitEthernet0/0 is up, line protocol is up

Hardware is i82543 (Livengood), address is 0008.7dfc.d408 (bia 0008.7dfc.d408)

Description: INTERNET

Internet address is ххх.ххх.40.210/30

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 5/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, link type is force-up, media type is LX

output flow-control is unsupported, input flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 23:32:37

Input queue: 0/75/6684/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 23223000 bits/sec, 3156 packets/sec

5 minute output rate 5236000 bits/sec, 2522 packets/sec

300928374 packets input, 728921439 bytes, 0 no buffer

Received 12314 broadcasts, 0 runts, 0 giants, 18 throttles

45398 input errors, 0 CRC, 0 frame, 6089 overrun, 39309 ignored

0 watchdog, 12109 multicast, 0 pause input

0 input packets with dribble condition detected

239047206 packets output, 1059273860 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 pause output

0 output buffer failures, 0 output buffers swapped out

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this