Jump to content
Калькуляторы

[РЕШЕНО] EoIP поверх L2TP проблема с MSS

Решено: понизил на EoIP MTU до 1420.

 

Во вложении схема и в нормальной ситуации трафик юзера идет через EoIP 5 на Main рутер в интернет. Когда падает линк 2, трафик уходит через радиомост 3 на Alt, далее через EoIP 6 на Main в интернеты.

 

Проблема в том, что при этом идут "жуткие глюки", понимаю что опять с MSS проблема и для этого есть 2 правила:

 

/ip firewall mangle
add action=change-mss chain=forward in-interface=l2tp new-mss=1440 passthrough=\
   yes protocol=tcp tcp-flags=syn tcp-mss=1391-65535
add action=change-mss chain=forward new-mss=1420 out-interface=l2tp \
   passthrough=yes protocol=tcp tcp-flags=syn tcp-mss=1391-65535

 

Профиль соединений:

 

/interface l2tp-client
add add-default-route=no allow=pap,chap,mschap1,mschap2 connect-to=<L2TP server IP> dial-on-demand=no \
   max-mru=1460 max-mtu=1460 mrru=disabled name=l2tp password=<password> \
   profile=l2tp user=<user>
/ppp profile
add change-tcp-mss=no name=l2tp only-one=default use-compression=default use-encryption=\
   default use-mpls=default use-vj-compression=default
/interface eoip
add arp=enabled l2mtu=65535 local-address=2.2.2.2 mac-address=02:3C:9F:XX:XX:XX \
   mtu=1500 name=eoip-main remote-address=1.1.1.1 tunnel-id=13

 

Смотрю статистику - пакеты в mangle по нулям. Сменил интерфейс в правилах на eoip - пакеты есть, толку нет. Приходится, как временная мера, заворачивать юзеров в l2tp интерфейс - проблем нет с указанными правилами mangle.

 

Как правильно прогнозировать такие ситуации с MTU и можно ли разрешить текущую?

post-87545-078352100 1393941564_thumb.png

Edited by a-zazell

Share this post


Link to post
Share on other sites

Зачем вообще что-то делать с MSS?

 

Создаете туннели, создаете EoIP и все работает без проблем. На микротике не надо настраивать лишнего.

 

Если у вас туннель идет из офиса в центр, то что мешает сделать EoIP напрямую в центр, и что бы при падении первого линка он автоматически перемаршрутизировался по OSPF через резервный канал? В итоге EoIP туннель будет всегда один и никаких проблем не возникнет.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this