Jump to content
Калькуляторы

cisco 4948 ограничение скорости на vlan

Прошу помощи у цисковедов. Гуглил много, но заставить работать нагугленное не смог :(

Имеется cisco WS-C4948, иос 12.2(50)SG1

Через сей девайс транзитом проходит несколько десятков vlan, к примеру с 100 по 130 из порта Gi1/1 в порт Gi1/10

Задача ограничить скорость на этих vlan независимо друг от друга в обе стороны.

Заранее благодарю

Share this post


Link to post
Share on other sites

Я не великий спец, но мне кажется, что скорость можно ограничить или на порту, или на SVI, а просто на транзитном влане - сомнительно, что возможно....

 

UPD: админ сказал, что через vlan qos наверное можно, но документация на 49хх циску в этом разделе отсылает на 45хх серию, с замечаниями, что сделано не так, короче - копать нужно...

 

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/12-2/53SG/configuration/config/qos.html#wp1338610

Share this post


Link to post
Share on other sites

4924,4948 умеют per-port per-vlan только.

 Policy Map lim200
   Class class-default
     police 200 mbps 32 mbyte conform-action transmit exceed-action drop

 Policy Map lim100
   Class class-default
     police 100 mbps 8 mbyte conform-action transmit exceed-action drop

interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
vlan-range 10
  service-policy input lim100
  service-policy output lim100
vlan-range 20-30
  service-policy input lim200
  service-policy output lim100
end

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/54sg/configuration/guide/qos.pdf

Share this post


Link to post
Share on other sites

На некоторых кисках есть такая фича -

Feature Description

Per Port Per VLAN Policing Per-port per-VLAN quality of service (QoS) offers differentiated QoSs to individual VLANs on a trunk or access port.

 

И FN говорит что она есть для указанного свича и имиджа.

Но по факту - там куча ограничений вроде как - пробуйте. Там match vlan должно быть доступно при определении класса если не ошибаюсь.

Share this post


Link to post
Share on other sites

приведенный кусок конфига успешно работает на:

System image file is "bootflash:cat4500-entservices-mz.150-2.SG8.bin"

cisco ME-4924-10GE

 

но это тупой рейтлимит.

Share this post


Link to post
Share on other sites

Сей документ читал, пытался сделать.

В документе в примере сказано:

ip access-list 101 permit ip host 1.2.2.2 any

Class-map match-all RT
match ip access-group 101

Policy-map P31_QoS
Class RT
 Police 200m 16k conform transmit exceed drop

Так как я ничего не знаю про трафик внутри vlan, то предположил что будет работать так:

Policy-map P31_QoS
Class class-default
 Police 200m 16k conform transmit exceed drop

Если vlan только один, то более менее работает нормально, но если несколько, то работает неправильно. Создается впечатление что полиси друг с другом конфликтуют.

Share this post


Link to post
Share on other sites

Создается впечатление что полиси друг с другом конфликтуют.

с таким берстом.. это не полиси конфликтуют. если у вы не накатываете aggregate-policer, то для каждого заданного порта/влана policy-map будет работать индивидуально.

Share this post


Link to post
Share on other sites

4924,4948 умеют per-port per-vlan только.

 Policy Map lim200
   Class class-default
     police 200 mbps 32 mbyte conform-action transmit exceed-action drop

 Policy Map lim100
   Class class-default
     police 100 mbps 8 mbyte conform-action transmit exceed-action drop

interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
vlan-range 10
  service-policy input lim100
  service-policy output lim100
vlan-range 20-30
  service-policy input lim200
  service-policy output lim100
end

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/54sg/configuration/guide/qos.pdf

Так тоже пробовал. По факту если делать по примеру, то на вланах 20-30 будет общее ограничение 100 мбит, а надо отдельно на каждый влан

Share this post


Link to post
Share on other sites

class-default - это типа весь неклассифицированный трафик.

а данная фича позволяет выделить в отдельный класс трафик по критерию match vlan.

Share this post


Link to post
Share on other sites

Создается впечатление что полиси друг с другом конфликтуют.

с таким берстом.. это не полиси конфликтуют. если у вы не накатываете aggregate-policer, то для каждого заданного порта/влана policy-map будет работать индивидуально.

Размер берста менял по всякому. Пробовал также делать qos vlan-based на интерфейсе.

При полиси 4мбит и берсте 64к iperf показывает разброс результатов от 500 кбит до 4.2 мбит в пустом канале

 

class-default - это типа весь неклассифицированный трафик.

а данная фича позволяет выделить в отдельный класс трафик по критерию match vlan.

К сожалению match vlan в данном девайсе отсутствует

Edited by ASemenov

Share this post


Link to post
Share on other sites

Пробовал еще так:

Policy-map Limit_4M
Class class-default
 Police 4m 64k conform-action transmit exceed-action drop

interface Vlan100
no ip address
service-policy input Limit_4M
service-policy output Limit_4M

Эффект тотже. Скорость на влане плавает в большом диапазоне.

 

При полиси 4мбит и берсте 64к iperf показывает разброс результатов от 500 кбит до 4.2 мбит в пустом канале

да вы батенька, жмот :D

https://learningnetwork.cisco.com/docs/DOC-7874

Пробовал ставить и больше, эффекта не дало.

Share this post


Link to post
Share on other sites

К сожалению match vlan в данном девайсе отсутствует

То есть такую конструкцию не даёт создать:

"class-map match-all CM_Vlan4

match vlan 4" ?

Только что на me3400g такое набил.

 

PS: Не уверен что применять полиси на int vlan корректно для транзитного трафика. Правильней наверно всёж на порт полиси вешать.

Edited by NikAlexAn

Share this post


Link to post
Share on other sites

Только что на me3400g такое набил.

на 4924/4948 нет match vlan

4924ME(config-cmap)#match ?
 access-group  Access group
 any           Any packets
 cos           IEEE 802.1Q/ISL class of service/user priority values
 ip            IP specific values
 not           Negate this match result
 protocol      Protocol

Share this post


Link to post
Share on other sites

Только что на me3400g такое набил.

на 4924/4948 нет match vlan

4924ME(config-cmap)#match ?
 access-group  Access group
 any           Any packets
 cos           IEEE 802.1Q/ISL class of service/user priority values
 ip            IP specific values
 not           Negate this match result
 protocol      Protocol

А какой софт?

Счас глянул - для cat4924-10ge данная фича доступна на 15.0(2)SG4. А на более новых иосах фича доступна только 4948е 4900м 4500е - 4924 и 4948 не просматриваются в FN.

Share this post


Link to post
Share on other sites

иос 12.2(50)SG1

Если верить FN то эта фича есть в этом иосе для cat4948 и cat4948-10ge.

От ip base и выше.

 

Но в этой ветке последняя - 12.2(54)SG1

Share this post


Link to post
Share on other sites

Счас глянул - для cat4924-10ge данная фича доступна на 15.0(2)SG4.

не доступна.

 

Не надо верить FN, он частенько врет. Пробежался по всем 4900M/4924 что есть в хозяйстве, с разношерстным софтом.

Везде так

4900(config-cmap)#match ?
 access-group  Access group
 any           Any packets
 cos           IEEE 802.1Q/ISL class of service/user priority values
 dscp          Match DSCP in IPv4 and IPv6 packets
 ip            IP specific values
 precedence    Match Precedence in IPv4 and IPv6 packets
 protocol      Protocol
 qos-group     Qos-group

 

да и на 4900M и 4500E оно нафиг не нужно - там через vlan configuration делается все

vlan configuration 13,17,516,1516
 service-policy input pm516
 service-policy output pm516o
!

но такой финт не прокатит на 4924/4948 в силу железных ограничений.

 

з.ы. на 4900M проверил на 15.0(2)SG1, 15.0(2)SG2, 15.0(2)SG7

Share this post


Link to post
Share on other sites

Планируем приобрести SNR-S4500-44x

Кто-нибудь знает, сможет ли он решить еще и этот вопрос?

Share this post


Link to post
Share on other sites

там даже поиском не находит match vlan... ;)

Фича в ФН называется "Per Port Per VLAN Policing" - а вот реализуется по разному в разных железках оказывается.

Я то в своё время искал для me3400g. Для 4500 4948 4924 - оказывается по другому.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this