Jump to content
Калькуляторы

Load balancing bgp на se100

Добрый день!

Возможно ли на smart edge 100 по bgp load balancing для абонентов сделать 50/50, но при падении одного аплинка чтобы все абоненты перешли на другой? Подскажите как это реализовать.

Сейчас конфиг bgp такой

router bgp aaaa

multi-paths external 2

address-family ipv4 unicast

dampening

network 9.xxx.xxx.0/24

!

neighbor 4.xxx.xxx.6 external

remote-as bbbb

update-source uplink

send community

send ext-community

address-family ipv4 unicast

!

neighbor 21.xxx.xxx.17 external

remote-as cccc

update-source uplink_2

send community

send ext-community

address-family ipv4 unicast

 

Натятся все абоненты через 1 пул:

ip nat pool NAT-POOL3 napt multibind

address 9.xxx.xxx.50/32 port-block 1 to 15

 

Сети абонентов:

interface 1mkr multibind

ip address 10.2.2.1/24

dhcp proxy 253

giaddr 10.2.2.1

!

interface 2mkr multibind

ip address 10.3.157.1/24

dhcp proxy 253

giaddr 10.3.157.1

!

interface 3mkr multibind

ip address 10.9.21.1/24

dhcp proxy 253

giaddr 10.9.21.1

!

interface 4mkr multibind

ip address 10.9.23.1/24

dhcp proxy 253

giaddr 10.9.23.1

 

Подскажите может там надо сети порезать по 25 маске или prefix-list и route-map составить?

Share this post


Link to post
Share on other sites

Балансировка входящего трафика должна делаться на аплинке, а не на SE100.

Я делал, но перекос получался слишком большим. Было два аплинка 2x600, перекос вполне мог быть в 200+500.

Сбалансировать по BGP так и не удалось, в конце концов перешли на L2 (LAG), там трафик распределялся очень ровно.

Share this post


Link to post
Share on other sites

Сбалансировать по BGP так и не удалось, в конце концов перешли на L2 (LAG)

 

Какой LAG? У ТС 2 аплинка:

 

neighbor 4.xxx.xxx.6 external

remote-as bbbb

update-source uplink

send community

send ext-community

address-family ipv4 unicast

!

neighbor 21.xxx.xxx.17 external

remote-as cccc

update-source uplink_2

send community

send ext-community

address-family ipv4 unicast

Share this post


Link to post
Share on other sites

Какой LAG? У ТС 2 аплинка

Да, не обратил внимания.

У меня аплинк был один и тот же на обоих каналах.

Если аплинки разные, то 50/50 вообще нереально.

Share this post


Link to post
Share on other sites

Какой LAG? У ТС 2 аплинка:

 

neighbor 4.xxx.xxx.6 external

remote-as bbbb

update-source uplink

send community

send ext-community

address-family ipv4 unicast

!

neighbor 21.xxx.xxx.17 external

remote-as cccc

update-source uplink_2

send community

send ext-community

address-family ipv4 unicast

При multi-paths external 2, я так понимаю будет баланситься, но каким образом?

Edited by kmk08

Share this post


Link to post
Share on other sites

Эти все припарки могут только на исходящий трафик работать. А вам я так понимаю и входящий разбалансить охота?

Share this post


Link to post
Share on other sites

Эти все припарки могут только на исходящий трафик работать. А вам я так понимаю и входящий разбалансить охота?

да входящий особенно надо

 

лимит сообщений закончился.

2 alibek - резать сетку, которую мы анонсируем провайдерам? Но абоненты лезут через эту сеть всего через пул, состоящий из 1 внешнего ip.

Edited by kmk08

Share this post


Link to post
Share on other sites

да входящий особенно надо

Режь свою сетку на подсети и анонсируй с разными коэффициентами.

Но как уже сказали, это припарки. 50/50 не будет никогда.

Кроме того, подсеть маленькая, если ее резать на /25 или мельче, ее аплинк вообще зафильтровать может.

Ну и даже если фильтровать мелкие префиксы не будут, нет никакой гарантии что будут принимать во внимание твои коэффициенты.

Share this post


Link to post
Share on other sites

да входящий особенно надо

 

 

Тут поможет или more-specific сетки анонсить (что плохо и надо за это по рукам бить), или навешивать коммьюнити на свои сетки и пытаться разбалансить.

Фишка в том что 50/50 практически не достижимо в длительном периоде. Т.е. живое БГП и склоки апстримов будут каждую неделю этот баланс ломать... :)

 

Ой а тут еще и /24... Не, more-specific тоже отпадает.

Share this post


Link to post
Share on other sites

Входящий балансируется с помощью перпендов, комьюнити и специфик. Обычно можно сделать любую пропорцию, хоть 50/50, хоть 10/90.

Но, всегда есть одно Но :) Балансировка эта весьма условна, и может произвольно уплывать в любую сторону. Для поддержания заданного коэффициента нужно постоянно вмешиваться в процесс и вручную корректировать параметры.

Простой пример - добились вы 50/50, все работает. Тут у одного из магистралов падает один из аплинков - у вас мгновенно все разваливается, трафик бежит в виде 20/80 с перегрузкой и потерями во втором канале. Лезете, крутите, получаете 50/50. Первый аплинк чинится, и опять та же хрень, но уже в другую сторону - и так по кругу)

Share this post


Link to post
Share on other sites

more-specific не обязательно отпадать, на пару AS маршрут вполне может пройти, анонсить только /25 + /24 и route-object создать, ну а дальше действительно играть community, даже в короткой перспективе вполне решение, отслеживать разбаланс можно и автоматически

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this