Jump to content
Калькуляторы

Выделенные таблицы маршрутизации на оборудовании CISCO и динамическая маршрутизация

Собственно, маршрутизатор CISCO881-SEC-K9.

 

От оператора приходит провод со статическим IP-адресом:

interface FastEthernet4
ip address 192.0.2.146 255.255.255.192
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto

 

На адрес 192.0.2.146 маршрутизируется публичная подсеть 198.51.100.17/28:

interface Vlan1
ip address 198.51.100.17 255.255.255.240

 

Дополнительно заведена серая подсетка 192.168.255.0/26 для локальной сети:

interface Vlan2
ip address 192.168.255.5 255.255.255.192
ip nat inside
ip virtual-reassembly in

 

Подняты GRE-туннели до собственного дата-центра:

interface Tunnel1
ip address 203.0.113.213 255.255.255.254
tunnel source 192.0.2.146
tunnel destination 203.0.113.243
!
interface Tunnel2
ip address 203.0.113.215 255.255.255.254
tunnel source 192.0.2.146
tunnel destination 203.0.113.244

 

Заведён кусок собственной подсети 203.0.113.160/28 на маршрутизаторе:

interface Vlan4
ip address 203.0.113.161 255.255.255.240

 

Результирующие сети выплёвываются в три интерфейса:

interface FastEthernet1
description 198.51.100.16/28
switchport trunk allowed vlan 1-8,1002-1005
switchport mode trunk
no ip address
no cdp enable
!
interface FastEthernet2
description 192.168.255.0/26
switchport trunk native vlan 2
switchport trunk allowed vlan 1-8,1002-1005
switchport mode trunk
no ip address
!
interface FastEthernet3
description 203.0.113.160/28
switchport trunk native vlan 4
switchport trunk allowed vlan 1-8,1002-1005
switchport mode trunk
no ip address

Задача:

  1. Обеспечить динамическую маршрутизацию подсети 203.0.113.160/28 через Tunnel1 и Tunnel2, используя OSPF.
  2. Обеспечить работу подсетей 198.51.100.16/28 и 192.168.255.0/26 через шлюз провайдера 192.0.2.129.

 

Такое вообще реально?

Если да, то какими инструментами следует пользоваться?

Edited by korobeynikov

Share this post


Link to post
Share on other sites

Ну по идее, если поднять OSPF на тоннелях и после этого при помощи policy-routing зарулить трафик с 198.51.100.16/28 и 192.168.255.0/26 в интерфейс к оператору, то все должно заработать.

Share this post


Link to post
Share on other sites

Нахрен тут не нужен pbr.

ip vrf forwarding и т.п...

Edited by dsk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this