Jump to content
Калькуляторы

Проблема с пингом Mikrotik 951g не ходят icmp выше 35000байт

Mikrotuk 951g не проходят пинг пакеты выше 35000 байт не с ПК на микротик, не с микротика на ПК.

С lite 5 и omnitik таких проблем не было. В чем может быть проблема?

Владельцы гигабитного 951 проверьте у себя.

Скрин ниже одновременный пинг на две железки для сравнения.

thumb.png

Share this post


Link to post
Share on other sites

Переключите сетевой порт в 100 мегабит и проведите повторные измерения.

Share this post


Link to post
Share on other sites

Порт был подключен в 100мбит, отключил все остальные порты и выбрал вручную скорость, интересно, что пакеты до 30000байт ходят почти без потерь.

post-118711-091823800 1392283364_thumb.jpg

post-118711-035401400 1392283394_thumb.jpg

Edited by sanychel

Share this post


Link to post
Share on other sites

ping -n 1000 -l 35000 байт

80% потерь, потеряно 808 пакетов

ping -n 1000 -l 30000 байт

1% потерь, потеряно 18 пакетов

 

Этот же роутер, соеденение по WiFi.

ping -n 1000 -l 65000 байт

0% потерь, потеряно 0 пакетов

Share this post


Link to post
Share on other sites

Я конечно скажу глупость, и Вы конечно проверили, но если заменить провод?

Share this post


Link to post
Share on other sites

Проверил кабеля, пробовал крос, пробовал проверенный и теперь к сожалению убедился в кривизне железки.

Вообщем уделил время сей железке провел пару экспериментов.

Работает она в плане icmp пакетов криво к большому сожалению.

ping 65000 байт на микротик (nat или local bridge) проходит, если подключен 1гбит девайс.

ping 65000 байт на микротик (nat или local bridge) не проходит, если подключен 100мбит девайс.

 

ping 65000 байт на девайсы подключенные в local bridge порты проходит, между 100мбит девайсами, и 1гбит девайсами, и не проходит между 100мбит и 1гбит девайсами.

 

Пробовал все порты выкрутить в 100мбит, пинг проходит только между 100мбит устройствами в бридж портах, на сам микротик и за нат пигни 65000байт не проходят, неуверенно пролезают во все стороны пакеты 30000байт (при 1% потерь), чем больше вес icmp пакета тем больше потерь на 35000байт 80% потерь.

 

Для справки близнец 951Ui тоже в этом плане кривой но его максимум значительно выше до 58000байт.

 

Все это крайне печально учитывая, что Lite 5 600Мгц этим не страдают и 5 портовые близнецы на 400Мгц процессоре например Omnitik.

 

Похоже это уже непоправимо в этой серии.

Edited by sanychel

Share this post


Link to post
Share on other sites

Проверил кабеля, пробовал крос, пробовал проверенный и теперь к сожалению убедился в кривизне железки.

Вообщем уделил время сей железке провел пару экспериментов.

Работает она в плане icmp пакетов криво к большому сожалению.

ping 65000 байт на микротик (nat или local bridge) проходит, если подключен 1гбит девайс.

ping 65000 байт на микротик (nat или local bridge) не проходит, если подключен 100мбит девайс.

 

ping 65000 байт на девайсы подключенные в local bridge порты проходит, между 100мбит девайсами, и 1гбит девайсами, и не проходит между 100мбит и 1гбит девайсами.

 

Пробовал все порты выкрутить в 100мбит, пинг проходит только между 100мбит устройствами в бридж портах, на сам микротик и за нат пигни 65000байт не проходят, неуверенно пролезают во все стороны пакеты 30000байт (при 1% потерь), чем больше вес icmp пакета тем больше потерь на 35000байт 80% потерь.

 

Для справки близнец 951Ui тоже в этом плане кривой но его максимум значительно выше до 58000байт.

 

Все это крайне печально учитывая, что Lite 5 600Мгц этим не страдают и 5 портовые близнецы на 400Мгц процессоре например Omnitik.

 

Похоже это уже непоправимо в этой серии.

Какой смысл в пинговании такими размерами пакетов?

Share this post


Link to post
Share on other sites

Я не хочу обсуждать смысл. Я как минимум хотел бы получить ответ на вопрос, почему у микротика проблемы с большими icmp пакетами. Одно дело програмный дроп как например у некоторых дешевых Zyxel`ей и совсем другое потери выраженные в процентах.

Edited by sanychel

Share this post


Link to post
Share on other sites

Я не хочу обсуждать смысл. Я как минимум хотел бы получить ответ на вопрос, почему у микротика проблемы с большими icmp пакетами. Одно дело програмный дроп как например у некоторых дешевых Zyxel`ей и совсем другое потери выраженные в процентах.

 

Дожили. Теперь микротик пакеты теряет=) Интересно, почему у меня в цепочке, когда они друг за другом подключены витухой, половина линков в гиге, половина в 100, т.к. длина большая, без потерь проходят пинги пакетами 65535 байт?

 

mikrotik-65535.png

 

Вам просто нужно версию ПО поменять, и начальную конфигурацию сбросить для чистоты эксперимента.

Share this post


Link to post
Share on other sites

половина линков в гиге, половина в 100, т.к. длина большая, без потерь проходят пинги пакетами 65535 байт?

Проверьте пожалуйста ping между 100мбит и 1гбит устройствами, проверьте пинг 100мбитного девайса на микротик и обратно.

Проблема стоит именно в 100мбитном режиме.

P.S.: Написал письмо в тех поддержку.

Share this post


Link to post
Share on other sites

половина линков в гиге, половина в 100, т.к. длина большая, без потерь проходят пинги пакетами 65535 байт?

Проверьте пожалуйста ping между 100мбит и 1гбит устройствами, проверьте пинг 100мбитного девайса на микротик и обратно.

Проблема стоит именно в 100мбитном режиме.

P.S.: Написал письмо в тех поддержку.

 

Все нормально проходит. Вообще пинги пакетами большого размера используются для проверки правильности очередности пакетов, а не для проверки надежности каналов. С таким же успехом можно пинг 1500 байт с интервалом в 100 - 50 мс запустить.

 

Когда делаете тест, попробуйте все другие устройства от сети отключить. И если на бридже включен STP или RSTP его тоже отключить.

Share this post


Link to post
Share on other sites

Все нормально проходит.

Когда делаете тест, попробуйте все другие устройства от сети отключить. И если на бридже включен STP или RSTP его тоже отключить.

Значит мне попался дефектный роутер о микротика, спасибо Вам за советы, но по скрину видно, что я так уже пробовал.

post-118711-091823800 1392283364_thumb.jpg

Edited by sanychel

Share this post


Link to post
Share on other sites

Вообще пинги пакетами большого размера используются для проверки правильности очередности пакетов, а не для проверки надежности каналов. С таким же успехом можно пинг 1500 байт с интервалом в 100 - 50 мс запустить.

У меня всего 1 вопрос почему при пинге пакетом 35кбайт 80% потерь, почему не 0% или на худой конец 100%. У Вас во владениях есть именно 951G ? На других микротиках не 951 такой проблемы нет!!!!!

Edited by sanychel

Share this post


Link to post
Share on other sites

У вас же на скрине видны названия интерфейсов из дефолтного конфига, вы пробовали его сбрасывать и настраивать с нуля без свич чипа?

Share this post


Link to post
Share on other sites

Дефолтный конфиг не сбрасывал, только редактировал, удаляя бридж нат и т.д.

Сегодня вечером сброшу конфиг и отпишу.

Не совсем понял, что Вы имеете в виду под "настройкой без свич чипа" - без объединения интерфейсов!? Видимо имеется ввиду 1 порт в режиме switch-all-ports=no.

Edited by sanychel

Share this post


Link to post
Share on other sites

Дефолтный конфиг не сбрасывал, только редактировал, удаляя бридж нат и т.д.

Сегодня вечером сброшу конфиг и отпишу.

Не совсем понял, что Вы имеете в виду под "настройкой без свич чипа" - без объединения интерфейсов!? Видимо имеется ввиду 1 порт в режиме switch-all-ports=no.

 

Ну так все остальные порты настроены на 1 порт, их настройки изменяли? Уже не раз писал в других темах, что начальный конфиг нельзя редактировать, т.к. при этом почти 100 процентная вероятность словить глюки. Лучше потратить 1-2 дня на изучение вопроса, чем разбираться потом неделями, почему пинги не ходят или что-то где-то не работает.

Share this post


Link to post
Share on other sites

Сбросил натройки по дэфолту. "без свич чипа"

Задал только IP первому порту и ничччего не изменилось!?!?

post-118711-098165600 1392741980_thumb.jpg

Share this post


Link to post
Share on other sites

Обновить версию!Не?

Я ставил 6.9 , странно но изначально стояла версия 5.25 и вроде на верси 5.25 пинг был лучше, наверное стоит откатить и проверить еще раз!? Смущает то, что OmniTik на 6.1 работает отлично, поэтому откатил до 6.1. Проверил - На версии 5.26 и 6.9 тоже самое.

Народ! Есть у кого в наличии 951G для сравнения?

Edited by sanychel

Share this post


Link to post
Share on other sites

настраивать с нуля без свич чипа?

Оказывается в 951 бутербродах порт ether1 нельзя отвязать из группы swich1.

Саппорт мне так и не ответил..

Крайне неудачная и странная железка мне попалась...

post-118711-022304300 1392748307_thumb.jpg

Share this post


Link to post
Share on other sites

настраивать с нуля без свич чипа?

Оказывается в 951 бутербродах порт ether1 нельзя отвязать из группы swich1.

Саппорт мне так и не ответил..

Крайне неудачная и странная железка мне попалась...

 

Что бы отключить, достаточно на порту Ether1 в пункте master port поставить - none.

Share this post


Link to post
Share on other sites

При сбросе это выполняется. У Вас есть 951?

 

Есть конечно, много, никаких проблем с пингами не замечено.

Share this post


Link to post
Share on other sites

И в гигабитные порты 951 есть подключенные 100мбитные устройства (без промежуточного свича)?

Share this post


Link to post
Share on other sites

И в гигабитные порты 951 есть подключенные 100мбитные устройства (без промежуточного свича)?

 

Да там почти все соединения на 100мбит.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this