Jump to content
Калькуляторы

Настройка мультикаста на оборудование Cisco IPTV от провайдера

Провайдер предоставляет услугу IPTV посредством мультикаста.

К абонентской линии подключен маршрутизатор Cisco 881, за которым публичная и локальная подсеть.

Задача: чтобы пользователь на ПК открыв VLC-плеер и вбив туда адрес типа udp://@239.1.10.69:1234 смог наслаждаться просмотром эфира.

 

Пробую следующий код:

!
ip multicast-routing
!
bridge irb
!
!
!
!
interface FastEthernet0
description Public LAN
switchport trunk allowed vlan 1-3,1002-1005
switchport mode trunk
no ip address
no cdp enable
!
interface FastEthernet1
description Private LAN
switchport trunk native vlan 2
switchport trunk allowed vlan 1-3,1002-1005
switchport mode trunk
no ip address
!
interface FastEthernet4
description ISP
ip address dhcp
ip pim sparse-mode
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 198.51.100.17 255.255.255.240
ip pim sparse-mode
!
interface Vlan2
ip address 192.168.255.5 255.255.255.192
ip pim sparse-mode
ip nat inside
ip virtual-reassembly in
!

 

Но он не работает. Кто смог настроить?

Share this post


Link to post
Share on other sites

А с чего бы ему работать?

Нужен в первую очередь igmp-snooping либо mvr. multicast-routing скорее всего не нужен.

Настройка зависит от того, как именно провайдер доставляет мультикаст. Вопрос по настройке нужно адресовать в первую очередь провайдеру.

Share this post


Link to post
Share on other sites

Получилось. Основные моменты:

interface FastEthernet4
description ISP
ip address dhcp
ip pim sparse-dense-mode
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 198.51.100.17 255.255.255.240
ip pim sparse-mode
ip igmp helper-address 192.0.2.129
!
interface Vlan2
ip address 192.168.255.5 255.255.255.192
ip pim sparse-mode
ip igmp helper-address 192.0.2.129
ip nat inside
ip virtual-reassembly in
!

192.0.2.129 — IP-адрес шлюза для интернета, выданный провайдером по DHCP вместе с DNS и прочим.

 

Осталось выяснить как работает ip igmp snooping.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this