Jump to content
Калькуляторы

Mikrotik NAT в Bridge

Помогите, что делаю не так?

На компьютере нет пинга...

 

post-111351-039308900 1391659540_thumb.jpg post-111351-000071200 1391659547_thumb.jpg

 

[admin@MikroTik] > /export compact
# jan/02/1970 00:18:14 by RouterOS 6.3
# software id = 41CT-0L4U
#
/interface bridge
add l2mtu=1598 name=bridge-local protocol-mode=rstp
/interface ethernet
set 0 comment=WAN mac-address=00:02:хх:хх:08:02 name=ether1-gateway
set 1 comment=LAN-HDS
/interface pptp-client
add add-default-route=yes connect-to=10.255.0.2 disabled=no max-mru=1460 max-mtu=1460 name=pptp-hds password=*** user=***
/ip neighbor discovery
set ether1-gateway comment=WAN
set ether2 comment=LAN-HDS
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk group-ciphers=tkip,aes-ccm mode=dynamic-keys unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=43EE02DD61A5 wpa2-pre-shared-key=43EE02DD61A5
add authentication-types=wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm management-protection=allowed mode=dynamic-keys name=profile1 supplicant-identity="" unicast-ciphers=tkip,aes-ccm \
wpa-pre-shared-key=*** wpa2-pre-shared-key=***
/interface wireless
set 0 band=2ghz-b/g/n channel-width=20/40mhz-ht-above default-authentication=no disabled=no distance=indoors frequency=2222 frequency-mode=superchannel ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=\
ap-bridge periodic-calibration=enabled security-profile=profile1 wireless-protocol=802.11
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/ip pool
add name=dhcp_pool1 ranges=192.168.88.250-192.168.88.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge-local name=dhcp1
/queue simple
add max-limit=2M/2M name=queue1 target=ether3
/queue type
add kind=pcq name=PCQ-Download pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-src-address6-mask=64
add kind=pcq name=PCQ-Upload pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-src-address6-mask=64
/queue simple
add disabled=yes max-limit=100M/100M name=Limit-all queue=PCQ-Upload/PCQ-Download target=bridge-local
/interface bridge port
add bridge=bridge-local interface=ether2
add bridge=bridge-local interface=wlan1
/interface pptp-server server
set authentication=pap,chap,mschap1,mschap2 mrru=1600
/interface sstp-server server
set enabled=yes
/ip address
add address=192.168.88.1/24 interface=wlan1 network=192.168.88.0
add address=192.168.88.1/24 interface=bridge-local network=192.168.88.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether1-gateway
/ip dhcp-server network
add address=192.168.88.0/24 gateway=192.168.88.1 netmask=24
/ip dns
set allow-remote-requests=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface=bridge-local to-addresses=0.0.0.0
add action=dst-nat chain=dstnat dst-port=7001 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.254 to-ports=7001
add action=dst-nat chain=dstnat dst-port=7001 in-interface=ether1-gateway protocol=udp to-addresses=192.168.88.254 to-ports=7001
add action=dst-nat chain=dstnat dst-port=16196 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.254 to-ports=16196
add action=dst-nat chain=dstnat dst-port=16196 in-interface=ether1-gateway protocol=udp to-addresses=192.168.88.254 to-ports=16196
add action=dst-nat chain=dstnat dst-port=2302 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.254 to-ports=2302
add chain=dstnat dst-port=1723 protocol=tcp to-addresses=192.168.88.3 to-ports=0-65535
add chain=dstnat protocol=gre
/ip proxy
set enabled=yes
/ip route
add distance=1 gateway=10.100.25.1
add distance=1 dst-address=10.0.0.0/8 gateway=10.100.25.1
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=bridge-local type=internal
add interface=ether1-gateway type=external
/system leds
set 0 interface=wlan1
/tool graphing interface
add
/tool graphing queue
add
/tool graphing resource
add
[admin@MikroTik] > 

Edited by Vitokhv

Share this post


Link to post
Share on other sites

Нужно подключиться к VPN провайдера на адрес 10.255.0.2 (не получается раскинуть NAT на порт в бридже, не пингуется на компьютере)

 

Сеть:

IP 10.100.25.14

MASK 255.255.252.0

GATEWAY 10.100.25.1

DNS 10.255.0.22

DNS 10.255.0.1

 

ROUTE 10.0.0.0 mask 255.0.0.0

ROUTE 46.8.128.0 mask 255.255.128.0

ROUTE 94.25.108.0 mask 255.255.255.0

ROUTE 92.50.243.0 mask 255.255.255.0

 

Доступ по MAC адресу: 00:02:хх:хх:08:02

Edited by Vitokhv

Share this post


Link to post
Share on other sites

Помогите, что делаю не так?

На компьютере нет пинга...

 

/ip address
#add address=192.168.88.1/24 interface=wlan1 network=192.168.88.0 <- Вот это уберите, так как этот порт в бридже.
add address=192.168.88.1/24 interface=bridge-local network=192.168.88.0

 

/ip firewall nat
add action=masquerade chain=srcnat out-interface=bridge-local to-addresses=0.0.0.0
add action=dst-nat chain=dstnat dst-port=7001 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.254 to-ports=7001
add action=dst-nat chain=dstnat dst-port=7001 in-interface=ether1-gateway protocol=udp to-addresses=192.168.88.254 to-ports=7001
add action=dst-nat chain=dstnat dst-port=16196 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.254 to-ports=16196
add action=dst-nat chain=dstnat dst-port=16196 in-interface=ether1-gateway protocol=udp to-addresses=192.168.88.254 to-ports=16196
add action=dst-nat chain=dstnat dst-port=2302 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.254 to-ports=2302
add chain=dstnat dst-port=1723 protocol=tcp to-addresses=192.168.88.3 to-ports=0-65535
add chain=dstnat protocol=gre

 

А вот что из этого маскарад в инет???? должно быть чтото типа:

add action=masquerade chain=srcnat out-interface=pptp-hds src-addresses=192.168.88.0/24

Share this post


Link to post
Share on other sites

Не получается :(

Отличный ответ. Что именно не получаеться?

 

1) с микротика пинги идут?

2) с компов микротик пингуеться? (компы я так понимаю подключены только в ether2 и wlan, судя по составу бриджа)

3) Вот это вот в нате нафига?

add action=dst-nat chain=dstnat dst-port=7001 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.254 to-ports=7001
add action=dst-nat chain=dstnat dst-port=7001 in-interface=ether1-gateway protocol=udp to-addresses=192.168.88.254 to-ports=7001
add action=dst-nat chain=dstnat dst-port=16196 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.254 to-ports=16196
add action=dst-nat chain=dstnat dst-port=16196 in-interface=ether1-gateway protocol=udp to-addresses=192.168.88.254 to-ports=16196
add action=dst-nat chain=dstnat dst-port=2302 in-interface=ether1-gateway protocol=tcp to-addresses=192.168.88.254 to-ports=2302
add chain=dstnat dst-port=1723 protocol=tcp to-addresses=192.168.88.3 to-ports=0-65535
add chain=dstnat protocol=gre

Если не знаете лучше уберите.

4) Вот это нафига?

/ip proxy
set enabled=yes

Выключите.

5) вот это что?

/ip route
add distance=1 gateway=10.100.25.1
add distance=1 dst-address=10.0.0.0/8 gateway=10.100.25.1

Тоже наверно выключить, первая строчка так точно не нужна.

6) днсы он получил нормально? пропишите на всякий случай нормальные

/ip dns
set allow-remote-requests=yes servers=208.67.222.222,208.67.220.220

7)Правда к основной проблеме отношения вообще не имеет но должно быть так:

/ip upnp interfaces
add interface=bridge-local type=internal
add interface=ether1-gateway type=external
add interface=pptp-hds type=external

 

8) правила NAT должны выглядеть примерно так:

/ip firewall nat
add action=masquerade chain=srcnat out-interface=pptp-hds src-address=192.168.88.0/24
add action=masquerade chain=srcnat out-interface=ether1-gateway src-address=192.168.88.0/24

Первый для интета, второй для локальных ресурсов провайдера. И больше ничего там быть не должно.

 

9) на всякий добавте днс вот сюда:

 /ip dhcp-server network
add address=192.168.88.0/24 dns-server=192.168.88.1 gateway=192.168.88.1  netmask=24

 

И напишите заново экспорт сюда, у меня ощущение что Вы, что то не так сделали, из того что я говорил.

Настройка то простейшая, должно работать с пол тычка.

Кстсти фаервол выключен (в конфиге про него ни слова)?

Edited by Ermak_

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this