Jump to content
Калькуляторы

IPTV (PIM+IGMP) на Cisco 6509

Здравствуйте.

Есть у меня мультикаст, который приходит на Cisco6509.

 

Вот такой.

interface Vlan136
description MULT_SOURCE
ip address 10.200.200.130 255.255.255.252
ip pim sparse-mode
end
!
ip multicast-routing
!
ip route 10.0.200.200 255.255.255.255 10.200.200.129
!
ip pim rp-address 10.0.200.200

 

10.0.200.200 Это точка рандеву с поставщиком мультикаста.

 

Есть у меня телеста, на которую нужно отдать мультикаст.

Делаю вот так:

!
interface Vlan1953
ip address 10.212.212.1 255.255.255.0
ip pim sparse-mode
end

 

Когда я на vlan1953 пишу ip pim sparse-mode, то на телесту приоходит мультикаст, она видит iptv, но нагрузка на кошку 99%.

И в логах вот такая надпись:

%PIM-5-DRCHG: DR change from neighbor 0.0.0.0 to 10.212.212.1 on interface Vlan1953

 

Вот нагрузка CPU:

cisco6509#show processes cpu sorted
CPU utilization for five seconds: 98%/77%; one minute: 44%; five minutes: 49%
PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
277     3424676   3537649        968 11.91%  3.72%  3.52%   0 IP Input
 12     2605560   2027267       1285  4.47%  4.30%  4.49%   0 ARP Input
358      229852     70548       3258  0.87%  0.90%  0.89%   0 CEF: IPv4 proces
579       60708     55422       1095  0.79%  3.75%  7.47%   1 Virtual Exec
346       94148     17832       5279  0.63%  0.37%  0.36%   0 IPC LC Message H
562      291176    250609       1161  0.47%  0.44%  0.47%   0 DHCPD Receive
506      235324    345074        681  0.31%  0.29%  0.31%   0 Port manager per
220       72440     15225       4757  0.31%  0.28%  0.26%   0 Compute load avg
279      124596    323838        384  0.23%  0.19%  0.21%   0 ADJ resolve proc
301       37916   2596678         14  0.23%  0.20%  0.21%   0 Ethernet Msec Ti
 65       89012   3523372         25  0.23%  0.24%  0.23%   0 Net Input
 52       49396     33246       1485  0.15%  0.16%  0.15%   0 Per-Second Jobs

 

Подскажите где я не прав и как убрать нагрузку с кошки?

Edited by serg_sk

Share this post


Link to post
Share on other sites

Хм. Оказалось все просто.

Сделал

ip mroute 0.0.0.0 0.0.0.0 10.0.200.200

И нагрузка упала.

 

Теперь второй вопрос.

Есть юзерский влан, в него нужно тоже отдать мультикаст.

interface Vlan999
description User
ip unnumbered Loopback13
ip helper-address 172.16.21.124
ip flow ingress
ip pim sparse-mode
end
!
!
interface Loopback13
ip address 10.yy.166.1 255.255.255.0 secondary
ip address xx.yy.166.1 255.255.255.0
no ip redirects
ip pim sparse-mode
end
!

Дальше этот влан уходит с кошки транком на управлялки и к юзерам.

Везде в этом влане igmp snooping выключен, но у юзера vlc не кажет.

Где я тут туплю? :)

Share this post


Link to post
Share on other sites

Действительно туплю я. Все работает. Однако за роутером Apple Airport Extreme(3 Generation) не хочет.

 

Тему можно закрывать.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this