Jump to content
Калькуляторы

Mikrotik VPN поверх PPoE

Всем добрый день!

Имеются роутер Mikrotik 750GL, подключенный к оператору по PPPoE. Интернет работает, все отлично.

Требуется на этом же роутере поднять VPN соединение до VPN сервера, и уже его раздавать в порты роутера.

Что я делаю.

Создаю в PPP клиентский интерфейс pptp-out, ввожу адрес VPN сервера, логин, пароль, тип шифрования, ставлю галку Add default route.

В итоге в логе пишет pptp-out: weiting for packets.

На этом все...

Подскажите, что делаю не так или недоделываю.

post-118126-052078300 1390123836_thumb.jpg

Edited by Akor4eg

Share this post


Link to post
Share on other sites

Значит что-то не так настроили, да и версию ПО необходимо обновить.

 

Если начальную конфигурацию не сбрасывали, то работать не будет, потому что изначально заблокирован доступ извне на устройство, зайдите в IP-Firewall и уберите все запрещающие правила, или добавьте разрешения для pptp.

Share this post


Link to post
Share on other sites

потому что изначально заблокирован доступ извне на устройство, зайдите в IP-Firewall и уберите все запрещающие правила, или добавьте разрешения для pptp.

Я же не к нему собираюсь подключаться, а им подключаюсь к pptp серверу. Отключение запрещающих правил, соответсвенно, не помогает.

 

И если после этого маршрутизатора, подключающегося к оператору по PPPoE, поставить еще один, например zyxel keenetic, и на нем поднять pptp к требуемому серверу, то он за милу душу подключается. А вот с Mikrotik'ом никак.

 

Я прекрасно понимаю, что задача элементарнейшая. Любой, человек, работающий с сетевым оборудованием решает ее за 1 минуту, и читая этот пост, просто ржет на идиотами, у которых это не получается.

Вам что трудно написать 1 строчку текста?

Share this post


Link to post
Share on other sites

Я же не к нему собираюсь подключаться, а им подключаюсь к pptp серверу. Отключение запрещающих правил, соответсвенно, не помогает.

 

И если после этого маршрутизатора, подключающегося к оператору по PPPoE, поставить еще один, например zyxel keenetic, и на нем поднять pptp к требуемому серверу, то он за милу душу подключается. А вот с Mikrotik'ом никак.

 

Я прекрасно понимаю, что задача элементарнейшая. Любой, человек, работающий с сетевым оборудованием решает ее за 1 минуту, и читая этот пост, просто ржет на идиотами, у которых это не получается.

Вам что трудно написать 1 строчку текста?

 

1. Создаете маршрут на 0.0.0.0/0 указав IP адрес сервера, по которому идет обмен данными PPTP, указываете маркировку маршрута, например test.

2. в Mangle создаете правило, где указываете src.address=вашей внутренней сети абонентов, а dst.address=! вашей внутренней сети абонентов, и действие - маркировка пакета test.

 

После этого все запросы от абонентов пойдут по туннелю, а не будут сливаться в интернет по подключению PPPoE.

Share this post


Link to post
Share on other sites

Все сделал.

Пока не работает.

pptp так и не хочет подключаться. И vpn сервер не видит попыток подключения.

Запрещающей правила отключать пробовал. Не помогает.

Share this post


Link to post
Share on other sites

поднимал l2tp over ppp(2G/3G) на микротике - всё ок

 

включайте дебаг логи и смотрите в чём дело

Share this post


Link to post
Share on other sites

В итоге в логе пишет pptp-out: weiting for packets.

и Еще такая картинка есть, где на интерфейсе pptp-out непонятные адреса.

post-118126-044685900 1391150742_thumb.jpg

Edited by Akor4eg

Share this post


Link to post
Share on other sites

Это вы Saab95 спрашивайте, это он пяткой грудь бьет про полезность Микротиков.

Share this post


Link to post
Share on other sites

Получилось соединиться с внешним PPTP сервером. Но сразу после подключения PPTP передача трафика останавливается.

Default Route ставил - не помогает.

Может надо как-то NAT поднастроить?

Share this post


Link to post
Share on other sites

Получилось соединиться с внешним PPTP сервером. Но сразу после подключения PPTP передача трафика останавливается.

Default Route ставил - не помогает.

Может надо как-то NAT поднастроить?

 

У вас передача трафика в интернет останавливалась? А на сам PPTP сервер могли попасть? Нужно просто тот адрес, что выдается клиенту, добавить в НАТ что бы он его тоже в интернет пускал.

Share this post


Link to post
Share on other sites

Получилось соединиться с внешним PPTP сервером. Но сразу после подключения PPTP передача трафика останавливается.

Default Route ставил - не помогает.

Может надо как-то NAT поднастроить?

Куда трафик не идет-то? с микротика сам сервер пингуется? а хосты за ним? а изнутри сети сервер и хосты за ним?

Может и нат донастроить надо - вы покажите сначала как он настроен-то...

Share this post


Link to post
Share on other sites

Формулировка проблемы и траблшутинг описыватся как "у меня кое-что работало, кое-что нет, я что-то сделал, и вроде заработало, но не совсем". Без кусков конфига тут понять что-либо нереально.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this