Jump to content
Калькуляторы

QinQ cisco 3750 проблема в настройке

Пытаемся настроить QinQ между двумя cisco 3750. Перерыли кучу статей..

соединены медным патчкордом

вот конфиг

catalyst 1

Building configuration...

Current configuration : 16577 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service unsupported-transceiver
!
hostname c3750
!
boot-start-marker
boot-end-marker
!

!
no aaa new-model
switch 1 provision ws-c3750g-12s
system mtu routing 1500
vtp domain xxi
vtp mode transparent
ip routing
ip dhcp relay information trust-all
!
!
ip multicast-routing distributed
!
!
no errdisable detect cause gbic-invalid
no errdisable detect cause sfp-config-mismatch
errdisable recovery cause sfp-config-mismatch
!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 1-4094
!
vlan internal allocation policy ascending
!
vlan 2-19,22-24,888
!
!
!
interface GigabitEthernet1/0/7
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-19,22-24
switchport mode trunk
switchport nonegotiate
no cdp enable
no cdp tlv server-location
no cdp tlv app
!
interface GigabitEthernet1/0/8
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4,23
switchport mode trunk
switchport nonegotiate
no cdp enable
no cdp tlv server-location
no cdp tlv app
!
interface GigabitEthernet1/0/10
description QinQ
switchport access vlan 888
switchport mode dot1q-tunnel
switchport nonegotiate
no cdp enable
no cdp tlv server-location
no cdp tlv app
!
interface Vlan888
ip address 10.21.80.1 255.255.255.0
---skip---

catalyst 2

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
switch 1 provision ws-c3750g-24t
system mtu routing 1500
ip routing
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1-4094
!
vlan internal allocation policy ascending
vlan dot1q tag native
!
!
interface GigabitEthernet1/0/3
switchport access vlan 23
switchport mode access
!
interface GigabitEthernet1/0/23
description QinQ
switchport access vlan 888
switchport mode dot1q-tunnel
switchport nonegotiate
speed 1000
no mdix auto
no cdp enable
!
interface GigabitEthernet1/0/24
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4,23
switchport mode trunk
no cdp enable
!
interface Vlan1
no ip address
!
interface Vlan4
no ip address
!
interface Vlan23
ip address 192.168.17.8 255.255.255.0
!
interface Vlan888
ip address 10.21.80.2 255.255.255.0
---skip---

 

на обеих цисках MTU

sh sys mtu

System MTU size is 1546 bytes
System Jumbo MTU size is 9000 bytes
System Alternate MTU size is 1546 bytes
Routing MTU size is 1500 bytes

в транспортном влане(888) связь есть с первой циски 10.21.80.2 пингуется, а остальные vlan 4,23 не проходят.

что может быть не так ?

Edited by Serg_xxi

Share this post


Link to post
Share on other sites

Вы хотите принять трафик в 4 влане, накинуть на него 888 и отправить соседу? Если да, то Вы не правильно поняли принцип.

Верхний тег накидывается на ingress порту и уходит в транк с этом влане. И наоборот, прилетает с двумя тегами и на egress снимает верхний тег.

Т.е. на железке с куинку Вы не увидите внутренние теги.

Edited by lejek

Share this post


Link to post
Share on other sites

Спасибо, разобрались. Сам принцип работы изначально не правильно поняли ).

Share this post


Link to post
Share on other sites

Вы хотите принять трафик в 4 влане, накинуть на него 888 и отправить соседу? Если да, то Вы не правильно поняли принцип.

Верхний тег накидывается на ingress порту и уходит в транк с этом влане. И наоборот, прилетает с двумя тегами и на egress снимает верхний тег.

Т.е. на железке с куинку Вы не увидите внутренние теги.

 

Скажите, это значит что ограничение в 1005 активных вланов не распространяются на эту железку ? При такой схеме ?

Share this post


Link to post
Share on other sites

Железка со "switchport mode dot1q-tunnel" оперирует только внешними тегами, поэтому не распространяется.

Share this post


Link to post
Share on other sites

Подскажите пжл,

1. какое кол-во вланов сможет "проглатить" данная железка. Т.е. сколько можно запихнуть в dot1q tunnel ?

2. какое колличество пользователей (если отталкиваться от схемы vlan-per-costumer) можно прогнать через ip unnumbared ?

 

В данной железке ?

Share this post


Link to post
Share on other sites

Подскажите пжл,

1. какое кол-во вланов сможет "проглатить" данная железка. Т.е. сколько можно запихнуть в dot1q tunnel ?

2. какое колличество пользователей (если отталкиваться от схемы vlan-per-costumer) можно прогнать через ip unnumbared ?

 

В данной железке ?

 

1. На 3560G я когда-то засовывал одну-две тысячи inner'ов в каждый из нескольких outer'ов. Не помню, чтобы кто-то жаловался :) 3560 не сильно отличается фичами от 3750. Вообще, мне кажется число inner'ов не ограничено.

 

2. Если хотите терминировать на 3750, то судя по докам 3750 умеет 1000 vlan-интерфейсов, получается на VPU тысячу хомячков должна съесть. Если делать vlan per switch (+traffic segmentation), должна есть больше, пока не упрется в нехватку ТСАМ (погуглите "SDM profile"). Если хотите терминировать на отдельном брасе - см. п. 1 ;)

 

Лучше всего все самим протестировать генератором трафика (ixia, spirent).

Share this post


Link to post
Share on other sites

Эх, зря писал.

Share this post


Link to post
Share on other sites

Да нет, все равно спс. Есть теперь с чем сравнивать ))

Share this post


Link to post
Share on other sites

ТОка уточню пожалуй: SNR s3750g-24s ))

В данной железке нет ip unnumbered. Есть унылый SuperVLAN, в который, насколько я помню, больше 127 subvlan не засунуть. А при схеме vlan-per-switch или больше начнутся проблемы с неконтролируемым arp polling'ом, который там практически не конфигурируется (таймеры, пороги и тд).

На счет dot1q-tunnel не вижу каких-то ограничений. На счет схемы с Selective QinQ были темы в персонально разделе, что у SNR кончается TCAM, но на других DCN я такого не встречал. Еще был баг с хождением ARP в схеме с Selective, тема тоже есть.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this