Jump to content
Калькуляторы

Порезать танчики (WOT)

Подскажите, как грамотно через скрипт по шедулеру в определенное время резать доступ к танкам? Создать правило - могу, но там десятки серверов - можно как-то раз вбить в список и использовать в дальнейшем?

 

update

Вот решение, если кому надо:

/ip firewall address-list
add address=213.252.176.0/24 list=WoT_servers
add address=213.252.177.0/24 list=WoT_servers
add address=213.252.178.0/25 list=WoT_servers
add address=213.252.131.0/24 list=WoT_servers
add address=185.12.240.0/23 list=WoT_servers
add address=92.223.0.0/22 list=WoT_servers
add address=94.198.55.0/24 list=WoT_servers
add address=178.20.235.0/24 list=WoT_servers
add address=193.110.91.0/24 list=WoT_servers
add address=62.115.254.0/24 list=WoT_servers
add address=188.127.241.0/24 list=WoT_servers
add address=92.223.4.0/22 list=WoT_servers
add address=92.223.8.0/21 list=WoT_servers
add address=209.170.73.0/24 list=WoT_servers
add address=162.213.60.0/22 list=WoT_servers
add address=162.216.228.0/22 list=WoT_servers
add address=211.100.96.64/26 list=WoT_servers
add address=42.62.8.192/26 list=WoT_servers
add address=221.192.143.128/25 list=WoT_servers
add address=114.80.73.0/24 list=WoT_servers
add address=61.188.177.0/25 list=WoT_servers
add address=183.61.253.0/25 list=WoT_servers
add address=117.103.201.0/25 list=WoT_servers
add address=121.78.67.0/24 list=WoT_servers
add address=92.223.16.0/22 list=WoT_servers
add address=178.172.239.0/24 list=WoT_servers


/ip firewall filter
add action=drop chain=forward comment=WoT dst-address-list=WoT_servers src-address=192.168.122.0/24 src-address-list=""

Edited by vnkorol

Share this post


Link to post
Share on other sites

Добавлю - можно ли закрывать по доменному имени а не айпи?

Share this post


Link to post
Share on other sites

а разве танчики не на конкретном порте сидят?

с оффорума:

Для WorldOfTanks.exe необходимо открыть порты UDP диапазон с 32800 по 32900 и UDP диапазон с 20010 по 20020

Для WOTLauncher.exe и WorldOfTanks.exe TCP 3128, 8081, 8088, 53, 3128, 80, 8080, диапазон с 20000 по 25000, 32801, 32803, 443.

Для работы голосового чата, так же необходимо для WorldOfTanks.exe открыть порты UDP диапазон с 12000 по 29999, 5060, 5062, 3478, 3479, 3432, 30443.

443, 80, 8080 и другие мелкопоместные лучше не трогать, остальные заблокировать.

 

Можно заблокировать конкретные IP, можно блокировать через прокси URL танков (список имен серверов авторизации).

 

Добавлю - можно ли закрывать по доменному имени а не айпи?

можно, средствами /ip web proxy

Edited by ChargeSet

Share this post


Link to post
Share on other sites

Эти танчики не хуже скайпа, блин... Почитав ссылки, сделал пока вот так. Вроде, не подключаются...

 

/ip firewall address-list
add address=188.127.241.0/24 comment=RU6 list=WoT_servers
add address=185.12.241.0/24 comment=RU7 list=WoT_servers
add address=94.198.55.0/24 comment=RU5 list=WoT_servers
add address=193.110.91.0/24 comment=RU4 list=WoT_servers
add address=213.252.177.0/24 comment=RU3 list=WoT_servers
add address=178.20.235.0/24 comment=RU1-RU2 list=WoT_servers
add address=92.223.8.0/24 comment=AUSTRALIA list=WoT_servers

/ip firewall filter
add action=drop chain=forward comment=WoT dst-address-list=WoT_servers src-address=192.168.122.0/24 src-address-list=""

 

Может, что не правильно принципиально у меня?

Share this post


Link to post
Share on other sites

Может, что не правильно принципиально у меня?

 

Создайте L7 фильтр по слову "worldoftanks" и все проблемы уйдут.

Share this post


Link to post
Share on other sites

vnkorol, у вас не все адреса.

 

Текущие ipv4 диапазоны всех серверов wargaming.net

 

ip4:213.252.176.0/24

ip4:213.252.177.0/24

ip4:213.252.178.0/25

ip4:213.252.131.0/24

ip4:185.12.240.0/23

ip4:92.223.0.0/22

ip4:94.198.55.0/24

ip4:178.20.235.0/24

ip4:193.110.91.0/24

ip4:62.115.254.0/24

ip4:188.127.241.0/24

ip4:92.223.4.0/22

ip4:92.223.8.0/21

ip4:209.170.73.0/24

ip4:162.213.60.0/22

ip4:162.216.228.0/22

ip4:211.100.96.64/26

ip4:42.62.8.192/26

ip4:221.192.143.128/25

ip4:114.80.73.0/24

ip4:61.188.177.0/25

ip4:183.61.253.0/25

ip4:117.103.201.0/25

ip4:121.78.67.0/24

ip4:92.223.16.0/22

ip4:178.172.239.0/24

Edited by wmdumb

Share this post


Link to post
Share on other sites

а /24 - не перебор? :)

 

хз, больше - не меньше :)

vnkorol, у вас не все адреса.

 

Текущие ipv4 диапазоны всех серверов wargaming.net

...

 

Большое спасибо!

 

Создайте L7 фильтр по слову "worldoftanks" и все проблемы уйдут.

 

Попробую, конечно, но мне как-то не до конца ясен принцип его работы. Пойду еще погуглю...

Share this post


Link to post
Share on other sites

Создайте L7 фильтр по слову "worldoftanks" и все проблемы уйдут.

 

Попробую, конечно, но мне как-то не до конца ясен принцип его работы. Пойду еще погуглю...

 

Принцип простой, микротик смотрит все проходящие пакеты на наличие этих строчек, если находит то можно его дропнуть как вариант=) обычно таким способом доступ к сайтам закрывают по доменному имени.

Share this post


Link to post
Share on other sites

[admin@MikroTik-ural] /ip firewall layer7-protocol> print
# NAME                                                                                              REGEXP                                                                                            
0 wot                                                                                               worldoftanks        

 

не отрабатывает

Share this post


Link to post
Share on other sites

[admin@MikroTik-ural] /ip firewall layer7-protocol> print
# NAME                                                                                              REGEXP                                                                                            
0 wot                                                                                       		worldoftanks        

 

не отрабатывает

 

Вот как надо:

 

/ip firewall filter

add action=reject chain=forward content=worldoftanks protocol=tcp src-address=192.168.0.0/16

 

Естественно протокол TCP/UDP и адреса клиентов, которых фильтровать, поставите по вкусу. Вводите интересующую строчку в поле CONTENT а не REGEXP.

Share this post


Link to post
Share on other sites

Подскажите, как грамотно через скрипт по шедулеру в определенное время резать доступ к танкам? Создать правило - могу, но там десятки серверов - можно как-то раз вбить в список и использовать в дальнейшем?

 

Тогда вопрос на засыпку.

Траву готовить закрыли,взрывать закрывают, торенды режут, добрались до танчиков.

Тогда в сети надо написать, уважаемый клиент, х@ й тебе не интернет,

а погоду на завтра узнаешь после завтра......

Зачем в обще интернетом заниматься?

Share this post


Link to post
Share on other sites

sokratТогда вопрос на засыпку.

Траву готовить закрыли,взрывать закрывают, торенды режут, добрались до танчиков.

Тогда в сети надо написать, уважаемый клиент, х@ й тебе не интернет,

а погоду на завтра узнаешь после завтра......

Зачем в обще интернетом заниматься?

Дык, это ж не технари продают инет, а тупые "продаваны", считающие каждый килобит, думающие, что продают народу нечто архиважное, под названием "интернет", а на деле всего лишь пропускную способность своей сраной сети... которую жопят повысить в плане упадка "моржи", отсюда и хитрят всевозможными способами за счет технарей.

Как то так...

Edited by Vladish

Share this post


Link to post
Share on other sites

Тогда вопрос на засыпку.

Траву готовить закрыли,взрывать закрывают, торенды режут, добрались до танчиков.

Тогда в сети надо написать, уважаемый клиент, х@ й тебе не интернет,

а погоду на завтра узнаешь после завтра......

Зачем в обще интернетом заниматься?

 

Дык я это, ребенку своему ограничиваю, чтобы учебой занимался, а не гонял целыми днями...

Share this post


Link to post
Share on other sites

Saab95 Я не пойму всё же в л7 или в простом фильтре рекомендуете делать?

Share this post


Link to post
Share on other sites

vnkorol, в простом, в L7 регулярки вроде бы только делают.

Я в простом некоторые сайты отлично дропаю.

Edited by SOFTOLAB

Share this post


Link to post
Share on other sites

Saab95 Я не пойму всё же в л7 или в простом фильтре рекомендуете делать?

 

Так попробуйте что удобнее. L7 фильтр работает медленнее, если с ним загрузка процессора не поднимается сильно, можно его и использовать, если при большом трафике появляются проблемы, тогда нужно искать решения обычными фильтрами.

Share this post


Link to post
Share on other sites

vnkorol, в простом, в L7 регулярки вроде бы только делают.

Я в простом некоторые сайты отлично дропаю.

 

по строке content?

Share this post


Link to post
Share on other sites

vnkorol, да. Сбрасываю соединение с сайтом провайдера в сети своих абонентов, что бы они в учетку мою не заходили (да да, провайдер пускает сразу и без вопросов если заходить со своего подключения), все прекрасно режется.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this