Jump to content
Калькуляторы

Cat4900M и VLAN mapping

Всем добрый день.

 

Жил себе спокойно в центре некоей "звезды" Cisco C4900M, IOS 12.2(54)SG1 ENTSERVICESK9-M, агрегировал IP-трафик с более мелких узлов. Примерно так,как на первой схеме.

post-5155-098172000 1387377491_thumb.gif

И тут понадобилось некоторые из этих P2P линков (от одного до шести-семи) протащить через двухпортовую 10Gbps сетевую карту некоего сервера без применения дополнительных промежуточных коммутаторов. Примерно как на второй схеме. Сервер для транзитного трафика вроде как прозрачен, т.е. ни на L2, ни на L3 не светится.

post-5155-086220700 1387377806_thumb.gif

Как это сделать? Один любой линк в untagged-режиме протаскивается без проблем:

4900M#show run inter te1/1
Building configuration...
!
interface TenGigabitEthernet1/1
switchport access vlan 10
switchport mode access
load-interval 30
spanning-tree portfast
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
end

4900M#show run inter te1/2
Building configuration...
!
interface TenGigabitEthernet1/2
switchport access vlan 110
switchport mode access
load-interval 30
spanning-tree portfast
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
end

4900M#

Конфигурация SVI c VLAN10 просто переносится в некий промежуточный VLAN110 с сохранением всех настроек (IP, OSPF итп.), удаленный роутер не трогается, он по-прежнему работает с VLAN10. Все замечательно.

Но как провернуть тот же фокус с несколькими линками?

post-5155-086197700 1387378847_thumb.gif

Смотрю в сторону VLAN Mapping, описанного здесь. Вроде бы то, что мне нужно. Делаю для начала хотя бы один линк, тот же, что в предыдущем примере, но теперь порты сервера в режиме транка.

4900M#show run inter te1/1
...
interface TenGigabitEthernet1/1
switchport mode trunk
switchport vlan mapping 110 10
load-interval 30
end

4900M#show run inter te1/2
...
interface TenGigabitEthernet1/2
switchport mode trunk
switchport vlan mapping 10 110
load-interval 30
end

Не работает.

Причем сам по себе маппинг работает, если взять и реализовать сценарий, описанный в мануале, один-в-один. Но у меня сценарий несколько иной - трафик нужно принять от самого себя и отдать самому себе. Это реализуемо в рамках одного свитча или нет?

Share this post


Link to post
Share on other sites

Про q-in-q почитайте.

Читал, ессно. И даже применяю довольно широко.

Все, что ниже середины сервера на вашем рисунке запихнуть в свободный таг не снимая пришедших.

А потом в петле развернуть? Заманчиво. Да вот в порты Giga3/10 - 12 (на схеме) прилетают далеко не только эти самые IP P2P. Там еще полно (до сотни на порт) других транзитных VLAN, не имеющих отношения к текущей задаче. За идею спасибо, в настоящий момент думаю в сторону Selective QinQ на этих портах, но уж очень не хочется их перепахивать по живому из-за этой шарманки, будь она здорова - это все делается на время проведения тестов...

Edited by Serhio Go

Share this post


Link to post
Share on other sites

Про q-in-q почитайте.

Читал, ессно. И даже применяю довольно широко.

Все, что ниже середины сервера на вашем рисунке запихнуть в свободный таг не снимая пришедших.

А потом в петле развернуть? Заманчиво. Да вот в порты Giga3/10 - 12 (на схеме) прилетают далеко не только эти самые IP P2P. Там еще полно (до сотни на порт) других транзитных VLAN, не имеющих отношения к текущей задаче. За идею спасибо, в настоящий момент думаю в сторону Selective QinQ на этих портах, но уж очень не хочется их перепахивать по живому из-за этой шарманки, будь она здорова - это все делается на время проведения тестов...

Не выходит каменный цветок. Selective QinQ не работает в таком виде, только традиционный dot1q tunnel, но он мне не годится, поскольку я не могу в него упихать все вланы портов giga3/x...

Share this post


Link to post
Share on other sites

Selective QinQ не работает в таком виде, только традиционный dot1q tunnel,

пора софт обновлять

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this