Jump to content
Калькуляторы

Dynamic source NAT на Juniper MX-5 Не выходит. Помогите, очень срочно нужно.

Добрый вечер!

 

Попал в руки следующий девайс:

admin@MX-5> show version invoke-on all-routing-engines
Hostname: MX-5
Model: mx5-t
JUNOS Base OS boot [11.4R1.14]
JUNOS Base OS Software Suite [11.4R1.14]
JUNOS Kernel Software Suite [11.4R1.14]
JUNOS Packet Forwarding Engine Support (MX80) [11.4R1.14]
JUNOS Online Documentation [11.4R1.14]
JUNOS Routing Software Suite [11.4R1.14]

admin@MX-5# run show chassis hardware
Hardware inventory:
Item             Version  Part number  Serial number     Description
Chassis                                F8293             MX5-T
Midplane         REV 08   711-038215   CAAG5254          MX5-T
PEM 0            Rev 04   740-028288   WE04350           AC Power Entry Module
PEM 1            Rev 04   740-028288   WF04970           AC Power Entry Module
Routing Engine            BUILTIN      BUILTIN           Routing Engine
TFEB 0                    BUILTIN      BUILTIN           Forwarding Engine Processor
 QXM 0          REV 06   711-028408   CAAH4636          MPC QXM
FPC 0                     BUILTIN      BUILTIN           MPC BUILTIN
 MIC 0                   BUILTIN      BUILTIN           4x 10GE XFP
   PIC 0                 BUILTIN      BUILTIN           4x 10GE XFP
FPC 1                     BUILTIN      BUILTIN           MPC BUILTIN
 MIC 0          REV 26   750-028392   CAAJ7556          3D 20x 1GE(LAN) SFP
   PIC 0                 BUILTIN      BUILTIN           10x 1GE(LAN) SFP
     Xcvr 0     REV 02   740-013111   D252841           SFP-T
     Xcvr 1     REV 02   740-013111   D254923           SFP-T
   PIC 1                 BUILTIN      BUILTIN           10x 1GE(LAN) SFP
     Xcvr 0     REV 02   740-013111   D252844           SFP-T
     Xcvr 1     REV 02   740-013111   D254901           SFP-T
     Xcvr 2     REV 02   740-013111   D252964           SFP-T
     Xcvr 3     REV 02   740-013111   D254942           SFP-T
     Xcvr 4     REV 02   740-013111   D255139           SFP-T
     Xcvr 5     REV 02   740-013111   D254917           SFP-T
     Xcvr 6     REV 02   740-013111   D254920           SFP-T
     Xcvr 7     REV 02   740-013111   D252835           SFP-T
     Xcvr 8     REV 02   740-013111   D254872           SFP-T
     Xcvr 9     REV 02   740-013111   D255646           SFP-T
Fan Tray                                                 Fan Tray

admin@MX-5# run show system license
License usage:
                                Licenses     Licenses    Licenses    Expiry
 Feature name                       used    installed      needed
 scale-subscriber                      0         1000           0    permanent
 scale-l2tp                            0         1000           0    permanent
 scale-mobile-ip                       0         1000           0    permanent

Licenses installed: none

 

Необходимо поднять простой динамический нат N:1.

 

Сделали вот так:

interfaces {
   ms-1/0/0 {
       unit 0 {
           family inet;
       }
   }
   ge-1/1/0 {
       gigether-options {
           802.3ad ae0;
       }
   }
   ge-1/1/1 {
       gigether-options {
           802.3ad ae0;
       }
   }
   ge-1/1/2 {
       description "TTK inet";
       unit 0 {
           family inet {
               address xx.xx.xx.xx/24;
           }
       }
   }
   ge-1/1/3 {
       description "RTK inet";
       unit 0 {
           family inet {
               address yy.yy.yy.yy/30;
           }
       }
   }
   ae0 {
       description "LACP to StoneGate";
       vlan-tagging;
       aggregated-ether-options {
           minimum-links 1;
           link-speed 1g;
           lacp {
               active;
               periodic fast;
           }
       }
       unit 11 {
           description "Transit network between StoneGate";
           vlan-id 11;
           family inet {
               address 10.11.11.1/30;
           }
       }
       unit 197 {
           description "Management network with routing";
           vlan-id 197;
           family inet {
               service {
                   input {
                       service-set nat_to_ttk;
                   }
                   output {
                       service-set nat_to_ttk;
                   }
               }
               address 192.168.197.252/24;
           }
       }
   }
   fxp0 {
       unit 0 {
           description "Management interface";
           family inet {
               address 192.168.197.251/24;
           }
       }
   }
   lo0 {
       unit 0 {
           description Loopback;
           family inet {
               address 10.10.10.10/32;
           }
       }
   }
   vlan {
       unit 11;
       unit 197;
   }
}
services {
   nat {
       pool ttk {
           address-range low xx.xx.xx.xx high xx.xx.xx.xx;
       }
       rule local_to_ttk {
           match-direction input;
           term t1 {
               from {
                   source-address {
                       192.168.197.0/24;
                   }
               }
               then {
                   translated {
                       source-pool ttk;
                       translation-type {
                           dynamic-nat44;
                       }
                   }
               }
           }
       }
   }
   service-set nat_to_ttk {
       nat-rules local_to_ttk;
       interface-service {
           service-interface ms-1/0/0;
       }
   }
}

Ни в какую не хочет работать. Есть у кого какие идеи?

Share this post


Link to post
Share on other sites

без сервисного мика работать не будет

Что такое МИК?

Share this post


Link to post
Share on other sites

http://www.juniper.net/techpubs/en_US/release-independent/junos/topics/reference/general/mic-mx-series-ms.html

 

Без этого MX не умеют ната. Да и появился он наверное пару-тройку месяцев как.

 

Ну разве что только inline-nat, который я не пробовал.

Edited by DVM-Avgoor

Share this post


Link to post
Share on other sites

Тогда скажите как отсутствие НАТа проявляется: команд нет или они не работают? Просто конфиг то ведь пишется, нет чтобы написать, что НАТа нет (в cli).

Share this post


Link to post
Share on other sites

Тогда скажите как отсутствие НАТа проявляется: команд нет или они не работают? Просто конфиг то ведь пишется, нет чтобы написать, что НАТа нет (в cli).

 

 

Ну как бы все знали что ната изначально в коробке нет. Вендор не скрывал. Ну команды есть, просто не работают :)

Share this post


Link to post
Share on other sites

А разые нельзя сделать inline NAT ?

 

Inline NAT только 1:1.

N:1 без сервисного модуля не полетит.

Share this post


Link to post
Share on other sites
N:1 без сервисного модуля не полетит.
сервисных модулей к MX5/20/40/80 нет и вероятно их не будет, хотя когда-то обещали. но даже если оно появится, то вряд ли по "доступной" цене .)

Share this post


Link to post
Share on other sites

сервисных модулей к MX5/20/40/80 нет

 

Модуль есть: MS-MIC-16G

http://www.juniper.net/techpubs/en_US/release-independent/junos/topics/reference/general/mic-mx-series-supported.html

Но принимая во внимание версию софта, есть сомнения, что он сейчас работоспособен :(

Share this post


Link to post
Share on other sites

Изначально MX-5 был куплен для BGP и 2 провов, но возникла потребность в НАТе. В общем пока тоже пришли к выводу о том, что НАТить он не будет. Спасибо за помощь.

Share this post


Link to post
Share on other sites

сервисных модулей к MX5/20/40/80 нет

 

Модуль есть: MS-MIC-16G

http://www.juniper.net/techpubs/en_US/release-independent/junos/topics/reference/general/mic-mx-series-supported.html

Но принимая во внимание версию софта, есть сомнения, что он сейчас работоспособен :(

ну карта поддерживается с 13.2, баги там естественно будут , но с другой стороны , скоро 13.3 будет :)

Share this post


Link to post
Share on other sites

Добрый вечер. У нас появилась аналогичная задача - динамический нат N:1 на Juniper MX5-t c  MS-MIC-16G.

Может кто-нибудь помочь с конфигурацией, пожалуйста?
show version invoke-on all-routing-engines 
Hostname: mx5-t
Model: mx5-t
Junos: 17.3R3-S7.2

 

Пытался настроить по обзазцу первого поста, нат заработал, а минут через 20 перестрал.

Может у кого-то есть образец рабочкго конфига?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this