Jump to content
Калькуляторы

Небольшая задачка по настройке оборудования Cisco

Уважаемые форумчане, помогите с решением данной задачки. Я конечно понимаю что это уже не ваш уровень и из разряда "для студента", но хотелось бы увидеть ваше решение.

post-109578-084064000 1385573255_thumb.jpg

Share this post


Link to post
Share on other sites

Cisco router

 

 

 

int fa0/0

ip add 192.168.45.2 255.255.255.248

!

int tu1

ip add 192.168.46.2 255.255.255.252

tunnel source 192.168.45.2

tunnel destination 192.168.45.1

!

router eigrp 1

no auto

network 192.168.46.2 0.0.0.0

network 10.5.0.4 0.0.0.0

no passive-interface tu1

passsive-interface default

 

 

Cisco Switch

 

int vlan 4

no shut

ip add 192.168.45.1 255.255.255.248

!

int fax/x

switch mode access

swtch access vlan 4

!

vlan 1

ip add 10.5.3.1 255.255.255.128

!

int fax/x

switch mode access

swtch access vlan 1

!

int tu1

ip add 192.168.46.1 255.255.255.252

tunnel source 192.168.45.1

tunnel destination 192.168.45.2

!

router eigrp 1

no auto

passive-interface default

network 192.168.46.1 0.0.0.0

network 10.5.3.1 0.0.0.0

no passive-interface tu1

Share this post


Link to post
Share on other sites

applx, а интерфейс лупбэк где на роутере?

Share this post


Link to post
Share on other sites

Cisco router

 

 

 

int fa0/0

ip add 192.168.45.2 255.255.255.248

!

int tu1

ip add 192.168.46.2 255.255.255.252

tunnel source 192.168.45.2

tunnel destination 192.168.45.1

!

router eigrp 1

no auto

network 192.168.46.2 0.0.0.0

network 10.5.0.4 0.0.0.0

no passive-interface tu1

passsive-interface default

 

 

Cisco Switch

 

int vlan 4

no shut

ip add 192.168.45.1 255.255.255.248

!

int fax/x

switch mode access

swtch access vlan 4

!

vlan 1

ip add 10.5.3.1 255.255.255.128

!

int fax/x

switch mode access

swtch access vlan 1

!

int tu1

ip add 192.168.46.1 255.255.255.252

tunnel source 192.168.45.1

tunnel destination 192.168.45.2

!

router eigrp 1

no auto

passive-interface default

network 192.168.46.1 0.0.0.0

network 10.5.3.1 0.0.0.0

no passive-interface tu1

и так тыкался и сяк- не робит у меня. Кто скажет в чем подвох. loppback и ПК настроены

Share this post


Link to post
Share on other sites

Реальную конфу, что забил в девайсы - в студию....

 

а еще на свиче

 

sh ip ro

 

sh vlan

 

sh int vlan 1

 

sh int vlan 4

 

sh int tun1

 

 

Edited by optimous

Share this post


Link to post
Share on other sites

Реальную конфу, что забил в девайсы - в студию....

 

а еще на свиче

 

sh ip ro

 

sh vlan

 

sh int vlan 1

 

sh int vlan 4

 

sh int tun1

Вот команды в указанном порядке:

 

10.0.0.0/25 is subnetted, 1 subnets

C 10.5.3.0 is directly connected, Vlan1

192.168.45.0/29 is subnetted, 1 subnets

C 192.168.45.0 is directly connected, Vlan4

 

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5

Fa0/6, Fa0/7, Fa0/8, Fa0/9

Fa0/10, Fa0/11, Fa0/12, Fa0/13

Fa0/14, Fa0/15, Fa0/16, Fa0/17

Fa0/18, Fa0/19, Fa0/20, Fa0/21

Fa0/22, Fa0/23, Fa0/24, Gig0/1

Gig0/2

4 VLAN0004 active Fa0/1

1002 fddi-default act/unsup

1003 token-ring-default act/unsup

1004 fddinet-default act/unsup

1005 trnet-default act/unsup

 

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 0 0

4 enet 100004 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 0 0

1003 tr 101003 1500 - - - - - 0 0

1004 fdnet 101004 1500 - - - ieee - 0 0

1005 trnet 101005 1500 - - - ibm - 0 0

 

Vlan1 is up, line protocol is up

Hardware is CPU Interface, address is 0090.21a1.5527 (bia 0090.21a1.5527)

Internet address is 10.5.3.1/25

MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 21:40:21, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

1682 packets input, 530955 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

563859 packets output, 0 bytes, 0 underruns

0 output errors, 23 interface resets

0 output buffer failures, 0 output buffers swapped out

 

Vlan4 is up, line protocol is up

Hardware is CPU Interface, address is 0090.21a1.5527 (bia 0090.21a1.5527)

Internet address is 192.168.45.1/29

MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 21:40:21, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

1682 packets input, 530955 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

563859 packets output, 0 bytes, 0 underruns

0 output errors, 23 interface resets

0 output buffer failures, 0 output buffers swapped out

 

Tunnel1 is up, line protocol is down (disabled)

Hardware is Tunnel

Internet address is 192.168.46.1/30

MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive not set

Tunnel source (FastEthernet0/1), destination 192.168.45.2

Tunnel protocol/transport GRE/IP

Key disabled, sequencing disabled

Checksumming of packets disabled

Tunnel TTL 255

Fast tunneling enabled

Tunnel transport MTU 1476 bytes

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 input packets with dribble condition detected

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

 

А вот на роутере на инт tu1 выдает line protocol is up:

 

Router#sh int tu1

Tunnel1 is up, line protocol is up (connected)

Hardware is Tunnel

Internet address is 192.168.46.2/30

MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive not set

Tunnel source 192.168.45.2 (FastEthernet0/0), destination 192.168.45.1

Tunnel protocol/transport GRE/IP

Key disabled, sequencing disabled

Checksumming of packets disabled

Tunnel TTL 255

Fast tunneling enabled

Tunnel transport MTU 1476 bytes

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 input packets with dribble condition detected

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

Edited by ShaManN

Share this post


Link to post
Share on other sites

Tunnel1 is up, line protocol is down (disabled)<<<

 

show log, там про recursive routing via tunnel ниче нету?

 

ну и sh ip eigrp int

Share this post


Link to post
Share on other sites

Tunnel1 is up, line protocol is down (disabled)<<<

 

show log, там про recursive routing via tunnel ниче нету?

 

ну и sh ip eigrp int

 

Я во всех этих вещах еще не так силен, так что на ваше компетентное мнение положусь!

 

Switch#show logging

Syslog logging: enabled (0 messages dropped, 0 messages rate-limited,

0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

No Inactive Message Discriminator.

Console logging: level debugging, 13 messages logged, xml disabled,

filtering disabled

Monitor logging: level debugging, 0 messages logged, xml disabled,

filtering disabled

Buffer logging: disabled, xml disabled,

filtering disabled

Logging Exception size (4096 bytes)

Count and timestamp logging messages: disabled

Persistent logging: disabled

No active filter modules.

ESM: 0 messages dropped

Trap logging: level informational, 13 message lines logged

 

и

 

Switch#sh ip eigrp int

IP-EIGRP interfaces for process 1

Xmit Queue Mean Pacing Time Multicast Pending

Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

Edited by ShaManN

Share this post


Link to post
Share on other sites

так у вас EIGRP на интерфэйсах не настроен

 

а чтоб логи были сделай logging buffered 4096 хотябы

Share this post


Link to post
Share on other sites

Чтобы не плодить темы, с позволения автора воспользуюсь этой

 

Имеется cisco 3640, ios 12.2

сам я с cisco не работал до недавнего времени, это первая, много больше одного десятка компьютеров, потому экспериментировать

нужно внести правки в аксесс-листы, но возникли сложности

год маршрутизатора 1997, места - 12 мб, более новая прошивка весит порядка 30 мб

так что строки правил в аксесс листе не пронумерованы, не особо нашел (а что нашел, не совсем разобрался), как внести правки в листы...

подскажите , как быть

находил информацию, что можно скопировать конфигурационный файл, его изменить, а далее уже залить измененный. По итогу пользователи даже не почувствуют неполадки с интернетом. Но выскочила проблема - я не нахожу новый сохраненный файл во флэш памяти (copy running-config startup-config => Enter) . Хотя вроде как он отображается в изменениях конфига

вот скрины

http://f3.s.qip.ru/18qb6muBL.png

http://f3.s.qip.ru/18qb6muBM.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this