Jump to content
Калькуляторы

Cisco 2911 + ES2-16-P маршрутизация

Подскажите пожалуйста, как настроить маршрутизацию между модулем коммутатора ES2-16-P, который установлен в Cisco 2911.

На модуле коммутатора подключены кабеля от других сетей и каждому порту назначен свой айпишник ( через switchport access vlan )

Нужно настроить OSPF, но его насколько я понимаю нужно настраивать на самом 2911.

 

Вопрос - как мне на основном конфиге 2911 "увидеть" подсети, которые прописаны в конфиге ES2-16-P ?

Как я понял, на роутере есть интерфейс коммутатора под названием G/E 1/0 который соединяется внутри циски с модулем коммутатора, который в режиме конфигурации коммутатора называется G/E 0/1.

Получается нужно через этот интерфейс как то настроить хождение трафика и динамическую маршрутизацию.

 

часть конфига роутера -

 

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

!

interface GigabitEthernet1/0

ip address 192.168.200.1 255.255.255.0

!

 

часть конфига коммутатора:

 

interface FastEthernet0/2

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/4

switchport access vlan 4

switchport mode access

!

interface FastEthernet0/5

switchport access vlan 5

switchport mode access

!

interface FastEthernet0/6

switchport access vlan 6

switchport mode access

!

interface GigabitEthernet0/1

description connection to router

switchport trunk native vlan 10

switchport mode trunk

!

interface GigabitEthernet0/17

!

interface GigabitEthernet0/18

!

interface Vlan1

no ip address

no ip route-cache

!

interface Vlan2

ip address 192.168.160.17 255.255.255.248

no ip route-cache

!

interface Vlan3

ip address 192.168.160.9 255.255.255.248

no ip route-cache

!

interface Vlan4

ip address 192.168.160.1 255.255.255.248

no ip route-cache

!

interface Vlan5

ip address 192.168.161.1 255.255.255.224

no ip route-cache

!

interface Vlan6

ip address 192.168.163.1 255.255.255.224

no ip route-cache

!

interface Vlan10

ip address 192.168.200.2 255.255.255.0

no ip route-cache

полные конфиги во вложении

comutat.txt

router.txt

Share this post


Link to post
Share on other sites

маршрутизацию между модулем коммутатора ES2-16-P, который установлен в Cisco 2911

 

Простите щито? Звучит как бред. Это модуль роутера. Между, ничего не настраивается. Включаете порт в нужный влан в нужном режиме и... и все.

Share this post


Link to post
Share on other sites

маршрутизацию между модулем коммутатора ES2-16-P, который установлен в Cisco 2911

 

Простите щито? Звучит как бред. Это модуль роутера. Между, ничего не настраивается. Включаете порт в нужный влан в нужном режиме и... и все.

http://conetec.ru/product_info.php?products_id=4602 вот этот модуль.

Когда я вставляю его в циску то добавляется только интерфейс Gigabit Ethernet 1/0.

Пишу в консоли service-module gigabit ethernet 1/0 session и попадаю в режим конфигурации коммутатора.

Или вы хотите сказать, что можно все настроить не входя в режим конфигурации коммутатора?

Share this post


Link to post
Share on other sites

конечно. это парадигма cli роутеров фирмы cisco (про XR и ASA(это аще не роутер) я молчу)

Share this post


Link to post
Share on other sites

конечно. это парадигма cli роутеров фирмы cisco (про XR и ASA(это аще не роутер) я молчу)

Ок, тогда как мне например задать айпишник 192.168.0.1/24 на 7 порту SM-ES2-16-P из консоли, при этом не заходя в service-module gigabit ethenet 1/0?

Share this post


Link to post
Share on other sites

Приветствую.

Если коммутатор (show ver с него покажите) только L2, то ip-интерфейсы терминируйте на роутере (router-on-the-stick).

На коммутаторе:

interface GigabitEthernet0/1
description connection to router
switchport trunk allow vlan 2-10
switchport trunk native vlan 1
switchport mode trunk

На маршрутизаторе:

interface GigabitEthernet1/0
no ip address
no shutdown
interface GigabitEthernet1/0.1
encapsulation dot1Q 1 native
ip address x.x.x.x
interface GigabitEthernet1/0.2
encapsulation dot1Q 2
ip address a.a.a.a
interface GigabitEthernet1/0.3
encapsulation dot1Q 3
ip address b.b.b.b
interface GigabitEthernet1/0.4
encapsulation dot1Q 4
ip address c.c.c.c

 

и так далее.

Если коммутатор L3, то ip-адреса терминируйте на нем, а на линке между ним и роутером поднимаете L3 и IGP по-выбору.

Edited by stepashka

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this