Jump to content
Калькуляторы

Обрывы связи pptp tunnel (Mikrotik 951)

Везде стоит оборудование Mikrotik 951 (сервер - клиент). Между филиалами поднята общая сетка через pptp.

Проблема в том что происходит затык в связи на несколько секунд, при этом сама сессия pptp не рвется.

Пример:

1) клиент - клиент, потоковое видео с камер наблюдения, картинка замирает на несколько секунд, потом возобновляется.

2) sip телефония, обрывается разговор.

 

Все настройки стандартны. Может проблема с MTU ? Сервер-1460. Клиент-1450.

Share this post


Link to post
Share on other sites

Надо от PPTP перейти на L2TP, при этом MTU трогать не нужно.

Далее запустить пинги через канал и смотреть что происходит в момент затыка, пинги с интервалом 100мс.

Share this post


Link to post
Share on other sites

Надо от PPTP перейти на L2TP, при этом MTU трогать не нужно.

Далее запустить пинги через канал и смотреть что происходит в момент затыка, пинги с интервалом 100мс.

 

До этого стояло DFL (сервер) - Mikrotik 951 (клиент)

Сейчас Mikrotik (сервер) - Mikrotik (клиент)

 

Затык поймать не так просто, он может пару раз в день, а может 15.

Запустил пинги(100ms). Из 595 пакетов потери 9%. При этом сессия pptp не рвется. Но это видать попал на затык, потом прогонял несколько тысяч пакетов, все было нормально. Как найти причину? В основных логах кроме подключения и отключения кого либо больше ничего нет.

 

У клиента настройки не менялись. Переходить на L2TP не вариант, было же все нормально пока был не Mikrotik, значит проблема где то в нем, в настройках сервера кроме MTU и MRU ничего нет, вот и предположил.

Edited by vlagilen

Share this post


Link to post
Share on other sites

До этого стояло DFL (сервер) - Mikrotik 951 (клиент)

Сейчас Mikrotik (сервер) - Mikrotik (клиент)

 

Затык поймать не так просто, он может пару раз в день, а может 15.

Запустил пинги(100ms). Из 595 пакетов потери 9%. При этом сессия pptp не рвется. Но это видать попал на затык, потом прогонял несколько тысяч пакетов, все было нормально. Как найти причину? В основных логах кроме подключения и отключения кого либо больше ничего нет.

 

У клиента настройки не менялись. Переходить на L2TP не вариант, было же все нормально пока был не Mikrotik, значит проблема где то в нем, в настройках сервера кроме MTU и MRU ничего нет, вот и предположил.

 

Интересно, начальный конфиг на микротике сбрасывали перед настройкой? Всякого рода фильтрации входящего трафика и т.п.? На микротике PPTP и L2TP, а так же SSTP работают без проблем и никаких потерь просто так не происходит. Бывает правда вышестоящие провайдеры чудят с пакетами, а так - ничего. Поэтому и нужно перейти для проверки на L2TP, ничего перенастраивать не нужно, кроме создания новых соединений на удаленных клиентах.

Share this post


Link to post
Share on other sites

Интересно, начальный конфиг на микротике сбрасывали перед настройкой? Всякого рода фильтрации входящего трафика и т.п.? На микротике PPTP и L2TP, а так же SSTP работают без проблем и никаких потерь просто так не происходит. Бывает правда вышестоящие провайдеры чудят с пакетами, а так - ничего. Поэтому и нужно перейти для проверки на L2TP, ничего перенастраивать не нужно, кроме создания новых соединений на удаленных клиентах.

 

Да конечно, первым делом сбрасываю. Фильтров никаких нет. Ошибки со стороны провайдера не исключены, тестировал связь последние несколько дней, с клиентами(pptp) более удаленных, связь стабильней. Больше склоняюсь что проблемы со стороны провайдера, поменяю порты на свиче провайдера и еще раз все перенастрою. L2TP попробую.

Edited by vlagilen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this