Jump to content
Калькуляторы

Все о Рапире обсуждение о маршрутизаторах Рапира

7. Если в процессера работы температура упала ниже -15°С, то включается нагреватель и ждем её повышения.

 

Если температура не повышается, что же произойдет дальше?

 

Температура будет расти, но в зависимости от внешней температуры с разной скоростью.

При прогонах в термокамере при внешней температуре -45°С выход на -15°С занимал около 12минут.

При более жестких условиях -50°С выход на -15°С занимал до 20 минут.

 

Еще есть фактор ветра, который вносит свои веские коррективы в общую температуру.

Мы исходим из типовой ситуации темперетура окружающей среды -35°С и ветер 5-7 м/с, который дает суммарное понижение температуры на 7-10°С.

 

PS: в алгоритме я описал процесс пробного запуска устройства каждые 15 минут независимо от внутренней температуры.

Edited by rapira-104

Share this post


Link to post
Share on other sites

и как определяется что роутер ожил? это самое основное я думаю в логике....

У нас есть мелкий демон, который дает короткие импульсы одни раз в минуту.

Если контроллер получает их - значит роутер жив.

 

Для routerboard-ов тоже есть решение, причем в рамках стандартного ПО.

Используя стандартные скрипты микротика, можно моргать светодиодами один раз в минуту,

что мы и используем в wifibird-e (в отличии от Rapira-ы, сигнал инвертированный получается).

Share this post


Link to post
Share on other sites

rapira-104, сделайте одолжение, дайте мигательный скрипт. Очень надо (НГ на носу)...

Вот скрипт для ёлочки. 8-)

:while (1=1) do={
   :led user-led=no led4=no led3=no led2=no led1=no;
   :delay (200ms);
   :for i from=1 to=4 do={
      :if ( $i = 1 ) do={
         :led led4=yes;}
      :if ( $i = 2 ) do={
         :led led4=no led3=yes;}
      :if ( $i = 3 ) do={
         :led led3=no led2=yes;}
      :if ( $i = 4 ) do={
         :led led2=no led1=yes;}
      delay (1s);
   }
   :led led1=no;
   :delay (200ms);
   :led user-led=yes led4=yes led3=yes led2=yes led1=yes;
   :delay (1s);
}

 

Вот так можно поморгать для нашей железки.

/system scheduler add name=WDT1m interval=1m on-event=WDT

 

Скрипт WDT для помаргивания

:led user-led=yes;
:delay (500ms);
:led user-led=no;

Share this post


Link to post
Share on other sites

К стати микротик неплохое железо для дома,если выкинуть родную прошивку и поставить опенврт.С родной у меня вай фай так и не смог заработать нормально

Share this post


Link to post
Share on other sites

Добрый день. Имеется радиомост из двух Rapira RS-2 (да-да, старые модели). Обе находятся в режиме Bridge и стоят за NAT-ом.

Пытаюсь после них поставить IPTV-приставку, но та отказывается подгружать видео от провайдера.

Посмотрел статистику на Ethernet-порту железки, стоящей у приставки - RX Multicast есть, а на Wireless удалённой (что ближе к NAT) - нет полученных мультикастов. Так понимаю, они не пробрасываются?

Нашел опцию allmulticast, включается она одновременно на всех интерфейсах, завязанных в Bridge, но её включение на обеих рапирах не влияет на ситуацию.

Проверял на альтернативном оборудовании для радиомоста - там пакеты бегают как надо.

Но хотелось бы сделать именно на Rapira.

Есть идеи, как это сделать?

Share this post


Link to post
Share on other sites

Вариант отдавать iptv не мультиком, а hls или через проксю типа astra или msd_lite не рассматриватся?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this