Jump to content
Калькуляторы

QinQ 7206

Сегодня собрал стенд следующей конфигурации:

На циске 7206 повешена на лупбэк сетка вида xx.xx.xx.xx/29. Конфиг интерфейсов:

interface GigabitEthernet0/1
mtu 1508
no ip address
media-type gbic
speed auto
duplex auto
negotiation auto
!
interface GigabitEthernet0/1.50
encapsulation dot1Q 50 second-dot1q 10
ip unnumbered Loopback1
!
interface GigabitEthernet0/1.51
encapsulation dot1Q 50 second-dot1q 20
ip unnumbered Loopback1
! 
interface GigabitEthernet0/1.52
encapsulation dot1Q 50 second-dot1q 30
ip unnumbered Loopback1
!
interface GigabitEthernet0/1.53
encapsulation dot1Q 50 second-dot1q 40
ip unnumbered Loopback1
!
interface Loopback1
ip address xx.xx.xx.249 255.255.255.248

 

Через Gi0/1 7206 подключена к 3550-12G в порт Gi0/1 соответственно.

 

На Gi0/11 и Gi0/12 3550 настроен QinQ, первый порт транком в сторону 7206, 12 и 13 акцесом в сторону тестового клиента.

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/11
switchport access vlan 50
switchport mode dot1q-tunnel
!
interface GigabitEthernet0/12
switchport access vlan 50
switchport mode dot1q-tunnel

 

В качестве тестового клиента стоят пара RB951, на которых подняты вланы 10,20,30,40. На свитче вланы запаковываются в влан 50 и вытащить их надо на 7206.

MTU на 3550 и 7206 поставил 1508. Итог таков, что микротики друг друга пингуют по всем внутренним вланам, со стороны каталиста я вижу мак с 11 и 12 порта в влане 50. Т.е. трафик внутри каталиста нормально ходит и запаковывается/распаковывается. Но с 7206 не пингуется ни один из микротиков. Более того, со стороны 7206 на каталисте я не вижу не одного мака, хотя счетчик на порту растет. На 7206 пробовал менять dot1q tunneling ethertype (0x88A8,0x9100,0x9200) - эфекта нет, на 3550 TPID поменять нельзя правда. Крутил MTU - не помогает.

Магия короче. В чем могут быть грабли?

 

И сразу вопрос, какой TPID выставляет циска на запакованном в QinQ трафике? 0x88A8?

Share this post


Link to post
Share on other sites

ну вообще чтобы циска могла пинговать микротики я так понимаю тебе нужно маршруты добавлять, что бы циска знала за каким интерфейсом какой ип висит, на 7206 вродеж можно tpid менять,если не знаешь какой юзать, используй 0x8100, тогда не потребуется поддержка qinq на промежуточных коммутаторах

 

ну а счетчики будут расти, просто пакеты дропаются

Share this post


Link to post
Share on other sites

Косяк в том, что на 7200 нельзя поставить 0x8100, только те, которые вшиты.

Я пробовал убирать подсетку с лупбэка, unnumbered тоже убирал и вешал ее прямо на сабинтерфейс. Сетка тогда directly connected, хотя и с unnumbered то же самое. Эффекта ноль. Т.е. на 3550 не видно даже фреймов с ARP-запросами от 7206. ((.

Share this post


Link to post
Share on other sites

на 7200:

interface GigabitEthernet0/1

no mtu

 

на 3550:

system mtu jumbo 1522 (или выше)

 

ethertype не трогаем.

Share this post


Link to post
Share on other sites

Все дело оказалось в GBICах, стояли два медных. Сразу не обратил внимание, что даже CDP не ходит через них. Поменял на оптические и все взлетело.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this