Jump to content
Калькуляторы

Проброс линий между SNR-VG-6040 и SNR-VG-3002

Это мое первое оборудование SNR.

Столкнулся с проблемами реализации. Сложность еще и втом, что я не увидел в устройствах каких либо логов и на чем все стопориться понять не могу.

Кроме того, как я понял, устройства не проверяют синтаксис параметров, в интерфейсе можно все что угодно и оно это примет.

Фактически надо просто пробросить линии от аналоговой АТС к которой пудключен VG-6040 до четырех аналоговых телефонов которые подключены к двум VG-3002.

Без всяких префиксов выхода на линию. Просто прямое соединеение конкретного порта АТС с конкретным внутренним аналоговым телефоном и все.

Инструкция приведенная здесь http://shop.nag.ru/article/nastrojka-analogovogo-fxo-shlyuza-bez-registratsii-na-sip-servere

мне не помогла, ничего не работает и не вижу способа узнать почему - синтаксис не проверяется, логов нет...

Прошу помочь

Edited by xxxservice

Share this post


Link to post
Share on other sites

по моему такие темы подымались и не один раз...можно поискать по форуму, а если нету то на наге есть http://data.nag.ru/SNR%20VoIP/VoIP%20Gateway/Documentation/How%20To/

логику в целом понять можно

Share this post


Link to post
Share on other sites

Естественно, прежде чем поднимать тему, я посомтрел данные статьи. Пока ничего не получилось. А некоторые строки в этот статье, типа "SIP-сервер (домен) – ch1:p1;ch2-p1;" вообще похожи на опечатки. Иначе почему соответствие канала и порта сначала пишется через двоеточие, а потом через тире??

С учетом отсутствия логов, которые помогли разобраться, с учетом того, что в строку параметров можно ввести хоть что и устройство не руганется, а также имея основании сомневаться в правильности этих статей, я и задал этот вопрос.

Если никаких советов или анализа моих конфигов не образуется, то буду долбиться с этими примерами... вариантов нет.

Может у кого есть готовые конфиги для связи данных аппаратов?

Share this post


Link to post
Share on other sites

это опечатки. надо сказать им

там ch1-p1 что значит канал 1(например порт ) к сип профилю 1

или так ch1-2:p1 что значит каналы 1 и 2 к профилю 1

Share this post


Link to post
Share on other sites

Действовал по указанной выше инструкции.

Получил следующие непонятные результаты:

1. При входящем звонке на шлюз, трубка снимается сразу, а не когда ее снимешь на телефоне подключенном к порту адаптера. Почему?

2. При снятии трубки подключенной на адаптере, звука в трубке нет - тишина. Почему? Трубка определяет входящий номер как 111 (имя пользователя по инструкции)

3. При попытке выхода через телефон подключенный к адаптеру на внешнюю линию подключенную к шлюзу, ничего не происходит - снимаю, гудок, нажимаю 8 или 9, тишина. Хотя это должно приводить к занятию соответствующего порта на шлюзе.

Почему?

4. В инструкции, при настройке шлюза, используются пароли пользователей (пользователь 111, пароль 111 и т.п.). Но по инструкции не используются никакие пароли на адаптере, при подключении к шлюзу. Это как понимать??

5. Как сделать, что бы не надо было донабирать 8 или 9 для выхода на внешнюю линию? Что бы телефон подключенный к первому порту адаптера, сразу занимал первый порт шлюза и т.п.?

6. Правильно ли я понимаю, что более двух адаптеров с одним шлюзом не соединишь? Так как надо будет активировать второй SIP сервер - для указания IP второго адаптера, а SIP серверов в шлюзе всего два...

Прошу помочь. Инструкция выполнена точно, проверено, результата ноль.

Конфиги приложу.

cfg.txt

cfg(1).txt

Edited by xxxservice

Share this post


Link to post
Share on other sites

1.измени stage method на шлюзе который сам подымает трубку

2 и 3 пункты противоречат друг другу...во втором говорите что ничего не происходит, а в 3 пункте уже появился тон...что все таки происходит? покажите как описаны правила для выхода на fxo порт через 8 и 9, пРимер диал плана:

{8=*47172*16*16*100*2*5260>|9=*47172*16*16*100*2*5262>}, т.е как бы описываем, что при нажатии 8 выходим на первую линию fxo-шлюза(которому привязан порт 5260), а при нажатии 9 на вторую линию fxo-шлюза(порт 5262). Вероятно инструкции у вас опечатки в номерах портов, номера портов должны быть не 5260 и 5262, а 5060 и 5062.

4.я думаю, что пароли просто напросто не отображаются - в целях безопасности. я когда настраивал - вводил для всех учеток

5.не уверен точно, но попробуй в качестве сип сервера указывать что-то типа 192.168.1.100:5060 - 5060 это как пример порт на линии fxo

6.не совсем понял. схему?

Share this post


Link to post
Share on other sites

Спасибо за подсказки, megahertz

1. Изменение Stage Method(1/2) на ch1-4:1; никак не поменяло ситуацию, трубка снимается при звонке тут же. Еще есть идеи?

 

2 и 3 не противоречат. Гудок, который я слышу в п.3 это гудок адаптера, к сигналу линии он никакого отношения не имеет.

Строка выхода сейчас выглядит так {<8=*47192*168*21*1*5060>|<9=*47192*168*21*1*5062>|[x*]+} где 192.168.21.1 это IP удаленного шлюза.

В портах действительно была ошибка, эта ошибка присутствует в инструкции на data.nag.ru, я не заметил

К сожалению, это не изменило ситуацию вообще никак.

 

4. Тут я писал не об этом. Что пароли скрыты, причем так что даже не поймешь заданы они или нет (странная реализация), я уже понял.

Я о том, что в настройках адаптера, если судить по инструкции, вообще не фигурируют пароли. Так зачем они указываются на шлюзе, если адаптер их не использует никак?

 

5. Понято. Попробую, когда хотя бы текущая схема заработает.

6. Шут с ним с этим вопросом. Пока бы с имеющимися разобраться.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this