Jump to content
Калькуляторы

Настройка RB450G на 4 локальных сети с подключением к провайдеру по PPTP

Есть локальная сеть с подключением к провайдеру по PPTP на 100 Мбит/с, в которой крутяться такие сервисы как игровые сервера, NASы под раздачу торрентов, web-сервера (в будущем), и обычные юзеры желающие пошастать по интернету (их немного, я и еще 2-3е).

Это все нужно разделить, т.е. создать следующие локальные сети:

192.168.1.0 (ether2) - Для моих личных девайсов в квартире (PC, htpc и прочие радости), еще тут будет UPS APC, что бы можно было разослать пакет завершения работы на все локальные сети.

192.168.2.0 (ether3) - NASы и Web сервера.

192.168.3.0 (ether4) - Игровые сервера.

192.168.4.0 (ether5) - Те двое-трое юзеров любящих пошастать по интернету (Соседи, пристыкованны по витой паре).

ether1 - это WAN с кабелем провайдера.

 

В порты 2-5 RB450G подключаются коммутаторы и дальше пошли уже к устройствам витухи.

 

Оборудование из разных сетей должно видеть остальных.

 

До этого были D-link'и, после долгого курения манов и манипуляций с настройками что в итоге ничего не дало решил написать сюда, может тут посдкажут детальнее...

Поднять PPTP с провайдером так же не удалось, хотя вроде бы все правильно настроил. Единственное насторожило что нельзя было выбрать интерфейс для него.

Share this post


Link to post
Share on other sites

Ну так прописываете на каждом порту свою сети вида 192.168.1.1/24, все клиенты используют его в качестве шлюза по умолчанию. Видеть друг друга будут без проблем, только правило ната делайте не по выходному интерфейсу, а по подсетям, где src = 192.168.0.0/16, dst = ! 192.168.0.0/16 и все сразу заработает.

Share this post


Link to post
Share on other sites

Saab95, т.е. в IP -> Adress list добавляем интерфесам шлюзы 192.168.x.1, после чего настраиваем DHCP (IP -> DHCP Server) для каждой подсети по своему вкусу (в моем случае это выдача адресов в диапазоне 192.168.x.200-192.168.x.250 для всяких устройств использующих DHCP).

 

Про нат я не понял (да и обилие настроек ната там пугает)... С консольными командами пока все сложно, тем более когда только что начал знакомиться с RouterOS...

Можно сказать я очень новичек в работе с RouterOS.

 

Про PPTP не подскажете почему он не хотит у меня поднимать сессию с провайдером? Может чего то где то не добавил?

Share this post


Link to post
Share on other sites

Saab95, т.е. в IP -> Adress list добавляем интерфесам шлюзы 192.168.x.1, после чего настраиваем DHCP (IP -> DHCP Server) для каждой подсети по своему вкусу (в моем случае это выдача адресов в диапазоне 192.168.x.200-192.168.x.250 для всяких устройств использующих DHCP).

 

Про нат я не понял (да и обилие настроек ната там пугает)... С консольными командами пока все сложно, тем более когда только что начал знакомиться с RouterOS...

Можно сказать я очень новичек в работе с RouterOS.

 

Про PPTP не подскажете почему он не хотит у меня поднимать сессию с провайдером? Может чего то где то не добавил?

 

Вот тут почитайте про настройку - http://www.lanmart.ru/blogs/mikrotik-rb751u-2hnd_rezim-besprovodnyj-router/

 

Нат настраивается легко, нужно только понять суть=) Адрес листы вам не нужны, и вообще на микротике основное правило - это не настраивать ничего лишнего, в том числе нужно сбрасывать начальную конфигурацию через меню system-reset configuration, поставив галочку no-defaults. Далее прописываете адреса на интерфейсах и вешаете на каждый свой DHCP сервер через конструктор в соответствующем разделе меню.

 

PPtP нужно создать клиента, указать адрес сервера и логин с паролем. Должен соединиться без проблем, если адрес провайдера пингуется с устройства. Но в начальной конфигурации как раз и могут быть косяки с ними=)

Share this post


Link to post
Share on other sites

Saab95, ман завтро почитаю.

В том то и дело что дефолтные настройки не ставлю, настраиваю с нуля, но в Interfaces у данного PPTP подключения передача/прием по нулям стоят, хотя сам порт данными обменивается с провайдером. При попытке пинга с роутера до какого либо ip он мне пишет No routing (мог немного напутать).

Разве все таки для него где то не нужно задавать к какому интерфесу он относиться?

Share this post


Link to post
Share on other sites

SOFTOLAB, для того чтоб поднять PPTP на провайдера, вам нужно на ether1 назначить IP адрес, который выдал провайдер, ну или адрес принадлежащий сети провайдера.

/ip address add interface=ether1 address=1.1.1.1/24

И само подключение к провайдеру, где 1.1.1.2 ip адрес PPTP сервера провайдера:

/interface pptp-client add add-default-route=yes disabled=no connect-to=1.1.1.2 name=login password=pass

чтоб повешать подсеть на порт нужно назначить локальный адрес:

/ip address add interface=ether2 address=192.168.1.1/24

И включить нат:

/ip firewall nat add src-address=192.168.1.0/24 dst-address=!192.168.0.0/16 chain=srcnat action=masquerade

Edited by wmdumb

Share this post


Link to post
Share on other sites

В PPP подключении нужно галочку дефолтный шлюз поставить, а то трафик по нему не побежит.

Share this post


Link to post
Share on other sites

ну в моем примере есть та галочка :)

 

add-default-route=yes

Share this post


Link to post
Share on other sites

Получается я все правильно сделал касательно PPTP, единственное нужно на первый интерфейс назначить IP адрес, но проблема в том что провайдер выдает динамику из множества подсетей, как быть в таком случае?

Share this post


Link to post
Share on other sites

Вам известен адрес ВПН сервера на который вы должны подконектиться?

Share this post


Link to post
Share on other sites

Получается я все правильно сделал касательно PPTP, единственное нужно на первый интерфейс назначить IP адрес, но проблема в том что провайдер выдает динамику из множества подсетей, как быть в таком случае?

 

Настроить DHCP Client и получить адрес от провайдера автоматически. Смотрите в меню IP->DHCP Client, там нужно добавить интерфейс, идущий в сторону провайдера.

Share this post


Link to post
Share on other sites

wmdumb, да, IP адрес их VPN сервера я знаю.

Saab95, я пока воспользовался их фишкой "СразуИнтернет", там типа все параметры роутер по DHCP получает на WAN порт, и PPTP не нужен. Потом хочу все же поднять PPTP, а то их фишка иногда сбоит... Пока собственно DHCP клиент на этот порт кинул как вы и написали. Работает.

 

PS: RB что то сильно греется даже с уменьшенной до 300MHz частотой, это нормально?

Edited by SOFTOLAB

Share this post


Link to post
Share on other sites

То, что греется это нормально, внутри температуру процессора всегда 45-55 показывает. А корпус реально горячий.

Share this post


Link to post
Share on other sites

Saab95, у меня рядом с вольтметром показывает 66 градусов (и сам горячий), хотя не под нагрузкой и стоит в плохладном углу... Частота 400MHz... Откуда такая температура не понятно.

Share this post


Link to post
Share on other sites

Откройте корпус и направьте на процессор вентилятор, увидите, что температура понижается. Далее аккуратно отклейте радиатор, удалите термолипучку, смажьте чип термопастой, а на углы капельки клея, установите радиатор обратно. Результат видно сразу. Хотя эти устройства и с температурой 66 градусов работают годами без проблем.

Share this post


Link to post
Share on other sites

Saab95, понятно, просто странным покалась такая температура в простое.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this