Jump to content
Калькуляторы

SNR-S3750G-24S-E BGP OSPF

здравствуйте, проблема такая есть коммутатор:

SNR-S3750G-48S-E#sh version
 SNR-S3750G-48S-E Device, Compiled on May 16 20:30:00 2013
 sysLocation Ak.Vonsovskogo str. 1-118, Ekaterinburg, Russia
 CPU Mac f8:f0:82:10:18:d1
 Vlan MAC f8:f0:82:10:18:d0
 SoftWare Version 7.0.3.1(R0058.0002)
 BootRom Version 7.1.4
 HardWare Version 1.0.2
 CPLD Version N/A
 Serial No.:SW032810D610000106
 Copyright (C) 2013 NAG LLC
 All rights reserved
 Last reboot is cold reset.
 Uptime is 1 weeks, 1 days, 0 hours, 46 minutes

 

на нем поднят BGP, OSPF , spanning-tree mode rstp.

При смене топологи в сети постепенно начинает падать линк, сначала пинги увеличиваются, минут через 10 связь вообще пропадает. после того как я рву связь на комутаторе с которым он соединен

conf t
int gi 3/12
sh
no sh

связь восстанавливается

 

SNR-S3750G-48S-E# show running-config

 

spanning-tree
spanning-tree mode rstp
spanning-tree priority 8192

Interface Ethernet1/0/7
description 24_lan
switchport mode trunk
switchport trunk allowed vlan 524;808
switchport trunk native vlan 808
!
Interface Ethernet1/0/8
description 24_lan
switchport mode trunk
switchport trunk allowed vlan 524;808
switchport trunk native vlan 808

Interface Ethernet1/0/48
description link to cisco
no spanning-tree
switchport mode trunk
switchport trunk allowed vlan 202

interface Vlan524
ip address 10.24.0.1 255.255.0.0
ip address 91.219.139.97 255.255.255.240 secondary

interface Vlan808
description default vlan for 10.24.0.0
ip address 192.168.162.1 255.255.255.0

router ospf 1
ospf router-id 91.219.136.131
passive-interface Vlan524
passive-interface Vlan526
passive-interface Vlan527
passive-interface Vlan528
passive-interface Vlan529
passive-interface Vlan531
passive-interface Vlan532
passive-interface Vlan525
passive-interface Vlan1
passive-interface Vlan806
passive-interface Vlan807
passive-interface Vlan808
passive-interface Vlan809
passive-interface Vlan810
network 10.0.0.0 0.255.255.255 area 0
network 91.219.136.0 0.0.3.255 area 0
network 91.237.220.0 0.0.3.255 area 0
network 192.168.0.0 0.0.255.255 area 0

router bgp 51655
bgp log-neighbor-changes
neighbor 91.219.136.141 remote-as 51655
neighbor 91.219.136.141 description "shaper2"
neighbor 91.219.136.141 weight 1
neighbor 91.219.136.141 next-hop-self
neighbor 91.219.136.142 remote-as 51655
neighbor 91.219.136.142 description "shaper1"
neighbor 91.219.136.142 next-hop-self
!
ip route 10.0.0.0/8 null0
ip route 10.220.0.0/16 91.219.136.129
ip route 69.167.150.99/32 91.219.136.129
ip route 69.167.154.0/24 91.219.136.129
ip route 91.219.136.0/22 null0
ip route 91.237.220.0/22 null0
ip route 159.253.19.190/32 91.219.136.129
ip route 172.16.0.0/12 91.219.136.129
ip route 172.32.0.0/24 91.219.136.129
ip route 192.168.0.0/16 null0
ip route 192.168.168.1/32 91.219.136.129
ip route 192.168.225.0/24 91.219.136.129
ip route 193.33.232.0/23 91.219.136.129

 

Подскажите пожалуйста причину разрыва связи

Edited by AlexSt

Share this post


Link to post
Share on other sites

постепенно начинает падать линк

Как то странно звучит)) либо он есть, либо его нет. Постепенно он падать не может. А в логах есть чего нибудь?

Share this post


Link to post
Share on other sites

чтобы было понятно

64 bytes from 91.219.136.131: icmp_req=1 ttl=63 time=1.21 ms
64 bytes from 91.219.136.131: icmp_req=2 ttl=63 time=1.22 ms
64 bytes from 91.219.136.131: icmp_req=3 ttl=63 time=1.63 ms
64 bytes from 91.219.136.131: icmp_req=4 ttl=63 time=1.16 ms
64 bytes from 91.219.136.131: icmp_req=5 ttl=63 time=1.31 ms
64 bytes from 91.219.136.131: icmp_req=6 ttl=63 time=1.19 ms
64 bytes from 91.219.136.131: icmp_req=7 ttl=63 time=1.20 ms
64 bytes from 91.219.136.131: icmp_req=8 ttl=63 time=1.28 ms
64 bytes from 91.219.136.131: icmp_req=9 ttl=63 time=1.17 ms
64 bytes from 91.219.136.131: icmp_req=10 ttl=63 time=1.17 ms
64 bytes from 91.219.136.131: icmp_req=11 ttl=63 time=1.26 ms
64 bytes from 91.219.136.131: icmp_req=12 ttl=63 time=1.30 ms
64 bytes from 91.219.136.131: icmp_req=13 ttl=63 time=1.27 ms
64 bytes from 91.219.136.131: icmp_req=14 ttl=63 time=1.24 ms
64 bytes from 91.219.136.131: icmp_req=15 ttl=63 time=3.25 ms
64 bytes from 91.219.136.131: icmp_req=16 ttl=63 time=89.9 ms
64 bytes from 91.219.136.131: icmp_req=17 ttl=63 time=86.6 ms
64 bytes from 91.219.136.131: icmp_req=18 ttl=63 time=227 ms
64 bytes from 91.219.136.131: icmp_req=19 ttl=63 time=150 ms
64 bytes from 91.219.136.131: icmp_req=20 ttl=63 time=177 ms
64 bytes from 91.219.136.131: icmp_req=21 ttl=63 time=259 ms
64 bytes from 91.219.136.131: icmp_req=22 ttl=63 time=261 ms
64 bytes from 91.219.136.131: icmp_req=23 ttl=63 time=242 ms
64 bytes from 91.219.136.131: icmp_req=24 ttl=63 time=193 ms
64 bytes from 91.219.136.131: icmp_req=25 ttl=63 time=293 ms
64 bytes from 91.219.136.131: icmp_req=26 ttl=63 time=351 ms

 

Затем вообще потери увеличиваются до полного пропадания связи

на 14 реквесте перезагружаю комутатор L2 в кольцевой топологии

 

а ето после релинка вручную

 

64 bytes from 91.219.136.131: icmp_req=62 ttl=63 time=217 ms
64 bytes from 91.219.136.131: icmp_req=63 ttl=63 time=335 ms
64 bytes from 91.219.136.131: icmp_req=64 ttl=63 time=404 ms
64 bytes from 91.219.136.131: icmp_req=101 ttl=63 time=1.26 ms
64 bytes from 91.219.136.131: icmp_req=102 ttl=63 time=1.20 ms
64 bytes from 91.219.136.131: icmp_req=103 ttl=63 time=1.15 ms
64 bytes from 91.219.136.131: icmp_req=104 ttl=63 time=1.23 ms
64 bytes from 91.219.136.131: icmp_req=105 ttl=63 time=1.49 ms
64 bytes from 91.219.136.131: icmp_req=106 ttl=63 time=1.17 ms
64 bytes from 91.219.136.131: icmp_req=107 ttl=63 time=1.13 ms
64 bytes from 91.219.136.131: icmp_req=108 ttl=63 time=1.52 ms
64 bytes from 91.219.136.131: icmp_req=109 ttl=63 time=1.15 ms
64 bytes from 91.219.136.131: icmp_req=110 ttl=63 time=1.20 ms
64 bytes from 91.219.136.131: icmp_req=111 ttl=63 time=1.17 ms

 

А с физическим линком все в порядке

Edited by AlexSt

Share this post


Link to post
Share on other sites

Вот схема:

netmap.jpg

В логах пусто

Каждый L3 коммутатор обслуживает свой rstp

Edited by AlexSt

Share this post


Link to post
Share on other sites

Смотрите свой RSTP - стоит у нас такая железка с BGP+OSPF но без RSTP и проблем не видим.

Share this post


Link to post
Share on other sites

В том то и дело что на интерфейсе нет рстп из конфига видно, почему при перестройки топологии участвует этот интерфейс? может опцию

какую прилепить типа портфаст?

Edited by AlexSt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this