Jump to content
Калькуляторы

локальный сервер Mikrotik маршрутизация

Очень давно не могу сделать такую маршрутизацию

 

Допустим есть микротик RB750

 

Порты микротика

 

1. аплинк

2. адрес 10.10.100.205/24 к порту подключен вебсервер-файлопомойка 10.10.100.200/24

3. поднят 1й рррое сервер (172.44.50.1)

4. поднят 2й рррое сервер (172.44.51.1)

5. поднят 3й рррое сервер (172.44.52.1)

 

Так вот как заставить клиентов которые подключены через рррое, видеть сервер 10.10.100.200/24 который находится на 2 порту?

Edited by laplundik

Share this post


Link to post
Share on other sites

Прописать маршрутизацию и отключить нат по внутренним адресам. При этом желательно использовать единую внутреннюю адресацию.

 

На файлопомойке нужно прописать маршрут в сторону микротика, с адресами подсетей 172.44.х, но проще всего включить OSPF на PPPoE серверах и вашем микротике. О маршрутах они после этого сами договорятся, только не забудьте стереть все статические маршруты.

Share this post


Link to post
Share on other sites

с ospf я фиг когда разберусь

А то что выше можно поподробнее?

Share this post


Link to post
Share on other sites

с ospf я фиг когда разберусь

А то что выше можно поподробнее?

 

С OSPF не нужно разбираться, заходите в меню Routing->OSPF, открываете вкладку Network, жмете + и добавляете туда 0.0.0.0/0 на всех устройствах. Через несколько секунд все устройства смогут работать. Что бы был доступ в интернет, если он идет тоже через микротик, введите дефолтный маршрут, только и всего.

 

Если хотите вручную, то надо сделать следующее:

 

1. На файлопомойке прописать маршрут, что сеть 172.44.50.0/24, 52 и 52 находятся на 10.10.100.205.

2. На микротике в правиле ната, если он его делает, указать src.address = 172.44.50.0/24 и dst.address = ! 10.10.100.0/24, а не по выходному интерфейсу, как любят.

 

После этого все должно заработать. PPPoE позволяет раздавать одинаковые адреса через все сервера, поэтому зря вы нагородили 3 разных сети на нем. Можно было выдавать адреса и из одного куска.

Share this post


Link to post
Share on other sites

Запустил OSPF в интерфейсах появилось куча записей 150148_thumb.jpg

 

Но но сервер так и не видно

Share this post


Link to post
Share on other sites

покажите как настроен нат /ip firewall nat export

 

тут один маршрутизатор, городить ospf считаю лишним.

 

все делается одни правилом нат.

 

создаем адрес лист со всеми локальными подсетями:

 

/ip firewall address-list

add address=172.44.50.0/24 disabled=no list=local

add address=172.44.51.0/24 disabled=no list=local

add address=172.44.52.0/24 disabled=no list=local

add address=10.10.100.0/24 disabled=no list=local

 

и само правила ната:

 

/ip firewall nat

add action=masquerade chain=srcnat disabled=no dst-address-list=!local src-address-list=local

Share this post


Link to post
Share on other sites

сейчас у меня так, три канала в интернет

 

/ip firewall nat
add action=netmap chain=dstnat comment="MIKROBILL WEB-CAP" disabled=no \
   dst-address=!10.10.100.200 dst-port=80 protocol=tcp src-address-list=\
   MikroBill_OFF_Users to-addresses=10.10.100.200 to-ports=81

add action=netmap chain=dstnat comment=Site disabled=no dst-port=80 \
   in-interface=1-wan-ttk protocol=tcp to-addresses=10.10.100.200 to-ports=\
   80

add action=masquerade chain=srcnat comment="MIKROBILL INTERFACE NAT_138" \
   disabled=no out-interface=138 src-address-list=MikroBill_LanBallance_138

add action=masquerade chain=srcnat comment="MIKROBILL INTERFACE NAT_176" \
   disabled=no out-interface=176 src-address-list=MikroBill_LanBallance_176

add action=masquerade chain=srcnat comment=\
   "MIKROBILL INTERFACE NAT_1-wan-ttk" disabled=no out-interface=1-wan-ttk \
   src-address-list=MikroBill_LanBallance_1-wan-ttk

add action=masquerade chain=srcnat comment="MIKROBILL USERS NAT" disabled=no \
   src-address-list=MikroBill_All_Drop

add action=netmap chain=dstnat comment="MIKROBILL 2WEB-CAP" disabled=no \
   dst-address=!10.10.100.200 dst-port=80 protocol=tcp src-address-list=\
   !MikroBill_Users to-addresses=10.10.100.200 to-ports=81

Share this post


Link to post
Share on other sites

У вас нат на все адреса, нужно локальные адреса добавить в исключения, для этого нужно создать один алрес лист и в него добавить все локальные подсети, и во всех правилах ната указать в поле dst-address-list c префиксом !

 

В вашем случее нужно создать адрес лист:

 

/ip firewall address-list

add address=172.44.50.0/24 disabled=no list=local

add address=172.44.51.0/24 disabled=no list=local

add address=172.44.52.0/24 disabled=no list=local

add address=10.10.100.0/24 disabled=no list=local

 

и отредактировать правила ната:

 

add action=masquerade chain=srcnat comment="MIKROBILL INTERFACE NAT_138" \

disabled=no out-interface=138 src-address-list=MikroBill_LanBallance_138 dst-address-list=!local

 

add action=masquerade chain=srcnat comment="MIKROBILL INTERFACE NAT_176" \

disabled=no out-interface=176 src-address-list=MikroBill_LanBallance_176 dst-address-list=!local

 

add action=masquerade chain=srcnat comment=\

"MIKROBILL INTERFACE NAT_1-wan-ttk" disabled=no out-interface=1-wan-ttk \

src-address-list=MikroBill_LanBallance_1-wan-ttk dst-address-list=!local

 

add action=masquerade chain=srcnat comment="MIKROBILL USERS NAT" disabled=no \

src-address-list=MikroBill_All_Drop dst-address-list=!local

 

 

Ну и на серваке 10.10.100.200 должен быть указан шлюз 10.10.100.205, или добавлен статический роут на подсети 172.44....

Share this post


Link to post
Share on other sites

пинг доходит до 10.10.100.205

до сервака нет,

 

кстати клиенты получают через рррое маску 255.255.255.255

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this