Jump to content
Калькуляторы

Конфигурация q-in-q vlan-per-user на des-3200

Решил построить стенд на DES-3200 с qinq. Вот уж третий день проходит, не могу прийти к результату.

Схема

Linux eth1 //intel 82576
       |
       | /-eth1.100.101
       |/
     eth1.100
       |
       |
     vlan100
       |
     DES-3200-28 C1
       |
     vlan101
       |
Linksys SPS 224G4

 

В результате необходимо получить на сервере: vlan101, который будет инкапсулирован на DES-3200-28 C1 в vlan100 и идти с Linksys SPS 224G4.

Настраиваю Linksys SPS 224G4 следующим образом.

vlan database
vlan 101
interface etherbet e1 //Интерфейс к клиенту
switchport mode access
switchport access vlan 101
exit
interface ethernet g4
switchport mode trunk
switchport trunk allowed vlan add 101
exit

 

Далее настройка D-Link DES-3200-28 C1;

Руководствуясь статьями http://blog.peter.am/index.php/2011/01/22/q-in-q-linux-d-link,

http://my.opera.com/Aminux/blog/2012/06/17/q-in-q

 

Привел к следующей конфигурации

create tag 100
enable qinq
config vlan vlanid 1 delete all
config vlan vlanid 100 add tagged 1
config vlan vlanid 100 add tagged 26
config qinq ports 1 role uni outer_tpid 0x8100
config qinq ports 26 role nni outer_tpid 0x8100
create vlan_translation ports 1 add cvid 101 svid 100
create vlan_translation ports 26 add cvid 101 svid 100

 

Даю на интерфейсы eth1.100.101 и клиентскому PC ip адреса и ничего не работает, tcpdump молчит. Пакеты не бегают вообще. На сервере vlan работают, проверял.

 

Подскажите где я допускаю ошибку? или опишите пожалуйста Ваш метод построения q-in-q vlan-per-user.

Edited by Dimka88

Share this post


Link to post
Share on other sites

create vlan_translation ports 26 add cvid 101 svid 100

 

Работает только на UNI портах поэтому он тут не нужен. А так вроде бы всё правильно - если подключится к 26 порту коммутатора, то снифером в нём вы должны увидеть вланы с 2мя тэгами

 

Прошивка на DES-3200 последняя? А то там были проблемы с tpid 0x8100

Edited by Butch3r

Share this post


Link to post
Share on other sites

Butch3r, спасибо за ответ, прошивка последняя.

create vlan_translation ports 26 add cvid 101 svid 100
понял, убрал.

tcpdump -i eth1 очень подозрительно молчит после включения qinq.

Share this post


Link to post
Share on other sites

Поменял сетевую карту, картина таже, пакеты ICMP бегают по 100 влану, по eth1.100.101 никакого трафика не пробегало.

Share this post


Link to post
Share on other sites

Вот детальная конфигурация DES-3200

DES-3200-28:admin#show switch

Command: show switch

 

Device Type : DES-3200-28 Fast Ethernet Switch

MAC Address : C8-BE-19-FC-B8-20

IP Address : 192.168.1.2 (Manual)

VLAN Name : VLAN100

Subnet Mask : 255.255.255.0

Default Gateway : 0.0.0.0

Boot PROM Version : Build 4.00.002

Firmware Version : Build 4.32.B006

Hardware Version : C1

Serial Number : R3DZ1CA005618

System Name :

System Location :

System Uptime : 0 days, 2 hours, 44 minutes, 33 seconds

System Contact :

Spanning Tree : Disabled

GVRP : Disabled

IGMP Snooping : Disabled

MLD Snooping : Disabled

VLAN Trunk : Disabled

Telnet : Enabled (TCP 23)

Web : Enabled (TCP 80)

SNMP : Disabled

SSL Status : Disabled

SSH Status : Disabled

802.1X : Disabled

Jumbo Frame : Disabled

CLI Paging : Enabled

MAC Notification : Disabled

Port Mirror : Disabled

SNTP : Disabled

Syslog Global State : Disabled

Single IP Management : Disabled

Password Encryption Status : Disabled

 

DES-3200-28:admin#show qinq

Command: show qinq

 

QinQ Status : Enabled

 

 

Command: show qinq ports 1

 

 

Port ID: 1

---------------------------------------------------------

Role: UNI

Miss Drop: Disabled

Outer Tpid: 0x8100

Add Inner Tag: Disabled

 

Command: show qinq ports 26

 

Port ID: 26

---------------------------------------------------------

Role: NNI

Miss Drop: Disabled

Outer Tpid: 0x8100

Add Inner Tag: Disabled

 

 

Command: show vlan_translation

 

Port CVID SPVID Action Priority

----- -------- -------- ------- ---------

1 101 100 Add -

 

Total Entries: 1

Command: show vlan ports 1

 

Port VID Untagged Tagged Dynamic Forbidden

----- ---- -------- ------ ------- ---------

1 100 - X - -

 

Command: show vlan ports 26

 

Port VID Untagged Tagged Dynamic Forbidden

----- ---- -------- ------ ------- ---------

26 100 - X - -

 

Share this post


Link to post
Share on other sites

Кто-то выкладывал в форуме мануалы по длинковскому qinq.

Поставьте в разделе gvrp для uni-порта pvid=100(данная метка будет навешиваться). Вланы висящие на портах влияют лишь на пропуск/непропуск уже помеченного трафика.

config port_vlan 1 gvrp_state disable ingress_checking enable acceptable_frame admit_all pvid 100

Ну и translation не нужны в данной ситуации.

Edited by kayot

Share this post


Link to post
Share on other sites

kayot, сделал

config port_vlan 1 gvrp_state disable ingress_checking enable acceptable_frame admit_all pvid 100

И удалил vlan_translation, но опять же, молчит как рыба (пакетов нет). Попробую реализовать на cisco, если заработает, буду сапорт d-link пытать =)

Share this post


Link to post
Share on other sites

Попробуй порт 1 сделать untagged, чтоб в все пакеты от туда оборачивались 2м тэгом

Share this post


Link to post
Share on other sites

Попробуй порт 1 сделать untagged, чтоб в все пакеты от туда оборачивались 2м тэгом

Немного позже попробую (от него я просто так не отстану, дело принципа). На циске 4 часа ушло что бы по xmodem реанимировать её после проблем с flash: и 3 минуты, что бы настроить qiniq.

 

Может кому пригодится

!

vlan 100

!

interface FastEthernet0/1

switchport access vlan 100

switchport mode dot1q-tunnel

!

interface GigabitEthernet0/2

port-type nni

switchport mode trunk

speed nonegotiate

no cdp enable

 

 

ну и не забыть про mtu

#show system mtu

 

System MTU size is 1508 bytes

System Jumbo MTU size is 1508 bytes

Routing MTU size is 1500 bytes

 

Edited by Dimka88

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this