Jump to content
Калькуляторы

Как ограничить скорость на interface vlan (DGS-3610)

Знающие люди, помогите пожалуйста. Есть железка Dlink DGS-3610. Не могу догнать каким способом можно ограничить скорость для Interface VLAN. Прикладываю часть конфига:

 

>!

>version v10.3(5T16), Release(90635)(Thu Jul 1 10:29:19 CST 2010 -ngcf70)

>co-operate enable

>!

>vlan 11

>!

>interface VLAN 11

> no ip proxy-arp

> ip address 192.168.11.1 255.255.255.252

 

Как можно ограничить скорость для "interface VLAN 11" ???

Share this post


Link to post
Share on other sites

На interface vlan нельзя повесить - не rate-limit, не traffic-shape. Если использовать policy-map то на interface vlan нельзя повесить service-policy

 

>DGS-3610(config-if-VLAN 11)#rate-limit ?

>% Unrecognized command.

>

>DGS-3610(config-if-VLAN 11)#traffic-shape ?

>% Unrecognized command.

>

>DGS-3610(config-if-VLAN 11)#service-policy ?

>% Unrecognized command.

 

Народ помогите плиз ......

Share this post


Link to post
Share on other sites

Я делал как-то...

Нужно делать policy-map и вешать его на физический интерфейс. В самом роутмапе как-то матчить по влан-у. Сейчас поищу конфиг, может осталось...

 

upd. А не, нихрена. Нельзя там по vlan-у матчить. Только по

ip access-list {extended | standard} { acl-id | acl-name }

Or mac access-list extended {acl-id | acl-name}

Or expert access-list extended {acl-id | acl-name}

Or ipv6 access-list extended acl-name

Or access-list acl-id series commands

 

Так что только изврат, навроде dscp метки и матчинга по ней.

Edited by vurd

Share this post


Link to post
Share on other sites

Я делал как-то...

Нужно делать policy-map и вешать его на физический интерфейс. В самом роутмапе как-то матчить по влан-у. Сейчас поищу конфиг, может осталось...

 

upd. А не, нихрена. Нельзя там по vlan-у матчить. Только по

ip access-list {extended | standard} { acl-id | acl-name }

Or mac access-list extended {acl-id | acl-name}

Or expert access-list extended {acl-id | acl-name}

Or ipv6 access-list extended acl-name

Or access-list acl-id series commands

 

Так что только изврат, навроде dscp метки и матчинга по ней.

 

в exprest acl разве нельзя сделать permit vid ?

Share this post


Link to post
Share on other sites

Эксперт это у них вроде content match filter, указываем смещение в байтах и так далее. Я когда пробовал это исопльзовать для фильтрации uTP, то у меня свитч умирал совсем.

Есть еще вариант посмотреть прошивку 1.4.x, может быть там запилили. Но она меня не устроила совершенно, какие-то дикие проблемы начались, про которые я даже не помню уже.

Share this post


Link to post
Share on other sites

Сделал, вроде работает, но нормальное ли это решение так и не понял .... вот конфиг, может кому пригодится :

 

>!

>version v10.3(5T16), Release(90635)(Thu Jul 1 10:29:19 CST 2010 -ngcf70)

>co-operate enable

>!

>vlan 1

>!

>vlan 2

>!

>ip access-list standard 1

10 permit 192.168.11.0 0.0.0.3

>!

>ip access-list standard 2

>10 permit 192.168.11.4 0.0.0.3

>!

>class-map 1

> match access-group 1

>class-map 2

> match access-group 2

>!

>!

>policy-map 1

> class 1

> police 1024 1024 exceed-action drop

> class 2

> police 2048 1024 exceed-action drop

>!

>interface GigabitEthernet 0/1

> switchport mode trunk

> service-policy input 1

> service-policy output 1

>!

>interface VLAN 1

> ip address 192.168.11.1 255.255.255.252

>!

>interface VLAN 2

> ip address 192.168.11.5 255.255.255.252

Edited by zloy-puzik

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this