Jump to content
Калькуляторы

Catalyst 3750, VLAN - волшебная ситуация. Помогите советом!

Дано:

Catalyst 3750 (S). На его 4-портах сконфигурирован access-VLAN:

дело выглядит так:

1/0/5 подключен ISP (195.200.0.1/24)

1/0/6 сервер Linux (195.200.0.2/24)

1/0/7 D-link DFL-860E (195.200.0.3/24)

1/0/8 Ноутбук HP (195.200.0.4/24)

 

Сервер Linux и ноутбук HP друг друга пингуют без проблем, а вот D-link и ISP не пингуются.

 

Если все четыре провода воткнуть в другой "глупый коммутатор" D-Link DGS-1008 то все пингуется. ACL-на циске нет (брандмауры везде отключены). ARP-кэш на сервере Linux выглядит так:

xxx (195.200.0.4/24) at 10:1F:74:EA:C9:BE [ether] on eth1

xxx (195.200.0.1/24) at <incomplete> on eth1

xxx (195.200.0.3/24) at <incomplete> on eth1

 

P.S Помогите, любыми идеями!

 

cisco#show running-config
!
vlan 151
!
!
interface GigabitEthernet1/0/5
switchport access vlan 151
switchport mode access
!
interface GigabitEthernet1/0/6
switchport access vlan 151
switchport mode access
!
interface GigabitEthernet1/0/7
switchport access vlan 151
switchport mode access
duplex full
!
interface GigabitEthernet1/0/8
switchport access vlan 151
switchport mode access
!


### выввод одного из интерфейсов
cisco#show interfaces GigabitEthernet 1/0/7
GigabitEthernet1/0/7 is up, line protocol is up (connected)
 Hardware is Gigabit Ethernet, address is 0006.f651.7407 (bia 0006.f651.7407)
 MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX
 input flow-control is off, output flow-control is unsupported
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input never, output 00:00:01, output hang never
 Last clearing of "show interface" counters 00:21:01
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 2000 bits/sec, 4 packets/sec
    533 packets input, 34112 bytes, 0 no buffer
    Received 501 broadcasts (0 multicasts)
    0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 0 multicast, 0 pause input
    0 input packets with dribble condition detected
    4450 packets output, 346818 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets

Share this post


Link to post
Share on other sites

1. show mac adress-table покажите

2. Если настроить один из ипов непосредственно на каталисте, с него будет пинговаться? Int vlan 151 \ ip addr 195.200.0.5 255.255.255.0

3. Сделайте миррор проблемного порта и посмотрите снифером что там происходит

 

Должно быть что-то совсем простое и не достает какой-то информации

Share this post


Link to post
Share on other sites

conf t

int range Gi 1/0/5 - 8 (ну или по одному)

spanning-tree bpdufilter enable

no cdp enable

 

 

И проверьте show logging до этого, есть ли там подозрительное

Share this post


Link to post
Share on other sites

nuclearcat и vurd, все ваши предположения смогу проверить только после 19:00 (в рабочее время не могу проверить). Так, что отпишусь только ближе к вечеру.

Edited by cisco-911

Share this post


Link to post
Share on other sites

А гляньте show spanning vla 151 ?

Share this post


Link to post
Share on other sites

проблема решилась (спасибо всем в частности nuclearcat)

Решение вопроса:

arvak(config)#interface range GigabitEthernet 1/0/5-8

arvak(config-if-range)#spanning-tree bpdufilter enable

arvak(config-if-range)#end

 

P.S Народ если не сложно, можно чуток от вас услышать ликбеза почему STP так себя ведет?

Share this post


Link to post
Share on other sites

Откровенно говоря протокол STP ведет себя хорошо. Работает из коробки и требует минимальной конфигурации для небольшой сети. Другой вопрос, что в больших сетях с большим количеством колец и цепочек коммутаторов могут быть приколы. Однако это не отменяет полезность протокола. Если интересует работа протокола можете почитать на вики http://ru.wikipedia.org/wiki/STP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this