Jump to content
Калькуляторы

SuperVlan в SNR S3750G-24S-E SuperVlan и MulticastVlan

Вопрос знатокам:

В документации SNR3750G-24S про SuperVlan сказано:

 

1.8.4 Super VLAN Troubleshooting

- Supervlan and these functions (VRRP, dynamic VLAN, private VLAN, multicast

VLAN, etc.) are mutually exclusive, so they should not be used at the same time.

 

Значит ли это, что при использовании Supervlan никак нельзя использовать multicast или нельзя что бы один VLAN участвовал в Supervlan и ассоциировался с multicast VLAN?

 

Каким образом на этом коммутаторе одновременно терминировать VLAN-ы и использовать igmp-snooping для IPTV?

Share this post


Link to post
Share on other sites

для iptv используйте коммутаторы доступа с одим multicast вланом и подмешивайте в абонентские порты отдельно.

Share this post


Link to post
Share on other sites

Multicast VLAN предназначен для использования на уровне доступа, а не на аггрегации.

Share this post


Link to post
Share on other sites

Andrey Savenkov

Извините за бестолковость, пытаюсь разобраться в умных сетевых технологиях ...

Про доступ я понял, в базе знаний доступно описано, попробовал на стенде SNR-S2940 - работает, теперь задача как этот мультикаст доставить до доступа.

 

В сети в основном описание для CISCO и используется PIM, в то же время говорят, что если только один маршрутизатор, то PIM не нужен.

 

Правильно я понял, что на агрегации и в ядре мультикаст идет в обычном VLAN (не нужно объявлять его multicast VLAN)?

 

Прокрутил доку до конца и увидел примерчик по настройке, завтра попробую ... Только не понял обязательно, как в примере, источник мультикаста помещать в отдельный VLAN и затем включать ip pim dense-mode в нём и в VLAN, в котором пойдет мультикаст дальше до приемника? Нельзя сразу порт порт источника поместить в тот же VLAN, в котором пойдет мультикаст дальше до приемника?

 

Извините за "кашу" в голове, я ещё только учусь :)

Share this post


Link to post
Share on other sites

Олег Кривицкий

Покажите схему сети, на которой вы хотите реализовать мультикаст. Это поможет в поиске оптимального решения для вас.

Share this post


Link to post
Share on other sites

Олег Кривицкий

Покажите схему сети, на которой вы хотите реализовать мультикаст. Это поможет в поиске оптимального решения для вас.

Схема сети очень простая, звезда - оптика до дома, в центре SNR-S3750G-24, на доступе SNR-S2940, 2950, 2960. Источник мультикаста - сервер с getstream или astra. Пользователей около 200 в перспективе до 1000.

Сейчас сеть практически неуправляемая, статические серые адреса с НАТ. Есть блок PI /24.

Хочется сделать IPOE и раздавать белые адреса, подскажите что удобнее VLAN на коммутатор и DHCP с opt.82 или VLAN на пользователя DHCP по VLANу???

Терминировать VLANы планировал на SNR-S3750G-24.

post-47-071061000 1363265557_thumb.gif

Edited by Олег Кривицкий

Share this post


Link to post
Share on other sites

Добрый день.

 

По сети - мне кажется Вам будет проще и удобнее использовать схему VLAN на коммутатор доступа, раздавать клиентам IP-адреса по DHCP, также порекомендую использовать DHCP Snooping User Binding для предотвращения подмены IP клиентами.

 

По мультикасту - как вы писали, существует 2 варианта - спустить VLAN с мультикастом до доступа, и создать 2 VLAN'а для мультикаста (1 для источника и 1 для трафика в сторону абонентов). На мой взгляд, а также надеюсь многие коллеги со мной согласятся, гораздо интереснее и эффективнее будет использовать вариант с двумя вланами и PIM-SM между ними. Если использовать вариант 1, то весь мультикаст трафик будет сливаться на коммутаторы доступа, даже если на него нет подписчиков, что не есть хорошо.

Share this post


Link to post
Share on other sites

Так и не смог заставить работать supervlan на SNR-S3750G

SNR-S3750G-24S-E Device, Compiled on May 22 22:11:31 2012

SoftWare Version 6.2.139.18

BootRom Version 4.12.2

HardWare Version 1.0.2

CPLD Version 0.4

 

!

vlan 100

supervlan

subvlan 101-116

!

Interface Ethernet1/0/1

switchport mode trunk

switchport trunk allowed vlan 10;101

switchport trunk native vlan 5

.

.

.

!

Interface Ethernet1/0/14

switchport mode trunk

switchport trunk allowed vlan 10;114

switchport trunk native vlan 5

 

!

interface Vlan100

arp-proxy subvlan all

ip address 192.168.100.1 255.255.255.0

!forward protocol udp 67(active)!

ip helper-address 192.168.11.5

 

В порты 1 - 14 включены коммутаторы доступа SNR-S2950-24G

без supervlan-а всё работает нормально и со статикой и с DHCP opt82

когда создаю supervlan то при подключении клиентов 3750 говорит:

dublicate IP address vlan100

dhcp сервер:

Abandoning IP address 192.168.100.4: declined.

DHCPDECLINE of 192.168.100.4 from 1c:7e:e5:5d:f0:07 via 192.168.100.1: abandoned

клиент WinxpSP3 перебирает весь пул, но адрес так и не получает .... клиент Debian при включении адрес получает, но если выдернуть клиентский шнурок из порта и воткнуть обратно или сделать down-up интерфейса, то так же не может получить адрес.

Со статическими адресами примерно также: Debian работает, если не трогать провода и интерфейсы, винда при первом включении работает а после перезагрузки говорит конфликт адресов в сети ....:(

 

Подскажите кто знает, что я не так делаю????

Share this post


Link to post
Share on other sites

Доброго дня.

 

Попробуйте в конфигурации int vlan 100 заменить arp-proxy subvlan all на ip local proxy-arp, по результатам отпишитесь.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this