Jump to content
Калькуляторы

Mikrotik заканчивается память, зависает Съездил на объект, хочу помочь всем

Обнаружил, что Mikrotik зависает, свободной памяти становится всё меньше и меньше. Процессор уходит в потолок.

Чтоб не ездить из-за проблемы использую скрипт, его легко установить вставив в командную строку следующее:

 

/system scheduler

remove resource

add comment="" disabled=no interval=1m name=resource on-event=\

"/system script run resource" policy=\

reboot,read,write,policy,test,password,sniff,sensitive start-time=startup

/system script

remove resource

add name=resource policy=\

ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\

# Script resource v1.01\r\

\n# \CF\F0\EE\E2\E5\F0\FF\E5\EC \EF\E0\EC\FF\F2\FC, \E0 \E7\E0\F2\E5\EC \

\EF\F0\EE\F6\E5\F1\F1\EE\F0\r\

\n# \CF\E5\F0\E5\E7\E0\EF\F3\F1\EA\E0\E5\EC\F1\FF, \E5\F1\EB\E8 \F1\E2\EE\

\E1\EE\E4\ED\EE\E9 \EF\E0\EC\FF\F2\E8 \EC\E5\ED\E5\E5 5\CC\E1\r\

\n# \CF\E5\F0\E5\E7\E0\EF\F3\F1\EA\E0\E5\EC\F1\FF, \E5\F1\EB\E8 \E7\E0\E3\

\F0\F3\E7\EA\E0 \EF\F0\EE\F6\E5\F1\F1\EE\F0\E0 \E2 \F2\E5\F7\E5\ED\E8\E5 5\

\_\F1\E5\EA \E1\EE\EB\E5\E5 95%\r\

\n\r\

\n:local \"free-memory\" [/system resource get free-memory]\r\

\n:local \"cpu-load\" [/system resource get cpu-load]\r\

\n:delay 5\r\

\n:local \"cpu-load2\" [/system resource get cpu-load]\r\

\n\r\

\n:if (\$\"free-memory\" < 5000) do= {\r\

\n :log warning \"mem_err \$\"free-memory\"Kb\"\r\

\n /system reboot\r\

\n}\r\

\n\r\

\n:if (\$\"cpu-load2\" > 95) do= {\r\

\n :if (\$\"cpu-load\" > 95) do= {\r\

\n :log warning \"cpu_err \$\"cpu-load\"%\"\r\

\n /system reboot\r\

\n }\r\

\n}\r\

\n"

Edited by Соколов

Share this post


Link to post
Share on other sites

Обнаруженные мной проблемы с нехваткой памяти и с зависанием в следующем:

1. Надо отключить Web Proxy

2. Если в используемых скриптах ошибки и они не завершают работу, что видно в scripts jobs, память заканчивается, исправьте или отключите скрипты.

Edited by Соколов

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this