Jump to content
Калькуляторы

Cisco 7600 шейпинг клиентов на исход например на SIP-400 + 1-port 10GbE SPA LAN PHY v2

Доброе время суток!

 

Есть шасси 7604 + RSP720-3CXL + WS-6704-10GE(в данный момент другой просто нет).

 

При попытке установить service-policy на исход (пошейпить клиента на 10М с которым настроено BGP взаимодействие) столкнулся с ошибкой:

Router(config-subif)#service-policy output CLIENT-SHAPE-OUT 
shape average command is not supported in output direction for this interface
Configuration failed on TenGigabitEthernet3/1.29

- интерфейс:

interface TenGigabitEthernet3/1.29
description -= CLIENT =-
encapsulation dot1Q 29
ip address XXX.XXX.XXX.XXX 255.255.255.252
no cdp enable

- полиси:

 
policy-map CLIENT-SHAPE-OUT
 class class-default
  shape average 10485760

при этом полисинг вешается на исход без проблем:

policy-map CLIENT-SHAPE-OUT
 class class-default
  police 10485760

 

нашел тред на supportforums.cisco.com:

Q:

I tryed to configure policy on gigabit ethernet interface and got message -

pdc-c7604-gt(config)#policy-map OUTSIDE
pdc-c7604-gt(config-pmap)#  class ISA2SPB
pdc-c7604-gt(config-pmap-c)#shape average 256000
pdc-c7604-gt(config)#int gi1/9
pdc-c7604-gt(config-if)#service-policy output OUTSIDE
shape average command is not supported in output direction for this interface
Configuration failed on:
GigabitEthernet1/9

Why i can't do it?

 

A:

Hi!

It looks like you are using a Lan card there. Lan cand doesnot support shaping. You will require OSM WAN Ports (includes GE-WAN ports, but not GigabitEthernet ports) or wan cards like Flexwan/SIP200/SIP400 to support shaping.

Lan cards are lower end cards and donot have sufficient h/w resources to support shaping. The Qos functionality on Lan cards is limited as there is not much necessity of Qos on Lan side of the networks where ample bandwidth is available.

 

Таким образом для шейпинга на 10G линке надо брать SIP-400 + 1-port 10GbE SPA LAN PHY V2... или я в чем-то ошибаюсь?

 

У кого есть опыт использования 7604 + RSP720-3CXL + SIP-400 + 1-port 10GbE SPA LAN PHY V2?

Будет ли такая система шейпить на сабинтерфейсах вида:

interface TenGigabitEthernet3/1.29
description -= CLIENT =-
encapsulation dot1Q 29
ip address XXX.XXX.XXX.XXX 255.255.255.252
no cdp enable

 

Заранее спасибо!

Share this post


Link to post
Share on other sites

вам нужно шейп повесить на input а police на output иначе не взлетит

 

Почему?!

 

Позвольте уточнить: output - это от клиента в мир, а input - из мира к клиенту?

 

По-моему логичнее шейпить именно исходящий от клиента трафик...

Например в Cisco ASR-1000F + 1-port 10GbE SPA LAN PHY V2 у нас так настроено:

- интерфейс:

interface TenGigabitEthernet0/1/0.29
description -= CLIENT =-
encapsulation dot1Q 29
ip address XXX.XXX.XXX.XXX 255.255.255.252
service-policy CLIENT-SHAPE-IN
service-policy CLIENT-SHAPE-OUT
no cdp enable

- полиси:

policy-map CLIENT-SHAPE-IN
 class class-default
  police 10485760

policy-map CLIENT-SHAPE-OUT
 class class-default
  shape average 10485760

 

ДОБАВЛЕНО по горячим следам:

В datasheet Cisco SIP-400 в разделе Features указано:

- Egress Class-Based Weighted Fair Queuing (CBWFQ)

Traffic Classification, Shaping, and Bandwidth Policing

думаю это как раз и есть искомый шейпинг на исход от клиента

Edited by allan_sundry

Share this post


Link to post
Share on other sites

 

Почему?!

 

ну вот такая она эта цыска

 

Позвольте уточнить: output - это от клиента в мир, а input - из мира к клиенту?

Наоборот

Share this post


Link to post
Share on other sites

вам нужно шейп повесить на input а police на output иначе не взлетит

 

ПРОВЕРИЛ - НЕ РАБОТАЕТ

создал полиси:

policy-map CLIENT-SHAPE-IN
 class class-default
  shape average 10485760

и попробовал прибить его на вход:

Router(config-subif)#service-policy input CLIENT-SHAPE-IN
shape average command is not supported in input direction for this interface
Configuration failed on TenGigabitEthernet3/1.29

результат для меня был ожидаемый.

 

Похоже на линейных картах shape average не крутится ни на вход ни на исход как на них не смотри... Остается надеятся на SIP-400

Edited by allan_sundry

Share this post


Link to post
Share on other sites

ДОБАВЛЕНО по горячим следам:

В datasheet Cisco SIP-400 в разделе Features указано:

производительность у него 2.5Г =)

шейпинг в исходящем направлении на стандартных линейных картах не получится сделать. делайте на вход или ставьте ES карты или меняйте платформу

Share this post


Link to post
Share on other sites

производительность у него 2.5Г =)

шейпинг в исходящем направлении на стандартных линейных картах не получится сделать. делайте на вход или ставьте ES карты или меняйте платформу

Спасибо! Шейпинг не настолько критичен что-бы менять платформу, во всем же остальном 76-я пока устраивает.

 

C SIP-400 печальная ситуация... А что скажете о SIP-600? Или лучше сразу смотреть на ES?

 

Какая реальная производительность у ES-20?

Судя по описанию она вполне умеет шейпить на исход:

Queuing and shaping:

• Enhanced Class-based Weighted Fair Queuing (CBWFQ)

• Egress low-latency queuing (LLQ); Traffic inside LLQ may be shaped

• Two levels of queuing hierarchy

• Egress Shaping

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this