Jump to content
Калькуляторы

Скрипт резервирования для Микротик

Сразу скажу, инет и все форумы облазил, решения не нашел.

Есть микротик 750GL, к нему подходит два кабельных канала, основной и резервный. Настроил статические маршруты с метрикой 1 у основного и 2 у резервного.

Откидываю основной канал вручную, все нормально работает, микрот видит, что шлюз отпал и трафик начинает бежать через резервный.

Но меня такой вариант не устраивает, нужно что бы микротик переключался когда пропадает связь на мир, к примеру на 8.8.8.8

И так, беру скрипт:

:local PingCount 3;

 

:local CheckIp1 8.8.8.8;

:local CheckIp2 8.8.4.4;

 

:local rName [/system identity get name];

:local rDate [/system clock get date];

:local rTime [/system clock get time];

 

:local isp1 [/ping $CheckIp1 count=$PingCount];

:local isp2 [/ping $CheckIp2 count=$PingCount];

 

:local BackGw [/ip route get [find comment=gw2] disable];

#if main ISP is DOWN and backup ISP is UP then:

:if (($isp1=0) && ($isp2=$PingCount) && ($BackGw=true)) do={

:log warning "Set routes to gw2";

/ip route disable [find comment=gw1];

/ip route enable [find comment=gw2];

}

 

:local MainGw [/ip route get [find comment=gw1] disable];

#if main ISP is UP then:

:if (($isp1=$PingCount) && ($MainGw=true)) do={

:log warning "Set routes to gw1";

/ip route enable [find comment=gw1];

/ip route disable [find comment=gw2];

}

Создаю дропы на портах, что бы 8.8.8.8 ходил только через провайдер1, а 8.8.4.4 только через провадер2, проверяю трассы, все работает, отключаю второй интерфейс, включаю скрипт который по идее должен при пропадании пинга на 8.8.8.8 отключить первый интерфейс и включить второй, но ничего не происходит, счетчик скрипта крутиться и в планировщике и в скрипте, то есть скрипт запускается, но толку нет.

Комментарии к роутам прописаны.

Пробовал ROS 5.13, 5.20, 5.23.

Помогите знаниями, заранее благодарен.

Edited by ucTuHa

Share this post


Link to post
Share on other sites

дык как бы netwatch есть )

 

/tool netwatch

add disabled=no down-script="/ip route disable \"main\"" host=8.8.4.4 interval=\

20s timeout=1s up-script="/ip route enable \"main\""

 

/ip route

add check-gateway=ping comment=main disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.19.19.254 scope=30 target-scope=10

add disabled=no distance=10 dst-address=0.0.0.0/0 gateway=pppoe-out1 scope=30 target-scope=10

add disabled=no distance=1 dst-address=8.8.4.4/32 gateway=10.19.3.254 scope=30 target-scope=10

 

 

Имеем - бэкап маршрут через ПППоЕ, и включается он при пропаже пинга на 8.8.4.4

Share this post


Link to post
Share on other sites

А как быть когда один внешний IP, один и тот же провайдер и соответственно IP gateway тот же? Два канала один проводной другой WiFi.

Пробовал как указал martini по основному ходит все нормально, только перекидываю на Wi-Fi происходит переключения на gateway=ether2 и все глохнет, так как настроить подскажите с одинаковым гетевей IP, еще нужно чтобы и IP адрес транслировался на два разных интерфейса (ether1, ether2).

Роутер который на схеме пропускает через себя трафик от нас (клиент) прозрачно.

 

post-90119-051492200 1367062269_thumb.jpg

 

Подскажите пожалуйста.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this