Jump to content
Калькуляторы

SNR-2950 пропадание связи

Добрый день, есть такая схема влан да абонента:

От микротика идет куча VLAN, суммарно около 250шт, приходят на 25 порт центрального комутатора по оптике 1Gb, далее по 25шт с портов 1-10, через 100Мб медиаконверторы расходятся на абонентские комутаторы (разных моделей и производителей, в основном catalist-C2950). Под управление выделен VLAN10.

Сперва в центре стоял catalist-C3524XL, полет нормальный.

Поставили SNR, в центре, и на одном из абонентских узлов, начала пропадать связь по управляющему VLAN, но только до этих двух комутаторов, т.е. клиентский трафик, и трафик в VLAV10 до остальных комутаторов ходит без проблем, а до этих двух потери пингов 40-50%

 

Поставил cpu-rx-ratelimit protocol ARP 2000 (было 100), потери исчезли, но мониторинг все равно фиксируеи 2-3 обрыва связи в сутки (ping-check раз в минуту)

Версия прошивки 6.2.139.129

Никакие ACL не используются, в конфиге только созданые VLAN и распределение их по портам.

 

На "столе" повторить ситуацию не получается

Кто может подсказать, в чем дело ?

Share this post


Link to post
Share on other sites

У меня такая же проблема...пока не нашёл как её победить

Share this post


Link to post
Share on other sites

Собственно, пороблема до сих пор актуальна!

Нашел вот эту тему http://forum.nag.ru/forum/index.php?showtopic=75240 , очень похоже на мой случай, можно узнать, чем там дело кончилось ?

Edited by inettel

Share this post


Link to post
Share on other sites

stp отключен везде.

В дебаге куча вот таких записей:

SNR2950-24G#debug driver receive interface all protocol arp

packet received:type=ARP,vlan=726,port=26,pktlen=60,reason=0x3a,
reasons=0x00002000 04000000 00000000 ,
srcmac=d4:ca:6d:44:c7:2b,  dstmac=ff:ff:ff:ff:ff:ff.
packet received:type=ARP,vlan=725,port=26,pktlen=60,reason=0x3a,
reasons=0x00002000 04000000 00000000 ,
srcmac=d4:ca:6d:44:c7:2b,  dstmac=ff:ff:ff:ff:ff:ff.
packet received:type=ARP,vlan=924,port=26,pktlen=60,reason=0x0,
reasons=0x00002000 00000000 00000000 ,

 

srcmac - соответствует МАС-у шлюза, номера VLAN - клиентские, т.е. впечатление такое, что комутатор принимает ARP запросы, которые идут не в управляющем VLAN.

Share this post


Link to post
Share on other sites

А SVI в клиентские VLAN нигде на свитчах не поднят? А меня как-то раз техники забыли повырубать при заливке дефолтного конфига vlan1 и потом долго удивлялись что это за железка в ip 192.168.0.1.

Share this post


Link to post
Share on other sites

У нас такая же проблема - не проходят арп-запросы от клиентов до роутера. В обратную сторону проходят.

Нужна помощь!

Share this post


Link to post
Share on other sites

у кого как проблема решилась ?

Share this post


Link to post
Share on other sites

Никак не решилась, поставили уже 7 шт SNR-ов, со всеми такая беда, на мониторинг смотреть жалко, 30 с лишним событий "потеря связи" за последние сутки.

Share this post


Link to post
Share on other sites

Добрый день.

 

Наши коммутаторы установлены и успешно работают более чем у 100 операторов связи по всей России и ближнему зарубежью, подобных проблем не наблюдается, по крайней мере обращений на support@nag.ru с такой проблемой небыло. Пишите, инженеры зададут Вам вопросы, соберут всю необходимую информацию и будут разбираться. Также рекомендую проверить сеть на наличие проблем. Все это необходимо т.к.

На "столе" повторить ситуацию не получается

Share this post


Link to post
Share on other sites

Написал на support@nag.ru

К стати, насчет "повторить на столе", был не прав, повторяется все очень легко.

 

vlan 1;10;20
!
Interface Ethernet1/1
switchport access vlan 20
!
interface Vlan10
ip address 10.10.10.1 255.255.255.0 

 

В порт Ethernet1/1 вкл. комп с адресом 192.168.1.1/24, на компе запущен пинг на адрес 192.168.1.2, остальные порты свободны.

На комутаторе смотрим

 

SNR-S2950-24G#show cpu-rx protocol arp
Type                Rate-limit    TotPkts        CurState
ARP                 100           249              allowed 

 

и видим, значение TotPkts медленно растет, соответственно, если вланов много, то растет как сумашедшее.

В один прекрасный момент установленного Rate-limit уже не хватает, и происходит обрыв связи

Edited by inettel

Share this post


Link to post
Share on other sites

#sh cpu-rx protocol arp
Type                Rate-limit    TotPkts        CurState
ARP                 100           4692682        allowed
#sh cpu-rx protocol arp
Type                Rate-limit    TotPkts        CurState
ARP                 100           4693102        allowed
#sh cpu-rx protocol arp
Type                Rate-limit    TotPkts        CurState
ARP                 100           4693105        allowed

Набегает. При отключенном Rate-limit (настройки из коробки) пропаданий связи не наблюдается.

Share this post


Link to post
Share on other sites

Набегает. При отключенном Rate-limit (настройки из коробки) пропаданий связи не наблюдается.

 

Он не отключен, из коробки, а установлен Rate-limit=100, а раз связь не пропадает - значит вам хватает такого значния )

Я пример выше привел для демонстрации "корня зла", так сказать, пропадать начнет, когда интерфейсов куча,(у нас порядка 200-300), и в каждом идут

достаточно много arp запросов.

Share this post


Link to post
Share on other sites

Добрый день.

 

Проблему подтвердили, передали в работу R&D.

Есть какая-нибудь информация по решению проблемы?

Share this post


Link to post
Share on other sites

Никогда. "Инженеры" нага ничего не решают. Они только "воспроизводят проблему на столе" и отсылают отчёт китайцам. Которые уже, если есть настроение и за окном плохая погода, может быть, когда нибудь, что-то там пофиксят. Мой трабл так и не пофиксили.

Share this post


Link to post
Share on other sites

Исправления вышли, кому необходимо - нужно запрашивать на support@nag.ru.

Share this post


Link to post
Share on other sites

а номер исправленной версии какой?

Share this post


Link to post
Share on other sites

04 июня 2013- баг подтвердился.

11 декабря 2013 - вышло ТАЙНОЕ исправление, которое всем не дают.

 

Летайте самолётами Аэрофлота.

Edited by sol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this