Jump to content
Калькуляторы

2 isp failover

http://wiki.mikrotik.com/wiki/Advanced_Routing_Failover_without_Scripting кто нибуть пробовал? работает? непонятно.

у меня 2 интерфейса езернет по дхцп, как при этом получать, не получать дефолт гетвей, карочи работоспособно или нет?

Share this post


Link to post
Share on other sites

Господа, дайте нормальный файловер. Ненужно никакого балансинга и желательно без скриптов. Отвалился 1 канал, подключился другой, всё. Появился первый, обратно переключился.

Share this post


Link to post
Share on other sites

Господа, дайте нормальный файловер. Ненужно никакого балансинга и желательно без скриптов. Отвалился 1 канал, подключился другой, всё. Появился первый, обратно переключился.

 

1 что в вашем понимании отвалился?

- если буквально это понимать то просто 2 машрута на 0,0,0,0 с разными метками

2 если просто перестает идти инет то там гемора с проверками и тд куча.....

Share this post


Link to post
Share on other sites
2 если просто перестает идти инет то там гемора с проверками и тд куча.....

Какой гемор? скрипт пингующий яндекс через два маршрута, и меняющий дефолтный шлюз....

Share this post


Link to post
Share on other sites

Арендуйте сервер в датацентре с каналом инета, создайте 2 туннеля и запустите поверх них OSPF. Когда все исправно по одному каналу будет идти входящий трафик, по другому исходящий, если один сломается то все переключится на оставшийся. Другой вариант просто 2 туннеля с одинаковыми метриками и шлюзом, тогда в один будет отключен, второй активен. При обрыве активного все автоматом переключится на резерв. Заодно и адреса не от своего провайдера клиенты будут на спидтесте видеть.

Share this post


Link to post
Share on other sites

Блин, ну Вам занятся более нечем:

Из плёвой задачи целую проблему раздули...

 

 

Гугл рулит:

 

http://papa-admin.ru/%D1%81%D1%82%D0%B0%D1%82%D1%8C%D0%B8/mikrotik/56-%D0%A1%D0%BA%D1%80%D0%B8%D0%BF%D1%82-%D0%B4%D0%BB%D1%8F-%D0%B0%D0%B2%D1%82%D0%BE%D0%BC%D0%B0%D1%82%D0%B8%D1%87%D0%B5%D1%81%D0%BA%D0%BE%D0%B5-%D0%BF%D0%B5%D1%80%D0%B5%D0%BA%D0%BB%D1%8E%D1%87%D0%B5%D0%BD%D0%B8%D0%B5-%D0%BD%D0%B0-%D1%80%D0%B5%D0%B7%D0%B5%D1%80%D0%B2%D0%BD%D1%8B%D0%B9-%D0%BA%D0%B0%D0%BD%D0%B0%D0%BB-%D0%B2-mikrotik

 

http://habrahabr.ru/post/141785/

 

Даже вообще БЕЗ скриптов:

 

http://wiki.mikrotik.com/wiki/Advanced_Routing_Failover_without_Scripting

 

http://wiki.mikrotik...thout_Scripting кто нибуть пробовал? работает? непонятно.

с DHCP --сложнее, но работат должно (вместо IP--интерфейс), статику настройте, для начала...

Edited by NewUse

Share this post


Link to post
Share on other sites

Гугл рулит:

 

http://papa-admin.ru...%D0%B2-mikrotik

скрипт чекает гетвеи 2х провайдеров и переключается если пров отваливается.

я кастомизировал скрипт, проверяет гугловский днс через 2 провайдеров и если он не доступен на мейне переключает на бэкап, как тока мейн запинговался обратно переключает дистанс у дефолтного гетвея.

 

:local PingCount 3;

 

:local CheckIp 8.8.8.8;

 

:local int1 ether1;

:local int2 ether3;

 

:local isp1 [/ping $CheckIp interface=$int1 count=$PingCount];

:local isp2 [/ping $CheckIp interface=$int2 count=$PingCount];

 

#if main ISP is DOWN and backup ISP is UP then:

 

:local BackGw [/ip route get [find comment=gw2] distance];

:if ($isp1=0 and $BackGw=2) do={

:log warning "Set routes to backup ISP"

/ip route set distance=2 [find comment=gw1]

/ip route set distance=1 [find comment=gw2]

}

 

#if main ISP is UP then:

 

:local MainGw [/ip route get [find comment=gw1] distance];

:if ($isp1>0 and $MainGw=2) do={

:log warning "Set routes to main ISP"

/ip route set distance=2 [find comment=gw2]

/ip route set distance=1 [find comment=gw1]

}

 

 

с дхцп , просто не получаем дефолт гетвей и роут дефолтный прописываем вручную

Edited by jdemon

Share this post


Link to post
Share on other sites

А ссыль на вики не прокатила, по ДХЦП -- место ip -- ether*?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this