Jump to content
Калькуляторы

Проблема с IPTV на SNR-S2940-8G-v2

Недавно взяли на тест коммутаторы SNR двухтысячной серии.

Предполагается их работа на доступе; оказываемые услуги — обычный Triple Play (интернет, IPTV, запланирована телефония).

Почему-то не удается их настроить для работы в сети.

 

Первоначальная проблема была в том, что при включении IGMP-снупинга IPTV на клиентских компьютерах не работало.

Если отключить снупинг, то IPTV работало (но в этом случае разумеется мультикаст рассылался на все порты и при большом числе каналов это неприемлимо).

Настраивал в соответствии со статьей на сайте.

Два дня пытался добиться от технической поддержки комментариев и советов, что у меня настроено неправильно, но без успеха.

Кстати, пользуясь случаем хочу "передать привет" службе технической поддержки.

Столь долгих ответов даже на пустяковые вопросы не встречал еще ни у кого.

 

Сегодня решил собрать отдельный стенд для тестирования.

Стенд выглядит так.

 

Есть коммутатор SNR-S2940-8G-v2:

#sh ver
 SNR-S2940-8G-v2 Device, Compiled on Feb 08 13:43:45 2012
 SoftWare Version 6.2.138.103
 BootRom Version 4.20.0
 HardWare Version 1.0.1
 CPLD Version 1.2
 Device serial number A2000417PE
 Copyright (C) 2012 NAG LLC
 All rights reserved
 Last reboot is warm reset.
 Uptime is 0 weeks, 0 days, 1 hours, 3 minutes

 

К коммутатору подключены два ноутбука, в порты 2 и 4.

В порт 10 подключен компьютер с запущенным VLC в режиме IPTV-стриммера.

В порт 9 подключен аплинк, на стенде он временно отключен.

Для управления используется VLAN 10, для IPTV используется VLAN 60, VLAN 400-499 — абонентские VLAN.

Изначальная конфигурация коммутатора:

#sh run
...
!
ip dhcp snooping enable
ip dhcp snooping vlan 60;400-499
!
...
!
vlan 1;400-499
!
vlan 10
name MGMT
!
vlan 60
name IPTV
multicast-vlan
multicast-vlan mode dynamic
multicast-vlan association 400
!
access-list 6000 permit ip any-source any-destination
!
pppoe intermediate-agent
pppoe intermediate-agent format circuit-id ascii
pppoe intermediate-agent format remote-id ascii
!
Interface Ethernet1/1-8
ip multicast destination-control access-group 6000
switchport access vlan 400
switchport association multicast-vlan 60
!
Interface Ethernet1/9
media-type fiber
switchport mode trunk
switchport trunk allowed vlan 10;60;300-499;800-899 
switchport trunk native vlan 10
pppoe intermediate-agent trust
ip dhcp snooping trust
!
Interface Ethernet1/10
media-type copper
switchport access vlan 400
!

 

В такой схеме запускаю IPTV-стриммер на порту 10, запускаю VLC на ноутбукам — вижу кино, т.к. IPTV работает.

Делаю ip igmp snooping — трансляция прерывается. Делаю no ip igmp snooping — трансляция возобновляется.

Делаю следующее:

ip igmp snooping
ip igmp snooping vlan 60
ip igmp snooping vlan 60 immediately-leave
ip igmp snooping vlan 60 mrouter-port interface ethernet 1/10
interface ethernet1/10
media-type copper
switchport access vlan 60

Однако трансляции по прежнему нет.

 

Отключаю порт 10, подключаю порт 9 (аплинк с тэгированным трафиком, где в VLAN 60 приходит мультикаст).

На ноутбуках по прежнему нет IPTV, перезапуск ноутбука/VLC не помогает, в sh ip igmp snooping vlan 60 groups отсутствуют каналы IPTV и абонентские порты.

Если на коммутаторе выполнить no ip igmp snooping — трансляция появляется (и естественно мультикаст приходит на все абонентские порты).

Теперь самое интересное — если с включенным снупингом

ip igmp snooping
ip igmp snooping vlan 60
ip igmp snooping vlan 60 immediately-leave
ip igmp snooping vlan 60 mrouter-port interface ethernet 1/10

коммутатор перегрузить, то на ноутбуке начинается трансляция. Причем работает все правильно — мультикаст отдается только в те порты, с которых произошла подписка, в sh ip igmp snooping vlan 60 groups указана правильная информация (перечислены порты и каналы, на которые организована подписка).

Но если в этот момент на ноутбуке сменить канал или перезапустить VLC, то IPTV снова не работает.

 

Кто-нибудь с таким сталкивался?

На тех.поддержку надежды мало, с их скоростью реакции проблема решится не раньше зимы.

Share this post


Link to post
Share on other sites

Любопытный момент.

Делаю следующее:

ip igmp snooping
ip igmp snooping vlan 60
ip igmp snooping vlan 60 immediately-leave
ip igmp snooping vlan 60 mrouter-port interface ethernet 1/10
interface ethernet1/10
media-type copper
switchport access vlan 60

Однако трансляции по прежнему нет.

Если оставить порт 10 в VLAN 60, но отключить IGMP-снупинг, то на ноутбуке трансляция возобновляется, несмотря на то, что стриммер и клиенты в разных VLAN.

То есть multicast-vlan association срабатывает. Проблема именно в снупинге.

Share this post


Link to post
Share on other sites

забей. На этих коммутаторах работает только базисный функционал л2. По поводу софта и реакции тех. поддержки(а они мнят себя убийцами длинка) проще покупать DCN в Китае только там цена дешевле.

Share this post


Link to post
Share on other sites

базисный функционал л2

igmp snooping сюда не попадает?

по поводу работы - если у "прослойки" возникает ступор при настройке SNMP и MTU - может дело в прослойке?

Share this post


Link to post
Share on other sites

Кстати, пользуясь случаем хочу "передать привет" службе технической поддержки.

Столь долгих ответов даже на пустяковые вопросы не встречал еще ни у кого.

 

 

На тех.поддержку надежды мало, с их скоростью реакции проблема решится не раньше зимы.

По поводу софта и реакции тех. поддержки(а они мнят себя убийцами длинка) проще покупать DCN в Китае только там цена дешевле.

 

Хотелось бы отметить что в служба технической поддержки обрабатывает далеко не 1 сообщение в неделю и на это требуется определенное время.

В случае подобных запросов необходимо собрать тестовую схему и убедится в работоспособности конфигураций и оборудования. Что мы и сделали.

Так же хотелось обратиться с просьбами не вести себя невоспитанно и общаться подобным образом. Мы все взрослые люди и просьба общаться без хамства и наездов. Про вас никто не забывает.

Еще раз отмечаю люди работают. И если вам не ответили в тот же момент, это не значит что надо писать подобные высказывания.

 

В данный момент ваше обращение проверяется специалистами ТП. Схема собрана и функционал IGMP snooping согласно вашей схеме работает. Подробности были высланы вам лично. Вопрос решается.

Share this post


Link to post
Share on other sites

К коммутатору подключены два ноутбука, в порты 2 и 4.

В порт 10 подключен компьютер с запущенным VLC в режиме IPTV-стриммера.

В порт 9 подключен аплинк, на стенде он временно отключен.

Для управления используется VLAN 10, для IPTV используется VLAN 60, VLAN 400-499 — абонентские VLAN.

Изначальная конфигурация коммутатора:

#sh run
...
!
ip dhcp snooping enable
ip dhcp snooping vlan 60;400-499
!
...
!
vlan 1;400-499
!
vlan 10
name MGMT
!
vlan 60
name IPTV
multicast-vlan
multicast-vlan mode dynamic
multicast-vlan association 400
!
access-list 6000 permit ip any-source any-destination
!
pppoe intermediate-agent
pppoe intermediate-agent format circuit-id ascii
pppoe intermediate-agent format remote-id ascii
!
Interface Ethernet1/1-8
ip multicast destination-control access-group 6000
switchport access vlan 400
switchport association multicast-vlan 60
!
Interface Ethernet1/9
media-type fiber
switchport mode trunk
switchport trunk allowed vlan 10;60;300-499;800-899 
switchport trunk native vlan 10
pppoe intermediate-agent trust
ip dhcp snooping trust
!
Interface Ethernet1/10
media-type copper
switchport access vlan 400
!

 

:) ндаа

зачем делать мультикаст вилан и вещать в клиентский вилан? хоть бы всем не показывали ;)

Edited by shelma

Share this post


Link to post
Share on other sites

Любопытный момент.

Делаю следующее:

ip igmp snooping
ip igmp snooping vlan 60
ip igmp snooping vlan 60 immediately-leave
ip igmp snooping vlan 60 mrouter-port interface ethernet 1/10
interface ethernet1/10
media-type copper
switchport access vlan 60

Однако трансляции по прежнему нет.

Если оставить порт 10 в VLAN 60, но отключить IGMP-снупинг, то на ноутбуке трансляция возобновляется, несмотря на то, что стриммер и клиенты в разных VLAN.

То есть multicast-vlan association срабатывает. Проблема именно в снупинге.

забавный пост :)

"Любопытный момент, начинаю делать верно" ;)

"несмотря на то, что стриммер и клиенты в разных VLAN." ;) именно так и работает мультикаст вилан

 

Я вот это дело не использую:

ip igmp snooping vlan ххх immediately-leave

ip igmp snooping vlan ххх mrouter-port interface ethernet

Share this post


Link to post
Share on other sites
зачем делать мультикаст вилан и вещать в клиентский вилан? хоть бы всем не показывали ;)

Ну вы сообщение до конца прочитайте.

Первоначально вещание шло в мультикастовом VLAN, но не работало.

Чтобы убедиться, что дело не в стриммере и не в клиентских ноутбуках, сделано вещание в клиентском VLAN (я так же мог просто подключить все в неуправляемый свитч).

 

по поводу работы - если у "прослойки" возникает ступор при настройке SNMP и MTU - может дело в прослойке?

Не понял. Не могли бы пояснить?

Share this post


Link to post
Share on other sites

Не понял. Не могли бы пояснить?

это было адресовано не Вам ;-)

Share this post


Link to post
Share on other sites

Andrey Shepelev, я же не на пустом месте на скорость реакции обратил внимание. С момента моего первого обращения неделя прошла.

Если вы руководитель, хронология такая.

1. 16 августа пишу обращение в тех.поддержку (проблема с входом по CLI, запрашивается имя/пароль), указываю номер заказа. В копию письма ставлю нашего менеджера.

2. На следующий день отвечает сотрудник, спрашивает номер заказа и ФИО менеджера.

3. Тишина.

4. 20 августа, после моего звонка наконец приходит ответ по запросу, в ответе пишут, что для входа авторизации не требуется. В ответ я сообщаю, что у меня имя/пароль запрашиваются и стандартные (admin) или пустые не подходят. Также пишу, что обнаружена проблема с IPTV, прилагаю вывод sh ver и sh run.

5. 21 августа, приходит ссылка на статью по настройке мультикаста (с сайта). Еще одна итерация вопрос/ответ, выясняем что по существу моя конфигурация практически повторяет конфигурацию на сайте, за исключением vlan multicast-vlan mode dynamic, добавление которого ничего не изменило. После этого меня просят прислать вывод sh ver и sh run.

 

Далее можно сказать, что обмен информацией вошел в нормальную колею.

Но до этого момента было ощущение, что отвечал бот по сценарию.

Share this post


Link to post
Share on other sites

Еще один странный момент.

Удалил конфигурацию (delete startup.cfg), перегрузил коммутатор, настроил практически так, как настраивал с самого начала — IPTV работает.

Либо в startup.cfg были какие-то неотображаемые параметры, либо одно из двух.

Написал в тех.поддержку, если станет известно что-нибудь конкретное, отпишусь тут.

Share this post


Link to post
Share on other sites
ip dhcp snooping vlan 60

это зачем в мултикаст вилане? оО

Share this post


Link to post
Share on other sites

нормально там мультикаст бегает. работает вон пара, на пробу, пить есть не просит. субъективно, веселее чем старые 2940

Share this post


Link to post
Share on other sites

alibek

Ну и какой результат? Можно на этих коммутаторах мультикаст гонять???

Можно, но уж лучше использовать 2960.

За три месяца пока никаких особых проблем не видел, даже HD воспроизводится без проблем.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this