Jump to content
Калькуляторы

OmniStack LS 6200 - помогите настроить IPTV

Железо: OmniStack LS 6200 с прошивкой 1.7.1.10.

 

Вот весь конфиг (кроме настроек ntp и snmp):

 

no amap enable
no spanning-tree
bridge multicast filtering
interface range ethernet e(1-24)
switchport mode customer
exit
interface range ethernet g(1-4)
switchport mode trunk
exit
vlan database
vlan 8,103,1021-1022
exit
interface range ethernet g(1-4)
switchport trunk allowed vlan add 8
exit
interface range ethernet g(1-4)
switchport trunk allowed vlan add 103
exit
interface range ethernet e(1-24)
switchport forbidden vlan add 103
exit
interface range ethernet g(1-4)
switchport trunk allowed vlan add 1021
exit
interface range ethernet e(13-24)
switchport forbidden vlan add 1021
exit
interface range ethernet e(1-12)
switchport customer vlan 1021
exit
interface range ethernet g(1-4)
switchport trunk allowed vlan add 1022
exit
interface range ethernet e(1-12)
switchport forbidden vlan add 1022
exit
interface range ethernet e(13-24)
switchport customer vlan 1022
exit
interface range ethernet e(1-24)
switchport customer multicast-tv vlan add 8
exit
interface vlan 8
name vlan8
exit
interface vlan 103
name vlan103
exit
interface vlan 1021
name vlan1021
exit
interface vlan 1022
name vlan1022
exit
ip igmp snooping
interface vlan 8
ip igmp snooping 
ip igmp snooping mrouter learn-pim-dvmrp 
ip igmp snooping host-time-out 260 
ip igmp snooping mrouter-time-out 300 
ip igmp snooping leave-time-out 0 
exit
interface vlan 1021
ip igmp snooping 
ip igmp snooping mrouter learn-pim-dvmrp 
ip igmp snooping host-time-out 260 
ip igmp snooping mrouter-time-out 300 
ip igmp snooping leave-time-out 0 
exit
interface vlan 1022
ip igmp snooping 
ip igmp snooping mrouter learn-pim-dvmrp 
ip igmp snooping host-time-out 260 
ip igmp snooping mrouter-time-out 300 
ip igmp snooping leave-time-out 0 
exit
no lldp enable 
interface vlan 8
exit
interface vlan 1021
exit
interface vlan 1022
exit
interface range ethernet e(1-24)
loopback-detection enable 
exit
loopback-detection enable 
errdisable recovery cause loopack-detection 
interface vlan 103
ip address 10.103.100.121 255.255.0.0
exit
ip default-gateway 10.103.0.1

 

vlan 8 - мультикастный vlan, vlan 103 - "управляющий" (т.е. в нем IP коммутатора), 1021 и 1022 - клиентские.

 

Подключаюсь со своего компа в 21 порт, пытаюсь запустить проигрывание мультикастного канала 230.1.202.4. Команды JOIN уходят в интерфейс.

 

На коммутаторе делаю show ip igmp snooping groups. Получаю:

 

Vlan   Group    	Source    	Include Ports    	Exclude Ports 	Comp.
  	Address  	Address                                          	Mode
---- ------------ ------------ -------------------- -------------------- -----
1022 230.1.202.4  *        	e21                           			v2
1022 239.255.255. *        	e21                           			v2
	250


IGMP Reporters that are forbidden statically:

Vlan   Group    	Source                      	Ports
  	Address  	Address
---- ------------ ------------ -----------------------------------------------
1022 230.1.202.4  *        	No Forbidden ports
1022 239.255.255. *        	No Forbidden ports
	250

Такое впечатление, что коммутатор "не знает", где ему брать этот мультикастный канал. Видимо, что-то где-то я недонастроил - но не могу понять, где. Дока такая мутная, как будто ее несколько раз переводили с одного языка на другой (в разделе про мультикаст - набор фраз и совершенно левые примеры).

 

Помогите, пожалуйста. Железка, похоже, неплохая, и можно было бы такие железки ставить в локалку - но без IPTV нет смысла их использовать...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this