Перейти к содержимому
Калькуляторы

Оборудование Juniper Network. Отзывы, реальная производительность. Особенности, плюсы, минусы

Роуты в принципе не проблема, нога тут на всю страну одна, своих внутренних адресов - немного, IX как таковых - нет.

Меня единственное смущает - FBF, из-за местных особенностей в циске у меня уйма route-map-ов. Но думаю осилю...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день!

 

Прошу совета. Есть следующая ситуация.

 

Используем сейчас в своеобразном ядре для паритетов и локалки Extreme Summit x650 и Extreme BD8810. У обоих 12К LPM + ip route compression, итого влазит до 16К FIB. Принимать же есть необходимость до 54К отчасти пересекающихся маршрутов, 3 IX и паритеты. Загруженно в сумме 52 порта 10Г.

 

Сейчас решаем следующим образом. Часть маршрутов на 650, часть на BD, и одна ix (16K маршрутов) распределена по сети множеством сессий.

 

Вот созревает план влить это все в одну железку и забыть о манипуляциях с маршрутами. Планируемое железо EX4600. И по нему есть множество сомнений.

 

Начну с того что сейчас взяли на тест EX4550 и заменили им 650й. Первое сомнение нагрузка процессора.

Загрузка Juniper при идентичной нагрузке:

post-118205-004938700 1429769480_thumb.png

 

 

650й:

post-118205-097183400 1429769489_thumb.png

 

 

Тут может у Вендоров разное измерение нагрузки, может настройка juniper - остается желать лучшего. Кто силен, подскажите тревожный это момент или особенность.

 

Дальше сомнения. Услышал от поставщика что заявленные 128К LPM у 4600 это RIB, а FIB там не более 32К. Мне хватает и 32К (маршруты большей частью попадут в RIB), но все же сбит с толку.

 

Еще порция сомнений. Тот же поставщик сигнализирует, что при стекировании двух или более коммутаторов 4600 (4550), мультикаст трафик стабильно рассыпается. Со слов проблема признанна Вендром на 4550 и не устраненная на 4600. Тут настораживает проблемы при возможном масштабировании.

 

Стоит ли рассматривать данный коммутатор как оптимальную замену текущим, или посоветуете что интереснее.

 

PS. Была мысль взять что-то из старших серий, но там цены другого уровня. Тут же оптимальное соотношение функционал/цена покрывающие наши требования.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

dubcon

относительно загрузки CPU - а чем собственно занят процессор? (shell -> top или show system processes extensive )

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Начну с того что сейчас взяли на тест EX4550 и заменили им 650й. Первое сомнение нагрузка процессора.
процессор не имеет никакого отношения к форвардингу трафика. понятия "софтсвитчинк" как в циске тоже нет. если что-то кончилось, то оно кончилось, никаких компромиссов :)

скорее всего у вас там какой-то протокол колбасит, про который думает RE: stp, lldp, bgp, ospf и т.п.

надо начать с show system process extensive вобщем.

Дальше сомнения. Услышал от поставщика что заявленные 128К LPM у 4600 это RIB, а FIB там не более 32К. Мне хватает и 32К (маршруты большей частью попадут в RIB), но все же сбит с толку.
ну позор поставщику, если сам не знает, то зачем говорить ? есть же даташит про это дело.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

-

Изменено пользователем Geum-ja

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Подскажите,

через Uplink порт нужно отдать c ex4200 на Cisco несколько VLAN. Среди этих VLAN так же должен быть Q-in-Q S-VLAN в котором несколько CVLAN.

 

1 - Настройка QinQ vlan

 

set vlans vlan1007 description "pppoe s-vlan"

set vlans vlan1007 vlan-id 1007

set vlans vlan1007 dot1q-tunneling customer-vlans 200-208

 

2 - Настройка UPLINK порт

 

set interfaces xe-0/1/0 unit 0 family ethernet-switching port-mode trunk

set interfaces xe-0/1/0 unit 0 family ethernet-switching vlan members vlan1007

set interfaces xe-0/1/0 unit 0 family ethernet-switching vlan members vlan6

set interfaces xe-0/1/0 unit 0 family ethernet-switching vlan members vlan54

set interfaces xe-0/1/0 unit 0 family ethernet-switching vlan members vlan104

set interfaces xe-0/1/0 unit 0 family ethernet-switching vlan members vlan154

 

Настройка одного из DOWNLINK порта с котрого приходят VLAN

 

set interfaces ge-0/0/16 unit 0 family ethernet-switching port-mode trunk

set interfaces ge-0/0/16 unit 0 family ethernet-switching vlan members vlan2

set interfaces ge-0/0/16 unit 0 family ethernet-switching vlan members vlan3

set interfaces ge-0/0/16 unit 0 family ethernet-switching vlan members vlan4

set interfaces ge-0/0/16 unit 0 family ethernet-switching vlan members vlan5

set interfaces ge-0/0/16 unit 0 family ethernet-switching vlan members vlan208

 

СVLAN :200-208

 

теперь вопрос

хватит ли настроек из п.1 и п.2

Потому как есть предложение делать физ.петлю. с ge-0/0/21 и ge-0/0/22

 

set interfaces ge-0/0/21 unit 0 description "out pppoe-qinq-loop"

set interfaces ge-0/0/21 unit 0 family ethernet-switching port-mode access

set interfaces ge-0/0/21 unit 0 family ethernet-switching vlan members vlan1007

 

 

set interfaces ge-0/0/22 unit 0 description "incoming pppoe-qinq-loop"

set interfaces ge-0/0/22 unit 0 family ethernet-switching port-mode trunk

set interfaces ge-0/0/22 unit 0 family ethernet-switching vlan members vlan200

set interfaces ge-0/0/22 unit 0 family ethernet-switching vlan members vlan201

set interfaces ge-0/0/22 unit 0 family ethernet-switching vlan members vlan202

set interfaces ge-0/0/22 unit 0 family ethernet-switching vlan members vlan203

set interfaces ge-0/0/22 unit 0 family ethernet-switching vlan members vlan204

set interfaces ge-0/0/22 unit 0 family ethernet-switching vlan members vlan205

set interfaces ge-0/0/22 unit 0 family ethernet-switching vlan members vlan206

set interfaces ge-0/0/22 unit 0 family ethernet-switching vlan members vlan207

set interfaces ge-0/0/22 unit 0 family ethernet-switching vlan members vlan208

Сообщение отредактировал MasterJey: Вчера, 17:32

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день!

 

Получил кусок железного счастья(Juniper MX-5t) на замену того, чье имя не произносят(МК-cloudcore).

Книга Douglas Richard Hanks Jr. - Juniper MX Series, сайт juniper.net, - за пару дней накидал конфиг,

в принципе все заработало - БГП поднялось, в интернет пускает/не пускает, шейпит, но видно что конфиг кривой

не совсем понял куда вешать фильтры на irb или lo0, да и в чем отличия irb от lo0. нет конечно вопросов миллион :)

 

Прошу взглянуть, подсказать/пнуть:

 

juni_nag.png

 

interfaces {
   xe-0/0/3 {                          
       description BGP-PEER;
       unit 0 {
           family inet {
               address 10.0.0.102/30;
           }
       }
   }
   ge-1/1/0 {
       vlan-tagging;
       encapsulation extended-vlan-bridge;
       unit 88 {
           vlan-id 88;
       }
       unit 252 {
           vlan-id 252;
       }
       unit 1031 {
           vlan-id 1031;
       }
   }                                   
   ge-1/1/1 {
       vlan-tagging;
       encapsulation extended-vlan-bridge;
       unit 88 {
           vlan-id 88;
       }
       unit 252 {
           vlan-id 252;
       }
   }
   fxp0 {
       description MGMT-ETH;
       unit 0 {
           family inet {
               filter {
                   input ADMIN-ACCESS;
               }
               address 192.168.252.2/24;
           }
       }                               
   }
   irb {
       unit 1031 {
           family inet {
               filter {
                   input-list [ ABON-SHAPER-IN ABON-TO-INET ];
                   output ABON-SHAPER-OUT;
               }
               address 192.168.111.1/24;
           }
       }
   }
   lo0 {
       description LOOP-ETH;
       unit 0 {
           family inet {
               address 127.0.0.1/32;
           }
       }
   }
}
routing-options {
   static {
       route 0.0.0.0/0 {
           next-hop 10.0.0.101;
           metric 20;
       }
   }
   autonomous-system 200;
}
protocols {
   bgp {
       graceful-restart;
       group BGP-PEER {
           type external;
           peer-as 300;
           neighbor 10.0.0.101 {
               local-address 10.0.0.102;
               export BGP-OUT;     
               as-override;
           }
       }
   }
}
policy-options {
   prefix-list MY-NET {
       192.168.252.1/32;
   }
   prefix-list 1031 {
       192.168.111.0/24;
   }
   prefix-list SHAPER-10M {
       192.168.111.20/32;
       192.168.111.22/32;
       192.168.111.30/32;
   }
   prefix-list SHAPER-20M {
       192.168.111.23/32;
       192.168.111.89/32;
   }
   policy-statement BGP-OUT {      
       term APEX {
           from {
               prefix-list 1031;
           }
           then accept;
       }
       term REJECT {
           then reject;
       }
   }
}
firewall {
   family inet {
       filter ADMIN-ACCESS {
           term MY-SSH {
               from {
                   source-prefix-list {
                       MY-NET;
                   }
                   protocol tcp;
                   destination-port [ 22 ];
               }
               then {                  
                   log;
                   accept;
               }
           }
           term MY-PING {
               from {
                   source-prefix-list {
                       MY-NET;
                   }
                   protocol icmp;
               }
               then {
                   log;
                   accept;
               }
           }
       }
       filter ABON-SHAPER-IN {
           term 10M {
               from {
                   prefix-list {
                       SHAPER-10M;
                   }                   
               }
               then policer 10M;
           }
           term 20M {
               from {
                   prefix-list {
                       SHAPER-20M;
                   }
               }
               then policer 20M;
           }
       }
       filter ABON-SHAPER-OUT {
           term 10M {
               from {
                   prefix-list {
                       SHAPER-10M;
                   }
               }
               then policer 10M;
           }
           term 20M {
               from {                  
                   prefix-list {
                       SHAPER-20M;
                   }
               }
               then policer 20M;
           }
       }
       filter ABON-TO-INET {
           term ABON-FILTER {
               from {
                   source-address {
                       0.0.0.0/0;
                   }
                   source-prefix-list {
                       SHAPER-10M except;
                       SHAPER-20M except;
                   }
               }
               then {
                   discard;
               }
           }
           term ABON-ALLOW {           
               then accept;
           }
       }
   }
   policer 10M {
       if-exceeding {
           bandwidth-limit 10m;
           burst-size-limit 1m;
       }
       then discard;
   }
   policer 20M {
       if-exceeding {
           bandwidth-limit 20m;
           burst-size-limit 1m;
       }
       then discard;
   }
}
bridge-domains {
   vlan1031 {
       vlan-id 1031;
       interface ge-1/1/0.1031;
       routing-interface irb.1031;
   }
   vlan252 {
       vlan-id 252;
       interface ge-1/1/0.252;
       interface ge-1/1/1.252;
   }
   vlan88 {
       vlan-id 88;
       interface ge-1/1/0.88;
       interface ge-1/1/1.88;
   }
}

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

не совсем понял куда вешать фильтры на irb или lo0, да и в чем отличия irb от lo0. нет конечно вопросов миллион :)

если интересуют фильтры для транзитного трафика то вешаете на irb (аналог SVI), если хочется зафильтровать удаленный доступ/snmp/telnet то вешаете на lo0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
если интересуют фильтры для транзитного трафика то вешаете на irb (аналог SVI), если хочется зафильтровать удаленный доступ/snmp/telnet то вешаете на lo0

спасибо, просто и логично

 

ребята, сейчас сеть как пробка IPoE: L2 Swicth -> DCHP Option82 -> Billing(самописный скрипт + isc-dhcp-server) -> Mikrotik + BGP

еще недавно был NAT, сеть была подроблена на вланы на мелкие районы, сейчас заимел пул нормальных адресов + пару дней назад МХ

(после перехода на белые IP выхватил кучу проблема из-за увеличения широковещательного домена и "срочности" отказа от НАТ.)

 

хочеться хорошего - qinq. в наличии доступ управляемый L2, зоопарк из Foxgate, Accton, ZTE, Eltex и сбор линков с домов на TP-LINK SG5412F,

на агрегации MES3124F, с которого планирую по 10G уходить в MX(BGP, Local-DHCP(?), Policer, QINQ, SORM).

 

проблема 1 - не могу представить как организовать qinq. сейчас у меня скриптом(биллинг) выдается рандомно IP+VLAN -> генерирует опцию82 и пишет класс+пул для DHCP,

дальше идет на шлюз добавляет запись в access-list, и конечно настраивает порт по шаблону для свича и исходя из выданного IP+VLAN.

надо как-то вникнуть как организовать работу с новыми "данными". в голове крутиться примерно такое:

 

 

[доступ 24 порта(порт 2 в c-влан(inner) 1031 настроен биллингом)]--- транспортный s-влан(outer) от свича до МХ = 100 --- [TP-LINK trunk]--- [MES trunk]--- транспортный s-влан(outer) от МХ до свича = 100 ---[MX irb.1031]--- [интернет тут]

 

 

по схеме: порт 2 может менять влан. таким образом, можно распланировать только s-влан на свич(дом), с-влан могут меняться от различных факторов.

 

еще вопрос по DHCP, у МХ есть свой DHCP сервер и релей, почему-то думается что надо переходить на Radius-server, отказаться от isc-dhcp и использовать МХ Local DHCP

и уже на основе S-Vlan/C-Vlan/Remote-ID/Circuit-ID через радиус выдавать адреса с самого МХ Local DHCP.

 

всем спасибо!

Изменено пользователем alexmasz

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

еще вопрос по DHCP, у МХ есть свой DHCP сервер и релей, почему-то думается что надо переходить на Radius-server, отказаться от isc-dhcp и использовать МХ Local DHCP

и уже на основе S-Vlan/C-Vlan/Remote-ID/Circuit-ID через радиус выдавать адреса с самого МХ Local DHCP.

 

всем спасибо!

http://forums.juniper.net/jnet/attachments/jnet/srx/26036/1/DO_DynamicSubscriberMgmt.pdf

лучше вот это сначала прочитать)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

рекомендую приземлять абонентов не на bridge-domain а на конкретный qinq интерфейс на физическом порту. MX в первую очередь роутер, а не коммутатор. Лучше даже сделать ip unnumbered DHCP. Тогда абонентская подсеть будет на lo интерфейсе.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

http://forums.junipe...scriberMgmt.pdf

лучше вот это сначала прочитать)

 

f289947570463c1e91fa6db1b3f5472c.gif

 

рекомендую приземлять абонентов не на bridge-domain а на конкретный qinq интерфейс на физическом порту. MX в первую очередь роутер, а не коммутатор. Лучше даже сделать ip unnumbered DHCP. Тогда абонентская подсеть будет на lo интерфейсе.

 

принято во внимание!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

затык, на не самом сложном, я так понимаю месте. без QINQ работает, LOCAL-DHCP выдает адреса из пулов, в зависимости от пришедшего vlan.

почитал дальше, примерно разобрался, подмешал QINQ - не выдает (: хотя access profile local authentication-order none

run show subscribers    

Interface           IP Address/VLAN ID                      User Name                      LS:RI
ge-1/1/0.1073745755 0x8100.3001 0x8100.1031                                           default:default 
ge-1/1/0.1073745756 0x8100.3001 0x8100.1030                                           default:default      
ge-1/1/0.1073745757 0x8100.3001 0x8100.1028                                           default:default      

 

jdhcpd DHCP pre-authentication failure for DHCPv4 client SDB session 7680 on incoming interface ge-1/1/0.1073745756
jdhcpd DHCP pre-authentication failure for DHCPv4 client SDB session 7681 on incoming interface ge-1/1/0.1073745755
jdhcpd DHCP pre-authentication failure for DHCPv4 client SDB session 7682 on incoming interface ge-1/1/0.1073745757

 

настроил IFD

interfaces {
   ge-1/1/0 {
       traceoptions {
           flag all;
       }
       flexible-vlan-tagging;
       auto-configure {
           stacked-vlan-ranges {
               dynamic-profile QNQ-INTERFACE {
                   accept any;
                   ranges {
                       any,any;
                   }
               }
           }
       }
       mtu 1600;
       encapsulation flexible-ethernet-services;
       unit 200 {
           encapsulation vlan-bridge;
           vlan-id 200;
       }
   }
   lo0 {
       unit 0 {
           family inet {
               address 127.0.0.1/32 {
                   primary;
                   preferred;
               }
               address 192.168.31.1/32;
               address 192.168.30.1/32;
               address 192.168.29.1/32;
           }
       }
   }
}   

 

настроил dhcp

system {
   services {
       dhcp-local-server {
           pool-match-order {
               ip-address-first;
           }
           group local {
               dynamic-profile SUB-INTERFACE;
               interface ge-1/1/0.0;
           }
       }
   }
}

 

и pool

access {
   profile local {
       authentication-order none;
       session-options {
           client-idle-timeout 10;
       }
   }
   address-assignment {
       pool DHCP-1031 {
           family inet {
               network 192.168.31.0/24;
               range VLAN-1031 {
                   low 192.168.31.3;
                   high 192.168.31.254;
               }
               dhcp-attributes {
                   maximum-lease-time 780;
                   name-server {
                       8.8.8.8;
                   }
                   router {
                       192.168.31.1;
                   }
               }
           }
       }
   }
}

access-profile local;

 

создал профили

dynamic-profiles {
   QNQ-INTERFACE {
       interfaces {
           "$junos-interface-ifd-name" {
               unit "$junos-interface-unit" {
                   proxy-arp restricted;
                   vlan-tags outer "$junos-stacked-vlan-id" inner "$junos-vlan-id";
                   family inet {
                       unnumbered-address lo0.0;
                   }
               }
           }
       }
   }
   SUB-INTERFACE {
       interfaces {
           demux0 {
               unit "$junos-interface-unit" {
                   demux-options {
                       underlying-interface "$junos-underlying-interface";
                   }
                   family inet {
                       demux-source {
                           $junos-subscriber-ip-address;
                       }
                   }
               }
           }
       }
   }
}

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

вешайте traceoptions на dhcp-service и курите логи

 

в документации пишет вот что

In the default ip-address-first matching, the server selects the address-assignment pool to use by matching the IP address in the client DHCP request with the network address of the address-assignment pool. If the client request contains the gateway IP address (giaddr), the local server matches the giaddr to the address-assignment pool’s address. If there is no giaddr in the request, then the DHCP local server matches the IP address of the receiving interface to the address of the address-assignment pool.

 

попробуйте

 

dynamic-profiles {

QNQ-INTERFACE {

interfaces {

"$junos-interface-ifd-name" {

unit "$junos-interface-unit" {

proxy-arp restricted;

vlan-tags outer "$junos-stacked-vlan-id" inner "$junos-vlan-id";

family inet {

unnumbered-address lo0.0 preferred-source-address 192.168.31.1;

}

}

}

}

}

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день!

 

Подскажите куда посмотреть, - запросы c option82 прилетают на MX, получаю username в виде Vlan+Port, но возникла ситуация

где за портом может находиться более одного устройства, как выдать адрес c freeradius на два и более устройства?

 

Работает схема - Влан на свич(влан на пон-порт)

 

на freeradius приходит много полезного:

Wed Sep  9 10:58:56 2015
Packet-Type = Access-Request
User-Name = "0C00000802"
Service-Type = Framed-User
Chargeable-User-Identity = ""
Acct-Session-Id = "26934"
ERX-Dhcp-Options = <cut>
ERX-Dhcp-Mac-Addr = "78a1.06f7.596d"
NAS-Identifier = "mx"
NAS-Port = 3072
NAS-Port-Id = "xe-0/0/0.1073744142:3072"
NAS-Port-Type = Ethernet
ADSL-Agent-Circuit-Id = "\014\000\000\010\002"
ADSL-Agent-Remote-Id = "\374\372\367\305\026\\"
NAS-IP-Address = 192.168.0.2

 

авторизирую по User-Name = "0C00000802" + общий пароль на MX, для отдельных случаев хочеться подмешать ERX-Dhcp-Mac-Addr = "78a1.06f7.596d"

 

стандартная успешная авторизация влан+порт(конфиг + ответ):

"Vlan3069+Ethernet1/9" Cleartext-Password := "password"
 Packet-Type = Access-Accept,
 Acct-Interim-Interval = 300,
 Service-Type = Framed-User,
 Framed-Pool = DHCP-200,
 Framed-IP-Address = 192.168.200.200,
 Framed-IP-Netmask = 255.255.255.0,
 ERX-Service-Activate:1 += "SUB-PROFILE(100m,100m)"

Wed Sep  9 13:02:39 2015 : Auth: Login OK: [Vlan3169+Ethernet1/9/password] (from client mx port 3169)

 

а вот как сюда в авторизацию добавить ERX-Dhcp-Mac-Addr = "78a1.06f7.596d"?

"0C00000802" Cleartext-Password := "password"
 Packet-Type = Access-Accept,
 Acct-Interim-Interval = 300,
 Service-Type = Framed-User,
 Framed-Pool = DHCP-100,
 Framed-IP-Address = 192.168.100.100,
 Framed-IP-Netmask = 255.255.255.0,
 ERX-Service-Activate:1 += "SUB-PROFILE(20m,20m)"

Wed Sep  9 12:46:57 2015 : Auth: Login incorrect: [0C00000802/password] (from client mx port 3072)

Спасибо!

Изменено пользователем alexmasz

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

где за портом может находиться более одного устройства, как выдать адрес c freeradius на два и более устройства?

username тогда стоит составлять из mac-address, opt82.

если захочется сделать ограничение по порту то смотреть в сторону interface-set

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
username тогда стоит составлять из mac-address, opt82.

 

вот этого и хочется, с isc-dhcp так и есть, если за ONU более 1го устройства я просто добавляю mac абонента к классу и все.

сам вопрос такой: куда, что и как воткнуть - что бы freeradius, если это явно указано, дополнительно спрашивал mас абонента.

 

допустим, если как в isc-dhcp, конфиг мог бы выглядеть так:

"0C00000802" Cleartext-Password := "password" ERX-Dhcp-Mac-Addr = "78a1.06f7.596d"
 Packet-Type = Access-Accept,
 Acct-Interim-Interval = 300,
 Service-Type = Framed-User,
 Framed-Pool = DHCP-100,
 Framed-IP-Address = 192.168.100.100,
 Framed-IP-Netmask = 255.255.255.0,
 ERX-Service-Activate:1 += "SUB-PROFILE(20m,20m)"

 

ну собственно что пересылает МХ

services {
   dhcp-local-server {
       pool-match-order {
           ip-address-first;
           external-authority;
       }
       forward-snooped-clients configured-interfaces;
       group local {
           authentication {
               password secret-password;
               username-include {
                   option-82 circuit-id;
               }                       
           }                           
           dynamic-profile SUB-INTERFACE;
           interface xe-0/0/0.0;       
       }                               
}     

Изменено пользователем alexmasz

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот такая конструкция работает, после Cleartext-Password := "password" ставим запятую и:

 

"0C00000802" Cleartext-Password := "password", ERX-Dhcp-Mac-Addr = "78a1.06f7.596d"
 Packet-Type = Access-Accept,
 Acct-Interim-Interval = 300,
 Service-Type = Framed-User,
 Framed-Pool = DHCP-100,
 Framed-IP-Address = 192.168.100.100,
 Framed-IP-Netmask = 255.255.255.0,
 ERX-Service-Activate:1 += "SUB-PROFILE(20m,20m)"

 

Странно, но по документации ничего у меня не получилось http://wiki.freeradius.org/guide/Mac-Auth

В конфиге в секции authorize { preprocess } дописано rewrite.calling_station_id, но кажется это лишнее,

так как в запросах такой опции не наблюдается:

Wed Sep  9 10:58:56 2015
       Packet-Type = Access-Request
       User-Name = "0C00000802"
       Service-Type = Framed-User
       Chargeable-User-Identity = ""
       Acct-Session-Id = "26934"
       ERX-Dhcp-Options = <cut>
       ERX-Dhcp-Mac-Addr = "78a1.06f7.596d"
       NAS-Identifier = "mx"
       NAS-Port = 3072
       NAS-Port-Id = "xe-0/0/0.1073744142:3072"
       NAS-Port-Type = Ethernet
       ADSL-Agent-Circuit-Id = "\014\000\000\010\002"
       ADSL-Agent-Remote-Id = "\374\372\367\305\026\\"
       NAS-IP-Address = 192.168.0.2

Таким образом если за одной ONU(BDCOM) находится более 1 устройства смело выдаем адреса, думаю с ELTEX проблем тоже не будет.

 

Прошу прощения, тут конечно больше вопрос был по Freeradius, чем по Juniper.

Всем спасибо!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

A в username-include добавит mac-address ? Не проще будет ?

 

Тогда он будет приходить со всеми username, а мне надо только там, где есть грабли в качестве ONU или порта на свиче с более чем 1 абонентом(очень немного таких).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну так если у вас радиус хранит все данные в файле , то да. Этопроблема , а если есть база то это легко чинится:)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день как получить доступ до закрытого форума, стал "счастливым" обладателем этого железа :D

Писал с pingz@bk.ru

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день! Подскажите, кто в курсе, oid для:

 

run show subscribers summary

Subscribers by State
  Configured: 2
  Active: 2679
  Total: 2681

Subscribers by Client Type
  DHCP: 2397
  VLAN: 284
  Total: 2681

 

есть enterprises.2636.3.64.1.1.3.1.0 для Total, не могу найти для значений Subscribers by Client Type.

Спасибо!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Приветствую, господа знатоки.

 

Подыскиваем замену 7609. Устали жонглировать фабриками и ловить репликацию трафика на супервизор из-за SPAN для СОРМ, что весьма сильно зажимает транзитный трафик через коробку. Выбор пока пал на EX 4600. Как у него дела со SPAN? Не будет ли аналогичных проблем?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас