Jump to content
Калькуляторы

ip unnumberd и бриджинг на Циске одновременно. Чисто пятничная тема

Диспозиция:

Кошка 3745. Куча интерфейсов.

Есть условно "приходящий" интерфейс. В нем живет "управляющий вилан" без тега (нативный) и несколько с тегом.

Есть несколько условно "уходящих" интерфейсов. В них должен попасть "управляющий вилан" без тега и пучок виланов с ip unnumbered. А так-же 1-2 просто вилана, отроученых на этой кошке.

Циска имеет интерфейс в "управляющем вилане".

Конфиг:

 

bridge irb

 

interface Loopback0

ip address XX.XX.XX.AA 255.255.255.240

 

interface FastEthernet0/1

description "Уходящий Интерфейс"

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 1 native

bridge-group 1

!

interface FastEthernet0/1.501

encapsulation dot1Q 501

ip unnumbered Loopback0

 

interface FastEthernet1/0

description "Приходящий Интерфейс"

no ip address

duplex auto

speed auto

!

interface FastEthernet1/0.1

encapsulation dot1Q 1 native

no cdp enable

bridge-group 1

!

interface FastEthernet1/0.408

encapsulation dot1Q 408

ip address XX.XX.XX.BB 255.255.255.252

ip ospf authentication

 

interface BVI1

description MGMT interface

ip address 10.10.10.10 255.255.255.0

 

ip route XX.XX.XX.CC 255.255.255.255 FastEthernet0/1.501

 

bridge 1 protocol ieee

bridge 1 route ip

 

Трабл:

Хосты, сидящие за ip unnumbered не пингуют ничего, даже XX.XX.XX.AA, но МАС адрес циски у них в АРП таблице есть.

Если разобрать бридж, то все начинает работать, за исключением проброса "управляющего" вилана.

 

Cisco IOS Software, 3700 Software (C3745-ADVENTERPRISEK9-M), Version 12.4(25a), RELEASE SOFTWARE (fc2)

 

Куда копать?

Share this post


Link to post
Share on other sites

други, ну пособите кто нибудь. Неуж-то CCIE нету с нами?

Share this post


Link to post
Share on other sites

Поступило мнение, что это баг конкретного ИОСа. В лабе нету именно 3745, проверка при очередном майнтенсе покажет, кто где срал.

Share this post


Link to post
Share on other sites

Апнем-ка тему.

Тесты на 2651 кошке показали аналогичную картину. Так что ИОС не причём.

Точные тесты показали, что работу ip unnumbered убивает включение сабинтерфейса "уходящего" интерфейса в любом вилане в любой бридж...

 

Есть ещё у народа варианты?

Вот, нагуглилось, но без объяснения.

http://www.opennet.ru/openforum/vsluhforumID6/21968.html

Edited by sol

Share this post


Link to post
Share on other sites

Впихните рядом какую-нибудь 2950 и не парьтесь :)

Можно вообще поменять роутер на каталист, или вам нужны какие-то чисто роутерные фичи, помимо терминации unnumbered интерфейсов?

Share this post


Link to post
Share on other sites

Впихнуть свичку рядом можно... Но не хотелось-бы по целому ряду причин. А роутерные фичи нужны. Шейпинг, иногда НАТ и ещё по мелочи.

 

Тут имеет место быть взрыв мозга. Как должно по идее работать - нихрена не работает. И без видимой причины.

Да и проблему хотелось - бы _решить_ а не городить обходные варианты. Обход проблемы очевиден, но, влечёт за собой + 1 железко в том месте, где хотелось - бы оставить как можно меньше оборудования. По причинам габаритным, климатическим и электропитательным.

Edited by sol

Share this post


Link to post
Share on other sites

Самое простое напрашивается - перенумеровать весь управляющий влан за уходящим интерфейсом и затерминить его на этом же роутере.

Более извратно без перенумерации - сделать еще один лупбэк с ip, прописанным у управляемых девайсов как дефолт шлюз, сделать управляющий сабинтерфейс unnumbered и напихать туда 32-х роутов с редистрибуцией их куда-то в голову сети. IP лупбэка не анонсить никуда, т.к. я понимаю он у вас существует на другой вышестоящей железяке.

Share this post


Link to post
Share on other sites

это приходило мне в голову, НО! Есть ряд виланов, которые просто должны быть прогнаны "мимо". Безо всякой терминации на этой кошке. Так вот, ip unnumbered перестаёт работать как только какой-то из сабов интерфейса становится членом бртджа.

 

Пример:

 

int fa 0/0

desc Uplink

 

int fa 0/0.100

ip 5.5.5.5/24

desc BBone

 

int lo 1

ip 6.6.6.254/24

 

int fa 0/1

desc Downlink

 

int fa 0/1.200

enc dotq 200

ip unn lo1

desc Abonent

 

ip route 6.6.6.1 255.255.255.255 fa 0/1.200

 

Вот всё заработало. Абонент запинговался.

 

Делаем бридж.

 

bridge irb

bridge 1 proto ieee

 

 

int fa 0/0.300

enc dot1q 300

desc аплинк для транзитного вилана

bridge-group 1

 

int fa 0/1.300

enc dotq 300

desc даунлинк для транзитного вилана

 

Пока всё работает.

 

bridge-group 1

 

Все, unnumbered клиент отвалился. А бридж прекрасно работает. Стоит только выкинуть fa 0/1.300 из бриджа - ip unnumbered начинает работать.

 

При этом, ARP таблицы и на кошке и у клиента правильные. Не ходит только ip.

Share this post


Link to post
Share on other sites

Точные опыты показали, что если вместо irb пользоваться crb то всё очень ОК. Кроме, конечно, ip интерфейса кошки в этом самом бридже.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this