Jump to content
Калькуляторы

Просьба помочь с multicast льется незапрошенный мультикаст в порт

уважаемые коллеги, если кто то сталкивался с подобной проблемой, плз подскажите что делать.

 

1. Есть поток мультикаст (мегабит 400), приземляется как source на access порт в 10 влан на c4948E. Настроен ip pim sparse-mode, на int vlan 10 назначен IP адрес, который есть же рандеву точка на этой же 4948. (10 влан = мультикаст влан в нашей сети)

 

2. Транком к этой 4948 подключен 3750, на нем настроен mvr, mvr vlan 10, набор mvr group, mvr mode dynamic, на транковом порту в сторону 4948 назначено mvr type source.

 

3. Транком к 3750 подключен с2950Т, на обоих транках (и 3750 и 2950Т) назначено mvr type source, на 2950Т тоже включен весь необходимый набор мвр. mvr vlan 10. На 2950Т еще нет ни одного порта в режиме mvr receiver.

 

Собственно, проблема такая:

Обраружилось, что в транковый порт с 3750 ---> 2950Т летит 100 мбит (свичи тоже подключены друг к другу на 100Мбит/с). Пропали пинги до интерфейса управления на 2950Т.

SPAN на 3750 показал, что в транке все 100 мбит - наш мультикаст поток - сколько влезло судя по всему в физический линк.

 

Вопрос, как мог взяться поток в 100 мбит, если sh mvr group не показывает вообще запрошенных мультикаст групп с этого порта (3750-2950Т) со стороны 2950Т? debug ip igmp не показал какой либо активности (что естественно) со стороны 2950Т, некому там проявлять активность по igmp.

 

Просто летит поток, потом может прекратиться вдруг, потом снова начаться. На приложенном графике видно поведение.

 

Подскажите, как продиагностировать или даже устранить проблему ?

post-1316-053863500 1340806152_thumb.jpg

Share this post


Link to post
Share on other sites

Влан с мвр и влан с сорсами должны быть разные.

Share this post


Link to post
Share on other sites

раньше вместо c4948 стояла 3750 с настроенным mvr и она же была ip igmp snoop querer - все работало нормально. При том что source и mvr вланы были одним и тем же.

 

Даже сейчас на 3750 приходят более одной с2950Т в которых есть клиенты IPTV и все работает вполне нормально, льется только запрошенный multicast.

На сабжевой c2950T все те же самые настройки, как и на здоровых свичах. Но в ее транк прет незапрошенный мультикаст.

 

Завтра попробуем ее заменить, может там что то в силиконе заболело.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this