Jump to content
Калькуляторы

Проблема с SUP7203bxl

Доброго времени суток!

Имеется цыска 6509 SUP7203bxl в неё воткнуты акцессом 3845 и транком ESR-10K

Сегодня столкнулись с такой проблемой: начались рваться динимические линки роутинга по BGP и EIGRP, в логах только записи вида:

000192: Jun 18 09:27:49: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is down: holding time expired
000193: Jun 18 09:27:52: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is up: new adjacency
000194: Jun 18 09:29:56: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is down: holding time expired
000195: Jun 18 09:29:57: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is up: new adjacency
000196: Jun 18 09:35:58: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is down: holding time expired
000197: Jun 18 09:36:03: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is up: new adjacency
000198: Jun 18 09:37:05: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.2 (Vlan3) is down: holding time expired
000199: Jun 18 09:37:05: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.2 (Vlan3) is up: new adjacency
000200: Jun 18 09:43:47: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.2 (Vlan3) is down: holding time expired
000201: Jun 18 09:43:51: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.2 (Vlan3) is up: new adjacency
000202: Jun 18 09:44:20: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is down: holding time expired
000203: Jun 18 09:44:25: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is up: new adjacency
000204: Jun 18 09:45:42: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.2 (Vlan3) is down: holding time expired
000205: Jun 18 09:45:46: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.2 (Vlan3) is up: new adjacency
000206: Jun 18 09:47:52: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is down: holding time expired
000207: Jun 18 09:47:55: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is up: new adjacency
000208: Jun 18 09:53:17: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.2 (Vlan3) is down: holding time expired
000209: Jun 18 09:53:20: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.2 (Vlan3) is up: new adjacency
000210: Jun 18 10:08:52: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is down: holding time expired
000211: Jun 18 10:08:57: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is up: new adjacency
000212: Jun 18 10:10:43: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is down: holding time expired
000213: Jun 18 10:11:06: %DUAL-5-NBRCHANGE: EIGRP-IPv4 43031: Neighbor 172.16.0.3 (Vlan3) is up: new adjacency
000214: Jun 18 10:12:04: %BGP-5-ADJCHANGE: neighbor хх.хх.58.61 Down BGP Notification sent
000215: Jun 18 10:12:04: %BGP-3-NOTIFICATION: sent to neighbor хх.хх.58.61 4/0 (hold time expired) 0 bytes
000216: Jun 18 10:12:48: %BGP-5-ADJCHANGE: neighbor хх.хх.58.61 Up

И никакой более ругани указывающей на суть проблемы, на других цысках тоже самое падение EIGRP и ничего более, иными словами проблема точно в 6509, подскажите кто сталкивался что это может быть?

Share this post


Link to post
Share on other sites

конфиг в студию. как возможные варианты: перекручены таймеры или есть какие-то acl, что маловероятно. еще возможны потери пакетов ввиду перегрузки канала или ошибок.

Share this post


Link to post
Share on other sites

конфиг в студию. как возможные варианты: перекручены таймеры или есть какие-то acl, что маловероятно. еще возможны потери пакетов ввиду перегрузки канала или ошибок.

upgrade fpd auto
version 12.2
parser config cache interface
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
service sequence-numbers
service counters max age 60
no service dhcp
service unsupported-transceiver
!
hostname C6509-CORE
!
boot-start-marker
boot system flash bootdisk:s72033-adventerprisek9_wan-vz.122-33.SXI6.bin
boot-end-marker
!
security passwords min-length 1
logging queue-limit 10000
logging buffered 5000000
logging rate-limit 10 except warnings
!
aaa new-model
!
!
!
!
!
aaa session-id common
clock timezone TMP 6
clock calendar-valid
logging event link-status default
no ip source-route
ip arp gratuitous none
no ip gratuitous-arps
ip icmp rate-limit unreachable 100
ip icmp rate-limit unreachable DF 100
!
!
ip tcp selective-ack
ip tcp timestamp
ip tcp path-mtu-discovery
no ip domain-lookup
!
no ip bootp server
ip flow-cache entries 524288
ip flow-cache timeout inactive 30
ip flow-cache timeout active 1
ip ssh authentication-retries 5
ip ssh version 2
login on-failure log
mls qos
mls aging fast time 10 threshold 50
mls netflow interface
mls netflow usage notify 90 120
mls flow ip interface-full
mls nde sender version 5
mls cef error action reset
!
crypto pki trustpoint TP-self-signed-43001
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-43001
revocation-check none
rsakeypair TP-self-signed-43001
!
!
crypto pki certificate chain TP-self-signed-43001
certificate self-signed 01
!
!
!
!
!
errdisable recovery cause udld
errdisable recovery cause bpduguard
errdisable recovery cause security-violation
errdisable recovery cause channel-misconfig
errdisable recovery cause pagp-flap
errdisable recovery cause dtp-flap
errdisable recovery cause link-flap
errdisable recovery cause gbic-invalid
errdisable recovery cause l2ptguard
errdisable recovery cause psecure-violation
errdisable recovery cause dhcp-rate-limit
errdisable recovery cause unicast-flood
errdisable recovery interval 120
diagnostic bootup level minimal
!
spanning-tree mode pvst
!
!
access-list 100 deny   udp any host 255.255.255.255
access-list 100 permit ip any any
access-list 100 deny   ip any any
!
redundancy
main-cpu
 auto-sync running-config
mode sso
!
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
policy-map 10M
 class class-default
  police 10240000 12800 12800    conform-action transmit     exceed-action drop
policy-map 1M
 class class-default
  police 1024000 1280 1280    conform-action transmit     exceed-action drop
!
!
!
!
!
!
interface Tunnel0
description LOGICA
ip address 10.11.0.1 255.255.255.252
ip access-group 100 in
ip access-group 100 out
ip flow ingress
ip flow egress
ip route-cache policy
ip tcp adjust-mss 1436
tunnel mode ipip
!
interface Tunnel2
description "Tunnel to TR-DM Tovarny dvor"
bandwidth 1024
ip address 10.11.0.5 255.255.255.252
ip access-group 100 in
ip access-group 100 out
ip flow ingress
ip flow egress
ip route-cache policy
ip tcp adjust-mss 1436
tunnel mode ipip
!
interface Tunnel4
description GALAREYA-M
bandwidth 1024
ip address 10.11.0.17 255.255.255.252
ip access-group 100 in
ip access-group 100 out
ip flow ingress
ip flow egress
ip route-cache policy
ip tcp adjust-mss 1436
tunnel mode ipip
!
interface Tunnel5
description OCIMTOO
ip address 10.11.0.21 255.255.255.252
ip access-group 100 in
ip access-group 100 out
ip flow ingress
ip flow egress
ip route-cache policy
ip tcp adjust-mss 1436
tunnel mode ipip
!
interface Tunnel12
description METELKOVA
ip address 10.11.0.53 255.255.255.252
ip access-group 100 in
ip access-group 100 out
ip flow ingress
ip flow egress
ip route-cache policy
ip tcp adjust-mss 1436
tunnel mode ipip
!
interface Loopback0
no ip address
!
interface Port-channel1
description C3550-12T-BLAID-FARM-1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
hold-queue 4096 in
hold-queue 4096 out
!
interface Port-channel2
description C3550-12T-BLAID-FARM-2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet5/1
description C3845-C-B-1 GIG0/0
switchport
switchport access vlan 3
load-interval 30
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet5/2
description C6509-C-A-1 GIG-0/2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
load-interval 30
media-type rj45
mls qos vlan-based
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/1
no ip address
load-interval 30
shutdown
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/2
no ip address
load-interval 30
shutdown
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/3
description ESR-10K GIG 1/0/0
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
load-interval 30
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/4
no ip address
load-interval 30
shutdown
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/5
no ip address
load-interval 30
shutdown
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/6
no ip address
load-interval 30
shutdown
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/7
description C3550-12T-BLAID-FARM GIG0/11
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
load-interval 30
channel-group 1 mode auto
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/8
description C3550-12T-BLAID-FARM GIG0/12
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
load-interval 30
channel-group 1 mode auto
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/9
no ip address
load-interval 30
shutdown
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/10
no ip address
load-interval 30
shutdown
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/11
no ip address
load-interval 30
shutdown
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/12
no ip address
load-interval 30
shutdown
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/13
description C3550-12T-BLAID-FARM GIG0/11
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
load-interval 30
channel-group 2 mode auto
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/14
description C3550-12T-BLAID-FARM GIG0/12
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
load-interval 30
channel-group 2 mode auto
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/15
description ROSTELECOM
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 800-899
switchport mode trunk
load-interval 30
speed nonegotiate
no cdp enable
hold-queue 4096 in
hold-queue 4096 out
!
interface GigabitEthernet9/16
no ip address
load-interval 30
shutdown
hold-queue 4096 in
hold-queue 4096 out
!
interface Vlan1
description MANAGEMENT
ip address 10.10.0.34 255.255.0.0
no ip redirects
no ip proxy-arp
ip flow ingress
ip flow egress
no ip route-cache
no ip mroute-cache
load-interval 30
!
interface Vlan3
description CORE
ip address 172.16.0.1 255.255.255.0
no ip redirects
no ip proxy-arp
ip flow ingress
ip flow egress
ip route-cache policy
hold-queue 4096 in
hold-queue 4096 out
!
!
interface Vlan700
description BEELINE-UPLINK-INET
ip address xx.xx.99.98 255.255.255.252
no ip redirects
no ip proxy-arp
ip flow ingress
ip flow egress
ip route-cache policy
load-interval 30
hold-queue 4096 in
hold-queue 4096 out
!
interface Vlan800
description ROSTELECOM-UPLINK-INET
ip address xx.xx.58.62 255.255.255.252
no ip redirects
no ip proxy-arp
ip flow ingress
ip flow egress
ip route-cache policy
load-interval 30
hold-queue 4096 in
hold-queue 4096 out
!
!
router eigrp 43031
network xx.xxx.0.0 0.0.15.255
network 172.16.0.0 0.0.0.255
redistribute connected
redistribute static
passive-interface default
no passive-interface GigabitEthernet5/1
no passive-interface Vlan3
!
router bgp 43031
no synchronization
bgp router-id xx.xx.0.1
bgp always-compare-med
bgp log-neighbor-changes
bgp bestpath compare-routerid
network xx.xx.0.0 mask 255.255.240.0
network xx.xx.0.0 mask 255.255.248.0
network xx.xx.8.0 mask 255.255.248.0
neighbor xx.xx.99.97 remote-as 3216
neighbor xx.xx.99.97 description ---=== BEELINE AS 3216 - Full View ===---
neighbor xx.xx.99.97 soft-reconfiguration inbound
neighbor xx.xx.99.97 route-map PREPEND-2 out
neighbor xx.xx.58.61 remote-as 12389
neighbor xx.xx.58.61 description ---=== ROSTELECOM AS 12389 - Full View ===---
neighbor xx.xx.58.61 soft-reconfiguration inbound
neighbor xx.xx.58.61 route-map PREPEND-2 out
no auto-summary
!
ip classless
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 xx.xx.58.61
ip route 10.9.2.32 255.255.255.252 10.11.0.54
ip route 10.9.2.40 255.255.255.252 10.11.0.54
ip route xx.xx.0.0 255.255.240.0 Null0
ip route xx.xx.0.0 255.255.248.0 Null0
ip route xx.xx.8.0 255.255.248.0 Null0
!
ip http server
ip http authentication local
ip http secure-server
ip flow-export source Vlan1
ip flow-export version 5
!
!
!
!
route-map SET-LOCAL-PREF permit 10
match as-path 1
set local-preference 200
!
route-map PREPEND-1 permit 10
match ip address prefix-list ROSTELECOM-out
set as-path prepend 43031
!
route-map PREPEND-2 permit 10
match ip address prefix-list ROSTELECOM-out
!
snmp-server ifindex persist
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps chassis
snmp-server enable traps module
snmp-server enable traps casa
snmp-server enable traps vtp
snmp-server enable traps vlancreate
snmp-server enable traps vlandelete
snmp-server enable traps rf
snmp-server enable traps fru-ctrl ps-output-change status
snmp-server enable traps entity
snmp-server enable traps c6kxbar intbus-crcexcd intbus-crcrcvrd swbus
snmp-server enable traps slb real virtual csrp
snmp-server enable traps rtr
snmp-server enable traps flash insertion removal
snmp-server enable traps syslog
snmp-server enable traps srp
snmp-server enable traps rsvp
snmp-server enable traps hsrp
snmp-server enable traps envmon fan shutdown supply temperature status
snmp-server enable traps dlsw
snmp-server enable traps sonet
snmp-server enable traps config
snmp-server enable traps config-copy
snmp-server enable traps bgp
snmp ifmib ifindex persist
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
line con 0
line vty 0 4
transport input telnet ssh
transport output telnet ssh
line vty 5 15
transport input telnet ssh
transport output telnet ssh
!
exception core-file
ntp clock-period 16925449
ntp master
ntp server 195.2.64.5 version 2
ntp server 194.186.254.22 version 2
ntp server 80.90.180.140 version 2 prefer
!
end

Таймеры дефолтные, да стояла система уже месяца два без проблем. АЦЛ нет, потери тоже врятли так как трафика всего то мегабит 120-140

Share this post


Link to post
Share on other sites

уверенны, что вам нужна эта настройка?

hold-queue 4096

Hold-queue – задает длину очереди пакетов на отправку в интерфейс. Единица измерения – 1 пакет. Максимальное значение 4096 пакетов.

 

Пакеты обрабатываются маршрутизатором по принципу первый пришел, первый ушел. Часто возникает ситуация, когда два пакета приходят на порт одновременно или практически одновременно (второй пакет приходит когда порт занят обработкой предидущего). Если длинна очереди нулевая (hold-queue 0), пакет пришедший вторым – отбрасывается.

 

Для предотвращения подобных ситуаций и создан параметр hold-queue. Приходящие на порт пакеты ставятся в очередь и обрабатываются последовательно. Отбрасываются только пакеты “неуместившиеся” в очередь.

 

Cisco не рекомендует править параметр hold-queue заданный поумолчанию. Явно заданный параметр влияет на пропускную способность канала.

что говорит

#sh processes cpu history 

   111111111     1111111111111111111     11111     1111111111
   1111222227777711111111110000000009999911111999992222200000
100                                                           
90                                                           
80                                                           
70                                                           
60                                                           
50                                                           
40                                                           
30                                                           
20                                                           
10 **********************************************************
  0....5....1....1....2....2....3....3....4....4....5....5....
            0    5    0    5    0    5    0    5    0    5    
              CPU% per second (last 60 seconds)

   1111111119111111111116111111912111111111111111119311111111
   3564343349434432243527253454940535322355435567439937335363
100          *                  *                   *         
90          *                  *                   *         
80          *                  *                   *         
70          *           *      *                   *         
60          *           *      *                   *         
50          *           *      *                   *         
40          *           *      *                   **        
30          *           *      *                   **        
20  **      #         * # *  * # ** *    **  ****  #* *  * * 
10 ##########################################################
  0....5....1....1....2....2....3....3....4....4....5....5....
            0    5    0    5    0    5    0    5    0    5    
              CPU% per minute (last 60 minutes)
             * = maximum CPU%   # = average CPU%
       1          1    1                   1   1  1               1  1   
   9999099978889990999909999999898878999999099909909999997998999990990999
   9999099067489990999909999999684964799999099909909999991008969990990999
100 *******     **************** *    ********************    ************
90 ******** * ******************* *  ******************** ***************
80 ****************************************************** ***************
70 **********************************************************************
60 **********************************************************************
50 **********************************************************************
40 **********************************************************************
30 **********************************************************************
20 ****#***********#*****************************************************
10 ######################################################################
  0....5....1....1....2....2....3....3....4....4....5....5....6....6....7.
            0    5    0    5    0    5    0    5    0    5    0    5    0 
                  CPU% per hour (last 72 hours)
                 * = maximum CPU%   # = average CPU%

 

можно

Share this post


Link to post
Share on other sites

а чем вам hold-queue 4096 не угодила? Да там fifo первым пришел первым ушел но дефолтное значение вроде как 75

Share this post


Link to post
Share on other sites

а чем вам hold-queue 4096 не угодила? Да там fifo первым пришел первым ушел но дефолтное значение вроде как 75

Да мы такой же мысли придерживались меняя параметр.

C6509-CORE#sh proc cpu history

                  11111122334543     111111
   5555555666778890135793729616687899124652788444444444444555
100
90
80
70
60
50                          ***
40                         *****
30                       *******
20                   ***********        **
10 *******************************************            ***
  0....5....1....1....2....2....3....3....4....4....5....5....
            0    5    0    5    0    5    0    5    0    5
              CPU% per second (last 60 seconds)
             * = maximum CPU%   # = average CPU%
                                     11
   3233533325322334222252222422235232007233533335322345333352
   1861721990189086979728868777841859006913234160287373144148
100                                   *#
90                                   *#
80                                   ##*
70                                   ##*
60     *                             ##*
50     *    *     *    *    *    *   ##*   *    *    **    *
40   * *  * *    **    *    *    * * ##*   *   **    **    *
30 **********************************##**********************
20 **********************************###*********************
10 ##########################################################
  0....5....1....1....2....2....3....3....4....4....5....5....
            0    5    0    5    0    5    0    5    0    5
              CPU% per minute (last 60 minutes)
             * = maximum CPU%   # = average CPU%
   1        1              1     1         1                     1
   0555555550555555555555550556660555555555057559555555555555555505555555
   0553616310244363687884730440010245445713041659667816659331246307664615
100 *        *              *     *         *    *                *
90 *        *              *     *         *    *                *
80 *        *              *     *         *    *                *
70 *        *              *     *         * *  *                *
60 *** * *  *    * ***** * *  ****  *  **  * ******** ****     * **** * *
50 **********************************************************************
40 **********************************************************************
30 **********************************************************************
20 **********************************************************************
10 ######################################################################
  0....5....1....1....2....2....3....3....4....4....5....5....6....6....7.
            0    5    0    5    0    5    0    5    0    5    0    5    0
                  CPU% per hour (last 72 hours)
                 * = maximum CPU%   # = average CPU%

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this