Перейти к содержимому
Калькуляторы

транк? между Sup720 и 3745

Коллеги, добрый день!

 

Подскажет может знающий человек, нужно оорганизовать dot1q туннель/линк между Catalyst 6509 с Sup720 и Cisco 3745 с 36ти портовым коммутатором на борту. Межде ними существует л2 канал, который режет все VLAN теги (access)

 

MPLS/L2TPv3/???

 

Спасибо!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Может перенастроить l2 канал в Q-in-Q ? (Если это оператор, то попросить перенастроить со стороны оператора линк в Q-in-Q).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

to triam: вообще никак, чистый access дают

 

а в MPLS на 3745 вроде dot1q нельзя пропустить (EoMPLS)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Xconnect можно сделать с сабинтерфеса. Но вот поддерживается ли такая фича на 3745 не готов сказать.

Изменено пользователем triam

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Xconnect можно сделать с сабинтерфеса. Но вот поддерживается ли такая фича на 3750 не готов сказать.

 

а как со стороны кошака, можете дать объяснение в виде куска конфига?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Q-in-Q с понижением mtu так до 1460 или скока там на тег надо.. но дело в том что косяков кучу всплывет и это надо все сетевое оборудование переводить на кадры 1460

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Xconnect можно сделать с сабинтерфеса. Но вот поддерживается ли такая фича на 3745 не готов сказать.

 

а как со стороны кошака, можете дать объяснение в виде куска конфига?

 

Поддерживается нормально xconnect в с3745. Входите в сабинтерфейс, пишите там xconnect PEER_IP VC_ID encapsulation mpls, как обычно это делается в cisco ios.

 

C mtu конечно геморрой поимеете, хотя смотря какой трафик вам пропкускать надо

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Поддерживается нормально xconnect в с3745. Входите в сабинтерфейс, пишите там xconnect PEER_IP VC_ID encapsulation mpls

 

Тоесть dot1q tunnel я могу протащить ?

 

как обычно это делается в cisco ios.

 

Глубоко начинающ я в MPLS отрасли :)

 

Ну и вопрос по кошке, где там xconnect ставить ?

Изменено пользователем zander

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Поддерживается нормально xconnect в с3745. Входите в сабинтерфейс, пишите там xconnect PEER_IP VC_ID encapsulation mpls

Тоесть dot1q tunnel я могу протащить ?

 

Делаете саб, а на нижестоящей железке навешиваете внешний тег, таким образом пропустите много вланов

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Мой SUP720-BASE не умеет MPLS. В схеме ещё присутсвует Juniper J-2320, может поднять MPLS между ним и C3745 ? А с него вторым портом уйти на каталист ?

 

 

<C3745> -------L2link--------<J-2320>---Dot1Q trunk---<Cat6509>

 

может так получится протащить dot1q trunk ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну тут как раз всё совсем просто =)

 

[xconnect 1.1.1.1 100 enc mpls ]-----Gi0/1.100---c3750---mpls----J-2320--l2circuit--from-ge-0/0/0.100-----trunk---cat6509-----

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну тут как раз всё совсем просто =)

 

[xconnect 1.1.1.1 100 enc mpls ]-----Gi0/1.100---c3750---mpls----J-2320--l2circuit--from-ge-0/0/0.100-----trunk---cat6509-----

 

triam, уважаемый, можно прямо кусками конфигов ?

Изменено пользователем zander

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да можно наверное. Тогда выложите сюда конфиги ваших железок. Лениво рисовать.

 

Если в двух словах то

1)Интерфейс в сторону L2-канала на с3745 пишим mpls ip. В глобальной конфигурации:

mpls ldp explicit-null

no mpls ip propagate-ttl

mpls label range 100000 524286

mpls label protocol ldp

mpls ldp router-id ВАШ_интерфейс_в_сторону_Л2канала force

interface Gi0/0

mpls ip

int Gi0/1.100

xconnect IP-j2320 100 enc mpls

2) На J2320

set protocols mpls interface ge-X/x/x.0 <--- в сторону Л2 канала

set protocols ldp interface ge-x/x/x.0

set interface ge-x/x/x.0 family mpls

set protocols l2circuit neighbor IP-c3745 interface ge-y/y/y.0 virtual-circuit 100

set interface ge-y/y/y.0 family ccc

 

Вот как-то так =)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Что-то на 3745 encap mpls нет, только encap l2tpv3

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Что-то на 3745 encap mpls нет, только encap l2tpv3

Печаль!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

triam, а вот в приведенных Вами конфигах, на циске gi0/0 это и есть l2 канал в сторону поставщика канала?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

triam, а вот в приведенных Вами конфигах, на циске gi0/0 это и есть l2 канал в сторону поставщика канала?

да

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

2) На J2320

set protocols mpls interface ge-X/x/x.0 <--- в сторону Л2 канала

set protocols ldp interface ge-x/x/x.0

set interface ge-x/x/x.0 family mpls

set protocols l2circuit neighbor IP-c3745 interface ge-y/y/y.0 virtual-circuit 100

set interface ge-y/y/y.0 family ccc

 

 

А этого точно хватит, чтобы p2p между 3745 и 2320 появилась в inet.3 на 2320? Или l2circuit без inet.3 маршрута построится?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

To all:

 

В конечном итоге из схемы пришлось выкинуть 3745 и заменить на второй J-2320+Cat3550

 

 

<Cat3550>---<J-2320>------L2access-operator-network------<J-2320>---<Cat6509>

 

Повторю вопрос: нужно прозрачный Dot1q tunnel между 3550 и 6509

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

To all:

 

В конечном итоге из схемы пришлось выкинуть 3745 и заменить на второй J-2320+Cat3550

 

 

<Cat3550>---<J-2320>------L2access-operator-network------<J-2320>---<Cat6509>

 

Повторю вопрос: нужно прозрачный Dot1q tunnel между 3550 и 6509

 

Не решается эта задача по уму никак.

 

Даже если что-то придумаете, в MTU упретесь по любому.

 

Можно искать Unix_base решения, типа бридж с фрагментацией/дефрагментацией, наверняка есть что-то.

На Cisco MTU можно обойти только одним хитрым извращением: GRE, на котором принудительно выставить требуемое MTU, тогда пакеты будут сами фрагментироваться.

Поверх GRE - MPLS, поверх MPLS - Ethernet Over MPLS, в том числе и с транком.

Не уверен, что 6500 умеет MTU на GRE в чипе да функционал EoMPLS у 6500 ограничен. 3550 не умеет точно ничего.

3745 вполне может не уметь MPLS, надо смотреть фичанифигатор и, возможно, какой-то софт умеет. Но производительность такого счастья - 10М в прыжке.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Так я ж джуниперы в схему вставил, они точно всё умеют, циску выкинул из схемы. На оба каталиста уже приходить dot1q tunnel, им про MPLS вообще не интересно

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В общем чтение документации Juniper + совет от SergeiK о GRE тунелях, рабочий конфиг джунипера:

 

version 9.6R2.11;
interfaces {
   ge-0/0/0 {
       description "Management"
       unit 0 {
           family inet {
               address 192.168.1.23/24;
           }
       }
   }
   gr-0/0/0 {
       description "GRE тунель для проброса по сети оператора с непонятным MTU"
       unit 0 {
           clear-dont-fragment-bit;
           tunnel {
               source 172.16.10.2;
               destination 172.16.10.1;
               allow-fragmentation;
           }
           family inet {
               mtu 1400;
               address 172.16.1.2/30; # С другой стороны 172.16.1.1
           }
           family mpls;
       }
   }
   ge-0/0/2 {
       description "L2 оператор"
       unit 0 {
           family inet {
               address 172.16.10.2/30;  # С другой стороны 172.16.10.1
           }
           family mpls;
       }
   }
   ge-0/0/3 {
       description "Транк dot1q на каталист"
       encapsulation ethernet-ccc;
       unit 0 {
           family ccc;
       }
   }
   lo0 {
       unit 0 {
           family inet {
               address 2.2.2.2/32;  # С другой стороны 1.1.1.1
           }
       }
   }
}
routing-options {
   router-id 2.2.2.2;  # С другой стороны 1.1.1.1
}
protocols {
   mpls {          
       interface lo0.0;
       interface gr-0/0/0.0;
   }
   ospf {
       area 0.0.0.0 {
           interface lo0.0 {
               passive;
           }
           interface gr-0/0/0.0;
       }
   }
   ldp {
       interface gr-0/0/0.0;
       interface lo0.0;
   }
   l2circuit {
       neighbor 1.1.1.1 {  # С другой стороны 2.2.2.2
           interface ge-0/0/3.0 {
               virtual-circuit-id 10;
           }
       }
   }
}
security {
   forwarding-options {
       family {
           mpls {
               mode packet-based;
           }
       }
   }
}

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В итоге 3745 не удалось завести в желаемой конфигурации (по причине отсутствия софта поддерживающего xconnect encapsulation mpls). Заменил на 2801. Привожу конфиг, который работает с джунипером ( конфиг которого я запостил выше):

 

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 
!
aaa new-model
!
!
!
!
aaa session-id common
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
username zander password 0 
!
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface Tunnel1
description GRE тунель для проброса по сети оператора с непонятным MTU
ip unnumbered Loopback1
ip ospf network point-to-point
mpls ip
tunnel source 172.16.10.2
tunnel destination 172.16.10.1
tunnel path-mtu-discovery
!
interface FastEthernet0/0
description L2 оператор
ip address 172.16.10.2 255.255.255.252
speed 100
full-duplex
!
interface FastEthernet0/1
description Транк dot1q на каталист
no ip address
speed 100
full-duplex
xconnect 1.1.1.1 10 encapsulation mpls
!         
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
passive-interface default
no passive-interface Loopback1
no passive-interface Tunnel1
network 2.2.2.2 0.0.0.0 area 0.0.0.0
!
!
!
mpls ldp router-id Loopback1 force
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
!
scheduler allocate 20000 1000
end

 

Как ожидалось, в схеме Juniper/Cisco производительность решения оказалась на уровне семи! мегабит (в сумме туда/сюда). Схема Juniper/Juniper выдала боее 100! мегабит в сумме (и это младшая модель!)

 

Вероятно не просто так Ростеле_ком свои магистрали несколько лет назад начал переводить на решения Juniper

 

 

---

wbr,

Alexander Mikheev

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2801

дешевая офисная железка.. что вы от нее хотите

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас