Jump to content
Калькуляторы

Cisco SCE 2020 Отчеты, графики

Настроил Cisco SCE 2020, Collection Manager, Database (Mysql).

SCE отправляет RDR на Collection Manager, часть отчетов я могу получить.

А большая часть выдает пустые графики, Insight Reporter выдает ошибку:

"No data found for current selection". Может чего надо дополнительно включить?

 

Задача определить какой процент от общего объема трафика принадлежит торренту, а также ужать торрент трафик для всех клиентов.

Необходим ли мне Subcriber Manager?

 

Софт версии 3.7.5.

Share this post


Link to post
Share on other sites

Subcriber Manager не потребуется.

 

А тестирование подключения к СУБД из SCA BB нормально проходит?

Share this post


Link to post
Share on other sites

Тестирование нормально.

Настройку сделал только первоначальную.

В SCA BB Console создал SCE, CM, DB.

Далее запустил мастер Usage Analysis Wizard, мастер работу закончил без ошибок.

В конфиге SCE появилась строка - отправлять рдр на ип сце.

СМ базу наполняет.

 

Этих шагов достаточно чтобы получить графики загруженности канала?

Share this post


Link to post
Share on other sites

В SCA Reporter получаю графики пустыми:

Average Subcriber Bandwidth

Global Bandwidth per Service

 

и другие графики из раздела Global Monitoring.

репортер обращается к таблице RPT_LUR.

Но она у меня пустая, после установки CM, запускал только скрипт:

./scripts/dbperiodic.sh

 

CM складывает данные в таблицу RPT_TR.

Edited by Macro

Share this post


Link to post
Share on other sites

В SCA Reporter получаю графики пустыми:

Average Subcriber Bandwidth

Global Bandwidth per Service

 

и другие графики из раздела Global Monitoring.

репортер обращается к таблице RPT_LUR.

Но она у меня пустая, после установки CM, запускал только скрипт:

./scripts/dbperiodic.sh

 

CM складывает данные в таблицу RPT_TR.

В конфигурации SCA-BB проверь, чтобы была активирована опция в RDR Settings "Generate Link Usage RDR".

Share this post


Link to post
Share on other sites

В конфигурации SCA-BB проверь, чтобы была активирована опция в RDR Settings "Generate Link Usage RDR".

Включена опция.

Может чего в конфиге самой SCE?

Вот конфиг:

#This is a general configuration file (running-config).
#Created on 10:08:28  UTC  FRI  May  25  2012

#cli-type 1
#version 1

service password-encryption
enable password level 0 5 "XXXXXXXXXXXXXXXXXX"
enable password level 5 5 "XXXXXXXXXXXXXXXXXXX"
enable password level 10 5 "XXXXXXXXXXXXXXXXXXXX"
enable password level 15 5 "XXXXXXXXXXXXXXXXXXXXXX"
no management-agent notifications notification-list 1417,1418,804,815,1404,1405,1406,1407,1408,400
no management-agent notifications notification-list 402,421,440,441,444,445,446,450,437,457
no management-agent notifications notification-list 3593,3594,3595,10040
snmp-server community "public" ro
RDR-formatter destination 192.168.3.20 port 33000 category number 1 priority 100

interface LineCard 0
aggregative-global-controllers
aggregative-global-controller-dynamic mode suspend
aggregative-global-controller network-side 0 cir 0 pir 200000 al 5 parent -1 name ""
aggregative-global-controller subscriber-side 0 cir 0 pir 200000 al 5 parent -1 name ""
aggregative-global-controller-dynamic mode active

connection-mode inline on-failure bypass
no silent
no shutdown
service-bandwidth-prioritization-mode global
protocol-pack version 3.7.5PP28


flow-filter partition name "ignore_filter" first-rule 4 num-rules 32
flow-filter partition name "udpPortsToOpenBySw" first-rule 40 num-rules 21
attack-filter subscriber-notification ports 80
replace spare-memory code bytes 3145728

interface FastEthernet 0/0
ip address 192.168.3.18 255.255.255.0

interface FastEthernet 0/1
ip address 192.168.3.18 255.255.255.0

interface GigabitEthernet 0/1
auto-negotiate

interface GigabitEthernet 0/2
auto-negotiate

interface GigabitEthernet 0/3
auto-negotiate

interface GigabitEthernet 0/4
auto-negotiate

exit
ip default-gateway 192.168.3.1

line vty 0 4
exit
interface Mng 0/1
exit
interface Mng 0/2
exit

interface LineCard 0
subscriber anonymous-group name "Anonymous Group" IP-range 0.0.0.0:0x00000000
exit
no subscriber LEG dhcp-lease-query
subscriber LEG dhcp-lease-query servers 127.0.0.1
logger device SCE-agent-Statistics-Log max-file-size 204800
management-agent property "com.pcube.management.framework.install.activation.operation" "Install"
management-agent property "com.pcube.management.framework.install.activated.version" "3.7.5 build 92"
management-agent property "com.pcube.management.framework.install.activated.package" "SCA BB"
management-agent property "com.pcube.management.framework.install.activation.date" "Sat May 19 22:52:29 UTC 2012"

Share this post


Link to post
Share on other sites

Проверь, что все RDR отправляются (не происходит дропов на SCE):

SCE#>sh RDR-formatter | inc RDR
RDR:    queued:     0 ,sent:1043750184, thrown:     0, format-mismatch:     0

 

Далее проверь, чтобы RDR-tag ,был замаплен корректно (к нужной категории):

 

SCE#>sh RDR-formatter rdr-mapping 0xf0f0f005
Mapping for tag 0xf0f0f005 is: 1

 

Чтобы увидеть, что нужные RDR "улетают" с SCE замапь их другой категориии (по-умолчанию категориия = 1) и настрой отправку только этой категории на CM. На CM можешь посмотреть tcpdamp'ом.

 

Посмотри логи на CM. Попробуй пересоздать таблицу (дропни таблицу и перезапусти CM).

Проверь чтобы была пуста вот эта директория на CM: ~cm/adapters/JDBCAdapter/

Проверь настройки в файле ~cm/config/queue.conf

Share this post


Link to post
Share on other sites

Спасибо за советы, результат с сце:

SCE2000#sh RDR-formatter rdr-mapping 0xf0f0f005
Mapping for tag 0xf0f0f005 is: 1

SCE2000#sh RDR-formatter | incl RDR
RDR:    queued:     0 ,sent:1738067, thrown:     0, format-mismatch:     0

Share this post


Link to post
Share on other sites

[root@sce-cm ~]# grep -v '#' /opt/cm/cm/config/queue.conf

[dbase-hi]
adapter_id=1
priority=3
warning_size=40000
maximum_size=50000
tags=4042321936,4042321922,4042321925,4042321924,4042322000,4042323052,4042321926,4042321928,4042322064,4042322048,4042321927


[bill-hi]
adapter_id=2
priority=3
warning_size=10000
maximum_size=12000
tags=4042323072,4042323004,4042323000,4042321984

[topper-hi]
adapter_id=3
priority=3
warning_size=40000
maximum_size=50000
tags=4042321920

[rag-hi]
adapter_id=4
priority=3
warning_size=40000
maximum_size=50000
tags=4042321920,4042323004,4042323072

[bill-custom]
adapter_id=5
priority=3
warning_size=10000
maximum_size=12000
tags=4042321925

 

~cm/adapters/JDBCAdapter/ - дира пустая.

 

В логах adapter-JDBC нашел вот что:

2012-05-27 22:21:31,929 [wrkr/JDBCAdapter] ERROR com.cisco.scmscm.adapters.jdbc.JDBCAdapter - processRDR - got Throwable
java.lang.ArrayIndexOutOfBoundsException
2012-05-27 22:21:31,929 [wrkr/JDBCAdapter] ERROR com.cisco.scmscm.db.DbInserter.RPT_LUR - insert err - Exception while inserting the rdr values [0, 3, 90, 300, 300, 1338137700, 0, 0, 0, 0, 0, 0, 0], for the rdr tag = 4042321925
java.lang.ArrayIndexOutOfBoundsException
2012-05-27 22:21:31,929 [wrkr/JDBCAdapter] ERROR com.cisco.scmscm.db.DbInserter.RPT_LUR - insert err (more details in next line), tag=4042321925, fieldNo-1=13 curSqlIndex=16, i=15
java.lang.ArrayIndexOutOfBoundsException
2012-05-27 22:21:31,929 [wrkr/JDBCAdapter] ERROR com.cisco.scmscm.adapters.jdbc.JDBCAdapter - processRDR - got Throwable
java.lang.ArrayIndexOutOfBoundsException
2012-05-27 22:21:31,930 [wrkr/JDBCAdapter] ERROR com.cisco.scmscm.db.DbInserter.RPT_LUR - insert err - Exception while inserting the rdr values [0, 3, 91, 300, 300, 1338138000, 0, 0, 0, 0, 0, 0, 0], for the rdr tag = 4042321925
java.lang.ArrayIndexOutOfBoundsException
2012-05-27 22:21:31,930 [wrkr/JDBCAdapter] ERROR com.cisco.scmscm.db.DbInserter.RPT_LUR - insert err (more details in next line), tag=4042321925, fieldNo-1=13 curSqlIndex=16, i=15
java.lang.ArrayIndexOutOfBoundsException

Share this post


Link to post
Share on other sites

Адаптер не может вставить данные из RDR в таблицу. Чтобы дальше не углубляться в диагностику/отладку, можно попробовать пересоздать таблицу RPT_LUR.

Попробуй пересоздать таблицу (дропни таблицу и перезапусти CM).

Share this post


Link to post
Share on other sites

exeyp

Сделал большее, грохнул СМ, грохнул базу и заново переинсталлил по мануалу с циски.

Может косяк в версии?

cm/logs/cm.log.2:2012-05-28 00:58:15,884 [main] INFO com.cisco.scmscm.Collector - Starting Cisco SCMS CM Version 3.7.5 Build 105

cm/logs/cm.log.2:2012-05-28 00:58:32,833 [main] INFO com.pcube.logger.userlog.UserLog - DC: EM Agent started. Version: Collection Manager 3.7.0 Build 43

 

Что за EM Agent started. Version: Collection Manager 3.7.0 Build 43.

У меня везде софт 3.7.5.

Share this post


Link to post
Share on other sites

Может откатиться на 3.7.2 ?

Downgrade нормально проходит на Cisco SCE?

Не хотелось бы поиметь проблем, циска в работе уже, абонов пропускает.

Share this post


Link to post
Share on other sites

Переконфигурировал CM на Оракл базу, проблема та же самая.

Таблица RPT_TR - заполняется и другие, а RPT_LUR - ошибка лезет в логах CM.

Share this post


Link to post
Share on other sites

У нас на SCE SCOS 3.7.2, а Collection Manager стоит Version 3.6.5 Build 301. Никаких проблем не возникает. Обновлять CM до версии 3.7.X смысла не увидел.

Share this post


Link to post
Share on other sites

Подскажите пожалуйсто такую вещь:

Есть жалобы от клиентов на некоторые программы, которые видимо сце определяет как п2п.

Решаю таким образом: добавляю определенные порты в bypass (через меню filtered traffic)

 

Трафик который идет в байпас учитывается на графиках сце? Просто график на сце явно отличается от графика на PRTG примерно на 30-50мбит.

Share this post


Link to post
Share on other sites

exeyp

Установил CM 3.7.2 версии, проблема решилась вроде.

RPT_LUR таблица по крайней мере заполняется, и ошибок в логах adapter-JDBC - нет.

Спс

Share this post


Link to post
Share on other sites

Приветствую,

 

Такая же проблема.

 

Похоже, баг... https://www.cisco.com/cisco/psn/bssprt/bss?keywords=CSCtz20343+&searchType=bstbugidsearch&page=bstBugDetail&BugID=CSCtz20343

 

Workaround:

The immediate workaround is provided in the Collection Manager (CSCtw75069 - CM need to support RDRs from different SCE versions). The CM will now use a default value of zero (= Ipv4) for the Ip type if it is not provided in the LUR. Please refer that bug for more specifics.

Attached cm.jar with the bug.

Installation steps:

1. Stop the CM server (~scmscm/cm/bin/cm stop)

2. Backup the ~scmscm/cm/bin/cm.jar file.

3. Copy the attached cm.jar file in the ~scmscm/cm/bin/ directory.

4. Restart the CM (~scmscm/cm/bin/cm start)

 

Только вот сам файл не нашел я на странице...

 

Если кому не трудно, кинте правильный cm.jar на fc_tpaktop(at)mail.ru

 

Спасибо!

Edited by EDA_SPB

Share this post


Link to post
Share on other sites
добавляю определенные порты в bypass (через меню filtered traffic)

Весь трафик который там указан циской тупо игнорируется, ЕМНИМС.

 

 

Такая же проблема.

Это на 3.7.5 или 3.7.5-P1?

Share this post


Link to post
Share on other sites

Release 3.7.5 New Features

This section describes the features introduced in this release:

  • IPV6 support:
    • Link Usage RDR (LUR)
    • Transaction RDR(TR)
    • HTTP TUR RDR
    • Video TUR RDR

    [*]Operating System Finger Printing Support (OSFP)

OSFP is supported for the Subscriber Usage RDR (NUR). New fields are added to RPT_NUR.

 

...

 

Release 3.7.5 Table Changes

List of tables changed for this release:

  • RPT_LUR
  • RPT_TR
  • RPT_USAGE_NF
  • RPT_TRANSACTION_NF
  • RPT_GLB_USAGE_NF

 

Похоже дело в IPv6 и может стоит обновить _весь_ софт? А то Вы нашли:

 

CM need to support RDRs from different SCE versions

Share this post


Link to post
Share on other sites

Весь софт 3.7.5

 

 

System version: Version 3.7.5-classic Build 412

Application name: Engage SML Version 3.7.5 build 31 (Protocol Pack 29 build 23)

Using Lib - PL_V3.7.5PP_B35

Using Lib - Classifier_V3.7.5_B35

 

Как-то странно что о проблеме в интернете пара упоминаний. Мысль у меня есть что я что-что делаю не так.

Edited by EDA_SPB

Share this post


Link to post
Share on other sites

Судя по всему у Вас используется "Per Link ...", верно?

Share this post


Link to post
Share on other sites

Извините, не понял, что значит "Per Link ..."?

Share this post


Link to post
Share on other sites

Macro пишет, что у него не заполняется таблица RPT_LUR.

Вы пишите, что у Вас та же проблема.

Вот я и хочу узнать, почему у Вас не записывается Link Usage RDR и делаю предположение что у Вас не "Aggregate GC", а "Per Link GC". Почему? Наверное потому что большинство использует Aggregate GC и поэтому так мало сообщений об ошибках. Хотя я, разумеется, могу заблуждаться.

Share this post


Link to post
Share on other sites

Я понял, посмотрю в эту сторону.

 

Спасибо за помощь.

 

UPD. Попробовал разные варианты, "Aggregate GC" и "Per Link GC".

Изменений нет, решение ищется.

Edited by EDA_SPB

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this