Jump to content
Калькуляторы

dhcp relay на cisco3550 траблы с ip unnumbered

добрый день!у меня схема такая

клиент->свич доступа->l3 relay(cisco3550)-> bras

 

на циске терминируются вланы и настроен dhcp relay, кроме того используется ip unnumbered, vlan-per-user.

 

проблема при доставке dhcp offer от браса до клиента. брас отсылает его успешно, а на циске он затыкается, почему то она не отдает его клиенту.

 

вот дебаг

 


3d01h: DHCPD: incoming interface name is Vlan3038
3d01h: DHCPD: bad circuit id length (6 bytes)
3d01h: DHCPD: Looking up binding using address 172.27.255.1
3d01h: DHCPD: Creating relay binding with address 172.27.255.1
3d01h: DHCPD: relay binding created for client 0100.0c42.4c74.f2.
3d01h: DHCPD: Received DHCPDISCOVER on UNNUM-IF
3d01h: DHCPD: setting giaddr to 172.27.255.1.
3d01h: DHCPD: BOOTREQUEST from 0100.0c42.4c74.f2 forwarded to 10.0.10.2.
3d01h: DHCPD: incoming interface name is Vlan199
3d01h: DHCPD: forwarding BOOTREPLY to client 000c.424c.74f2.
3d01h: DHCPD: bad circuit id length (6 bytes)
3d01h: DHCPD: Forwarding reply on un-numbered intf
3d01h: Overridden giaddr = 0
3d01h: DHCPD: validating relay information option.
3d01h: DHCPD: relay information is invalid; dropping BOOTREPLY message (2).
3d01h: DHCPD: incoming interface name is Vlan3038
3d01h: DHCPD: bad circuit id length (6 bytes)
3d01h: DHCPD: Looking up binding using address 172.27.255.1


вот конфиг

 


no aaa new-model
ip subnet-zero
ip routing
ip dhcp relay information option
ip dhcp relay information policy keep
ip dhcp relay information trust-all
!

ip dhcp snooping vlan 3038
ip dhcp snooping information option allow-untrusted
ip dhcp snooping

vtp mode transparent
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 1
!
vlan internal allocation policy ascending
!
vlan 100,150,199,1155,3038 
!
!
! 
!
!
!
interface Loopback1
ip address 172.27.255.1 255.255.0.0
no ip redirects
!

!
interface GigabitEthernet0/10
description manager
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,100,150,3038
switchport mode trunk
!
interface GigabitEthernet0/11
description bras1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,150,199
switchport mode trunk
!
interface GigabitEthernet0/12
description client
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,115,3038
switchport mode trunk
!
interface Vlan1
ip address 172.20.1.221 255.255.255.0
!
interface Vlan199
ip address 10.0.10.1 255.255.255.252
!
interface Vlan3038
description ipoe1
ip dhcp relay information trusted
ip unnumbered Loopback1
ip helper-address 10.0.10.2
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.10.2
no ip http server
no ip http secure-server
!

 

 

в дебаге циска ругается на длину circuit-id. возможно из-за того, что у меня одновременно включен и снупинг и релей. но если я оставляю только релей, то на радиус сервер в итоге приходит пустой circuit-id. вот тут это обсуждается кстати.

если я вставляю option 82 на доступе, а на циске оставляю только релей, то дебаг почти такой же, тоже ругается на длину circuit-id.

 

 

вопрос как заставить каталист не дропать пришедший dhcp offer и доставлять его до клиента.

 

кстати если не юзать unnumbered, все работает.

Share this post


Link to post
Share on other sites

победил.

вот так работает.

 

 

ip dhcp relay information option

no ip dhcp relay information check

ip dhcp relay information trust-all

!

ip dhcp snooping vlan 3038

ip dhcp snooping information option allow-untrusted

ip dhcp snooping

 

 

 

пока правда клиент не пынгается с браса, но это уже другая история.

Share this post


Link to post
Share on other sites

А во т если бы сначала прочитали доку , а потом взялись бы за настройку , то не пришлось бы побеждать ! :-)))

Edited by config

Share this post


Link to post
Share on other sites

а если еще немного покрутить, то начнет и пинговаться :))

Следующее, чего вы захотите - выдачу адресов из пула :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this