Перейти к содержимому
Калькуляторы

as5350 и поток E1 as5350 не проходят входящие вызовы из E1

Уважаемые господа! Помогите настроить связку e1-as5350-asterisk, проблема в следующем:

исходящие звонки из астериска уходят в е1 без проблем, но входящие.... понимаю что проблема в написании dial-peer'ов и translation-rule.

три дня голову ломаю, все не как.

формат аона 495ХХХХХХХ

 

мой конфиг (сильно не ругайте)

 

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname m9-2

!

no boot startup-test

enable secret 5 $1$iWS9$AQ9ebdhGVhiBtFdOE1.NO/

 

!

resource-pool disable

spe default-firmware spe-firmware-1

aaa new-model

!

!

aaa authentication login default group tacacs+ local enable

aaa authentication login CONSOLE none

aaa authentication ppp default if-needed group tacacs+

aaa session-id common

ip subnet-zero

ip cef

!

isdn switch-type primary-net5

!

voice call send-alert

no voice call carrier capacity active

!

voice service voip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw

sip

!

voice class codec 2

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 g729r8

codec preference 5 g723r53

codec preference 6 g723ar53

codec preference 7 g723r63

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

!

!

controller E1 3/0

framing NO-CRC4

pri-group timeslots 1-31

description Beeline

!

controller E1 3/1

!

!

interface FastEthernet0/0

ip address XXX.XXX.22.88 255.255.255.0

ip access-group stopvoip1 in

duplex full

speed 100

!

interface FastEthernet0/1

description ipass(m9-cat-2:fa11,18,30)-255

ip address XXX.XX.241.140 255.255.255.248

ip access-group stopvoip1 in

duplex full

speed 100

!

interface Serial0/0

no ip address

shutdown

clockrate 2000000

!

interface Serial0/1

no ip address

shutdown

clockrate 2000000

!

interface Serial3/0:15

no ip address

isdn switch-type primary-net5

isdn overlap-receiving

isdn network-failure-cause 17

isdn incoming-voice modem

isdn map address . plan isdn type subscriber

isdn send-alerting

isdn negotiate-bchan

isdn sending-complete

no cdp enable

!

interface Async1/00

no ip address

!

interface Async1/01

no ip address

!

interface Async1/02

no ip address

!

interface Async1/03

no ip address

!

interface Async1/04

no ip address

!

interface Async1/05

no ip address

!

interface Async1/06

no ip address

!

interface Async1/07

no ip address

!

interface Async1/08

no ip address

!

interface Async1/09

no ip address

!

interface Async1/10

no ip address

!

interface Async1/11

no ip address

!

interface Async1/12

no ip address

!

interface Async1/13

no ip address

!

interface Async1/14

no ip address

!

interface Async1/15

no ip address

!

interface Async1/16

no ip address

!

interface Async1/17

no ip address

!

interface Async1/18

no ip address

!

interface Async1/19

no ip address

!

interface Async1/20

no ip address

!

interface Async1/21

no ip address

!

interface Async1/22

no ip address

!

interface Async1/23

no ip address

!

interface Async1/24

no ip address

!

interface Async1/25

no ip address

!

interface Async1/26

no ip address

!

interface Async1/27

no ip address

!

interface Async1/28

no ip address

!

interface Async1/29

no ip address

!

interface Async1/30

no ip address

!

interface Async1/31

no ip address

!

interface Async1/32

no ip address

!

interface Async1/33

no ip address

!

interface Async1/34

no ip address

!

interface Async1/35

no ip address

!

interface Async1/36

no ip address

!

interface Async1/37

no ip address

!

interface Async1/38

no ip address

!

interface Async1/39

no ip address

!

interface Async1/40

no ip address

!

interface Async1/41

no ip address

!

interface Async1/42

no ip address

!

interface Async1/43

no ip address

!

interface Async1/44

no ip address

!

interface Async1/45

no ip address

!

interface Async1/46

no ip address

!

interface Async1/47

no ip address

!

interface Async1/48

no ip address

!

interface Async1/49

no ip address

!

interface Async1/50

no ip address

!

interface Async1/51

no ip address

!

interface Async1/52

no ip address

!

interface Async1/53

no ip address

!

interface Async1/54

no ip address

!

interface Async1/55

no ip address

!

interface Async1/56

no ip address

!

interface Async1/57

no ip address

!

interface Async1/58

no ip address

!

interface Async1/59

no ip address

!

interface Group-Async0

no ip address

no group-range

!

ip classless

ip route 0.0.0.0 0.0.0.0 XXX.XXX.22.254 250

no ip http server

!

!

 

 

access-list 99 permit XXX.XXX.23.0 0.0.0.255

access-list 99 permit XXX.XXX.254.0 0.0.0.255

access-list 99 deny any

!

tacacs-server host XXX.XXX.23.4

tacacs-server directed-request

tacacs-server key 7 DBDB7KNNCVB897676VV

 

!

radius-server authorization permit missing Service-Type

!

voice-port 3/0:D

disc_pi_off

echo-cancel coverage 32

no non-linear

no vad

no comfort-noise

cptone RU

timeouts call-disconnect 3

bearer-cap Speech

!

!

!

dial-peer voice 156 pots

!

dial-peer voice 1 pots

description Trunk_2_POTS

destination-pattern T

progress_ind alert enable 8

progress_ind progress enable 8

direct-inward-dial

port 3/0:D

!

dial-peer voice 3 voip

description Default_VoIP_peer

incoming called-number .T

voice-class codec 2

session protocol sipv2

session transport udp

dtmf-relay rtp-nte

fax protocol none

no vad

!

dial-peer voice 5 voip

description 495 728

incoming called-number .T

voice-class codec 2

session protocol sipv2

session target ipv4:XXX.XXX.23.214

session transport udp

dtmf-relay rtp-nte

fax protocol none

!

dial-peer voice 7 pots

description test

huntstop

preference 10

incoming called-number .T

direct-inward-dial

no register e164

!

!

!

line con 0

password 7 CHJHGFTREFGL

line aux 0

line vty 0 4

access-class 99 in

exec-timeout 40 0

line 1/00 1/59

no flush-at-activation

modem InOut

!

scheduler allocate 10000 400

!

end

 

 

debug isdn q931

 

*May 3 17:41:17.583: ISDN Se3/0:15 Q931: RX <- SETUP pd = 8 callref = 0x01C9

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA18391

Preferred, Channel 17

Calling Party Number i = 0x2183, '9655291119'

Plan:ISDN, Type:National

Called Party Number i = 0xA1, '4957284005'

Plan:ISDN, Type:National

*May 3 17:41:17.587: ISDN Se3/0:15 Q931: isdn_parser_map_lkup: overriding plan/type for 9651291109, isdn/national to isdn/subscriber

*May 3 17:41:17.587: ISDN Se3/0:15 Q931: isdn_parser_map_lkup: overriding plan/type for 4957284005, isdn/national to isdn/subscriber

*May 3 17:41:17.587: ISDN Se3/0:15 Q931: isdn_parser_map_lkup: overriding plan/type for 9651291109, isdn/national to isdn/subscriber

*May 3 17:41:17.587: ISDN Se3/0:15 Q931: isdn_parser_map_lkup: overriding plan/type for 4957284005, isdn/national to isdn/subscriber

*May 3 17:41:17.591: ISDN Se3/0:15 Q931: TX -> SETUP pd = 8 callref = 0x0010

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA1839F

Preferred, Channel 31

Calling Party Number i = 0x4183, '9655291119'

Plan:ISDN, Type:Subscriber(local)

Called Party Number i = 0xC1, '4957284005'

Plan:ISDN, Type:Subscriber(local)

*May 3 17:41:17.591: ISDN Se3/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x81C9

Channel ID i = 0xA18391

Preferred, Channel 17

*May 3 17:41:17.639: ISDN Se3/0:15 Q931: RX <- CALL_PROC pd = 8 callref = 0x8010

Channel ID i = 0xA9839F

Exclusive, Channel 31

*May 3 17:41:17.723: ISDN Se3/0:15 Q931: RX <- SETUP pd = 8 callref = 0x01CB

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA18392

Preferred, Channel 18

Calling Party Number i = 0x2180, '9655291119'

Plan:ISDN, Type:National

Called Party Number i = 0xA1, '4957284005'

Plan:ISDN, Type:National

 

 

 

debug voice translation

 

*May 3 17:44:22.099: regxrule_get_profile_from_trunkgroup: Voice port 0x63D4D600 does not belong to any trunk group

*May 3 17:44:22.099: regxrule_get_profile_from_trunkgroup: Voice port 0x63D4D600 does not belong to any trunk group

*May 3 17:44:22.099: regxrule_stack_pop_RegXruleNumInfo: stack=0x642E01F0; count=1

*May 3 17:44:22.103: regxrule_stack_push_RegXruleNumInfo: stack=0x642E01F0; count=0

*May 3 17:44:22.103: regxrule_profile_translate: Error: invalid input; callinfo=0x642F1490 profilep=0x0 rtype=calling

*May 3 17:44:22.103: regxrule_profile_translate: Error: invalid input; callinfo=0x642F1490 profilep=0x0 rtype=redirect-called

*May 3 17:44:22.103: regxrule_profile_translate: Error: invalid input; callinfo=0x642F1490 profilep=0x0 rtype=called

*May 3 17:44:22.103: regxrule_stack_push_RegXruleNumInfo: stack=0x642E01F0; count=1

*May 3 17:44:22.103: regxrule_dp_translate: No profile found in peer 1 for outgoing direction

*May 3 17:44:22.103: regxrule_dp_translate: calling_number=9655291119 calling_octet=0x21

called_number=4957284005 called_octet=0xA1

redirect_number= redirect_type=4294967295 redirect_plan=4294967295

*May 3 17:44:22.103: regxrule_vp_translate: No profile found in voice port or trunk group for outgoing direction

*May 3 17:44:22.103: regxrule_vp_translate: calling_number=9655291119 calling_octet=0x21

called_number=4957284005 called_octet=0xA1

redirect_number= redirect_type=4294967295 redirect_plan=4294967295

*May 3 17:44:22.219: regxrule_get_profile_from_trunkgroup: Voice port 0x63D4D600 does not belong to any trunk group

*May 3 17:44:22.219: regxrule_get_profile_from_trunkgroup: Voice port 0x63D4D600 does not belong to any trunk group

*May 3 17:44:22.219: regxrule_stack_pop_RegXruleNumInfo: stack=0x64281080; count=1

*May 3 17:44:22.219: regxrule_stack_push_RegXruleNumInfo: stack=0x64281080; count=0

*May 3 17:44:22.219: regxrule_profile_translate: Error: invalid input; callinfo=0x642E6D3C profilep=0x0 rtype=calling

*May 3 17:44:22.223: regxrule_profile_translate: Error: invalid input; callinfo=0x642E6D3C profilep=0x0 rtype=redirect-called

*May 3 17:44:22.223: regxrule_profile_translate: Error: invalid input; callinfo=0x642E6D3C profilep=0x0 rtype=called

*May 3 17:44:22.223: regxrule_stack_push_RegXruleNumInfo: stack=0x64281080; count=1

*May 3 17:44:22.223: regxrule_dp_translate: No profile found in peer 1 for outgoing direction

*May 3 17:44:22.223: regxrule_dp_translate: calling_number=9655291119 calling_octet=0x21

called_number=4957284005 called_octet=0xA1

redirect_number= redirect_type=4294967295 redirect_plan=4294967295

*May 3 17:44:22.223: regxrule_vp_translate: No profile found in voice port or trunk group for outgoing direction

*May 3 17:44:22.223: regxrule_vp_translate: calling_number=9655291119 calling_octet=0x21

called_number=4957284005 called_octet=0xA1

redirect_number= redirect_type=4294967295 redirect_plan=4294967295

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

а зачем трансляция? Нет воип диалпира с destination-pattern

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

а зачем трансляция? Нет воип диалпира с destination-pattern

СПАСИБО ОГРОМНОЕ!!!

все, вызовы пошли в обе стороны.

есть правда одна БЕДА, нет кпв при звонке со стороны е1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

google:cisco+КПВ

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Большое СПАСИБО кпв заработал, в воиповский диалпир нужно было добавить tone ringback alert-no-PI

Изменено пользователем alupianets

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас