Jump to content
Калькуляторы

Обновление прошивки устройства SNR-ERD-2.3 обновления, фиксы, баги, обсуждения хотелок.

Добрый день !

Как создать bat файл на windows с отправкой команды erd на перезагрузку ?

 

для любой ERD, которая поддерживает перепрошивку - под винду и под *nix:

 

echo X | nc -p 3000 -w 2 -u 192.168.15.20 1200

 

netcat под винду собрать или скачать готовый.

Edited by vim

Share this post


Link to post
Share on other sites

У меня такой вопрос к разработчикам сего девайса SNR-ERD-2.3, а не могли бы вы в замен функции (ресет) на контактах №5,6 сделать как на контактах №5,8 или дать прошивку может у вас есть такая.

Share this post


Link to post
Share on other sites

У меня такой вопрос к разработчикам сего девайса SNR-ERD-2.3, а не могли бы вы в замен функции (ресет) на контактах №5,6 сделать как на контактах №5,8 или дать прошивку может у вас есть такая.

Можем предложить вам изготовление кастомной прошивки на платной основе (либо бесплатно при условии контрактного приобретения определенного количества устройств)

 

Однако такой функционал есть "из коробки" в устройствах SNR-ERD-PRO-Mini и SNR-ERD-4S

Share this post


Link to post
Share on other sites

У меня такой вопрос к разработчикам сего девайса SNR-ERD-2.3, а не могли бы вы в замен функции (ресет) на контактах №5,6 сделать как на контактах №5,8 или дать прошивку может у вас есть такая.

Можем предложить вам изготовление кастомной прошивки на платной основе (либо бесплатно при условии контрактного приобретения определенного количества устройств)

 

Однако такой функционал есть "из коробки" в устройствах SNR-ERD-PRO-Mini и SNR-ERD-4S

Так я и так приобрел у вас 4 устройства SNR-ERD 2.3 и два устройства SNR-ERD-GSM.

Share this post


Link to post
Share on other sites

У меня такой вопрос к разработчикам сего девайса SNR-ERD-2.3, а не могли бы вы в замен функции (ресет) на контактах №5,6 сделать как на контактах №5,8 или дать прошивку может у вас есть такая.

Можем предложить вам изготовление кастомной прошивки на платной основе (либо бесплатно при условии контрактного приобретения определенного количества устройств)

 

Однако такой функционал есть "из коробки" в устройствах SNR-ERD-PRO-Mini и SNR-ERD-4S

Так я и так приобрел у вас 4 устройства SNR-ERD 2.3 и два устройства SNR-ERD-GSM.

Тем не менее кастомные прошивки предлагаем на платной основе

Share this post


Link to post
Share on other sites

Привет.

 

Приобрели 4 устройства SNR-ERD-2.3-termo-out.

обновили на всех прошивку до 6.7

Но какой то странный баг, не один из дачиков не работает через коммутатор.

Если подключаю напрямую к ПК, датчик доступен и работает.

Подключаю к cisco 2960, конфиг порта:

interface GigabitEthernet0/18
description 53
switchport access vlan 3
switchport mode access
spanning-tree portfast
end

порт корректно согласуется в a-half a-10

Но мак не появляется.

Либо может появиться, и устройство даже может ответить на пару icmp,

а потом перестает отвечать. По snmp так же недоступно.

 

В итоге просто не можем использовать датчики для снятия температуры.

Share this post


Link to post
Share on other sites

Привет.

 

Приобрели 4 устройства SNR-ERD-2.3-termo-out.

обновили на всех прошивку до 6.7

Но какой то странный баг, не один из дачиков не работает через коммутатор.

Если подключаю напрямую к ПК, датчик доступен и работает.

Подключаю к cisco 2960, конфиг порта:

interface GigabitEthernet0/18
description 53
switchport access vlan 3
switchport mode access
spanning-tree portfast
end

порт корректно согласуется в a-half a-10

Но мак не появляется.

Либо может появиться, и устройство даже может ответить на пару icmp,

а потом перестает отвечать. По snmp так же недоступно.

 

В итоге просто не можем использовать датчики для снятия температуры.

Добрый день!

 

Попробуйте выставить настройки на порту вручную 10/half

Share this post


Link to post
Share on other sites

Попробуйте выставить настройки на порту вручную 10/half

Это первое, что я пробовал, не помогло. Симптомы такие же.

Пробовал подключать к другому свичу (snr-2990T), cимптомы такие же.

Пробовал использовать прямой и кроссовер кабель(вдруг MDI-X как то не отрабатывал).

В общем ничего не решило проблему.

Share this post


Link to post
Share on other sites

Попробуйте выставить настройки на порту вручную 10/half

Это первое, что я пробовал, не помогло. Симптомы такие же.

Пробовал подключать к другому свичу (snr-2990T), cимптомы такие же.

Пробовал использовать прямой и кроссовер кабель(вдруг MDI-X как то не отрабатывал).

В общем ничего не решило проблему.

значит проблема в большом количестве широковещательных пакетов в сети с устройством

рекомендуем вам выделить его в отдельный vlan

Share this post


Link to post
Share on other sites

рекомендуем вам выделить его в отдельный vlan

Действительно, утилизация порта была 100%

Спасибо за подсказку.

Share this post


Link to post
Share on other sites

добрый день

а можно в устройстве в режиме термостата заложить хоть какой-то гистерезис? нагрузка включается-выключается по несколько раз в минуту, когда температура стоит в пограничном значении например в районе 17-18 градусов?

судя по всему датчик там ds18b20, у которого точность выше чем градус

пусть в интерфейсе будут отображатся целые градусы, но софт изменение состояния нагрузки будет не на ровно а на половинках, например на 17.5 вкл на 18.5 выкл гистерезиса в градус будет достаточно

Share this post


Link to post
Share on other sites

Купили несколько erd 2.3 и к ним управляемые розетки. В описании и инструкции написано, что ресет 3 секунды, на деле это 0,5 (тупо щёлкает реле в розетке). Оборудование даже не успевает понять, что 220 пропало. Так же написано, что устройство делает замер наличия питания. Подключаем в порт мониторинга и нифига ни по snmp, ни в web этой информации нет. Пробуем подключить на контакты по замеру напряжения (хотя бы так думаем мерить) - результат либо 0, либо значения постоянно плавают, но чаще просто 0. Прошивки и танцы с бубном не помогают. Все эти проблемы тоже "кастомной платной прошивкой" решаются?

Share this post


Link to post
Share on other sites

ERD-3S Fmv_1.6

Считываю показание температурного сенсора, отдаёт как положено:

# snmpget -c public -v1 -On 10.1.3.126 .1.3.6.1.4.1.40418.2.4.4.2.2.0
.1.3.6.1.4.1.40418.2.4.4.2.2.0 = INTEGER: -12                               

Вставляю сточку OID в PRTG как кастомный сенсор, он его читает как положено:

59dcd6fa15a2c_2017-10-10191902.thumb.png.6c0e6b8df513d5eb260dfa39a5236a88.png

Добавляю сенсор, начинает показывать какую-то дребедень:

59dcd78a33474_2017-10-10192150.thumb.png.341021eae3ffa294b7e9b8535d5ed320.png

 

Share this post


Link to post
Share on other sites
В 10.10.2017 в 17:22, ThreeDHead сказал:

ERD-3S Fmv_1.6

Считываю показание температурного сенсора, отдаёт как положено:


# snmpget -c public -v1 -On 10.1.3.126 .1.3.6.1.4.1.40418.2.4.4.2.2.0
.1.3.6.1.4.1.40418.2.4.4.2.2.0 = INTEGER: -12                               

Вставляю сточку OID в PRTG как кастомный сенсор, он его читает как положено:

59dcd6fa15a2c_2017-10-10191902.thumb.png.6c0e6b8df513d5eb260dfa39a5236a88.png

Добавляю сенсор, начинает показывать какую-то дребедень:

59dcd78a33474_2017-10-10192150.thumb.png.341021eae3ffa294b7e9b8535d5ed320.png

 

У вас не верно указан тип данных. Попробуйте float или custom

Share this post


Link to post
Share on other sites
13 часов назад, d.brusentsev сказал:

У вас не верно указан тип данных. Попробуйте float или custom

Я перепробовал все варианты. Custom - нет такого.

Share this post


Link to post
Share on other sites
On 6/30/2015 at 10:08 AM, Victor Pestov said:

планируется выпустить приложение под линуксы, но есть некоторые вопросы.

Прошло почти три года, где собственно флешер под линукс?

Share this post


Link to post
Share on other sites
В 14.02.2018 в 00:05, LynxChaus сказал:

Прошло почти три года, где собственно флешер под линукс?

 

 

Edited by Victor Pestov

Share this post


Link to post
Share on other sites

Добрый день. Устройство сейчас не поддерживает протокол DHCP. Можно ли расчитывать на его реализацию в прошивке?

Share this post


Link to post
Share on other sites
14 часов назад, Gorbushka сказал:

Добрый день. Устройство сейчас не поддерживает протокол DHCP. Можно ли расчитывать на его реализацию в прошивке?

Добрый день! Нет возможности поддержать DHCP в этой версии устройства. В ERD-4 реализована поддержка

Share this post


Link to post
Share on other sites

Хочу измерять напряжение с помощью встроенного датчика измерения напряжения. Подключаю источник питания 12В к контактам 1 и 10 в соответствии с документом Мультиметром подтверждаю, что там 12В. Однако, датчик упорно показывает 6.3-6.4В. Что я делаю не так?

Share this post


Link to post
Share on other sites
В 06.08.2018 в 18:14, Gorbushka сказал:

Хочу измерять напряжение с помощью встроенного датчика измерения напряжения. Подключаю источник питания 12В к контактам 1 и 10 в соответствии с документом Мультиметром подтверждаю, что там 12В. Однако, датчик упорно показывает 6.3-6.4В. Что я делаю не так?

Странно, всё должно работать, скорее всего аппаратная неисправность.

Share this post


Link to post
Share on other sites

да, второй контроллер из партии показывает напряжение нормально.

Share this post


Link to post
Share on other sites

А можно получить схему устройства? Хочу перепрошить на Arduino и добавить поддержку mqtt

Share this post


Link to post
Share on other sites
В 24.10.2018 в 23:25, Aven сказал:

А можно получить схему устройства? Хочу перепрошить на Arduino и добавить поддержку mqtt

Пока mqtt есть только в ERD-4

Share this post


Link to post
Share on other sites

Сомневаюсь, что НАГ будет писать прошивку с mqtt под 2.3, последняя прощивка 3,5 года назад... там внутри обычная atmega328, сделать прошивку с mqtt не так сложно, просто не хочется тратить время на разбор какие входы к каким пинам подключены...

Edited by Aven

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now