Jump to content
Калькуляторы

ip unnumberd на Mikrotik

Сломал всю башку. КАК настроить аналог цисковского ip unnumbered на этой шайтан борде?!? Желательно через winbox.

 

Создал виланы на клиентском интерфейсе. Задал для них proxy-arp.

Написал роуты для ip клиентов с маской /32, смотрящие в свои виланы.

 

Теперь, КАК создать интерфейс типа loopback, что-бы привязать к нему "адрес шлюза", что указан у клиентов?

Делал bridge без портов в нем и прописывал на него. Работает 1 мин и потом перестает.

 

ЧЯДНТ?

Share this post


Link to post
Share on other sites

Что люди не сделают, чтобы не тратить денги. Купите б/у циску 3750 или навроде, так это аппаратно реализовано, все софтверные решения будут сильно уступать в производительности. ну а по теме есть мануал от микротика: http://wiki.mikrotik.com/wiki/Manual:Interface/VLAN#RouterOS_.2F32_and_IP_unnumbered_addresses

Share this post


Link to post
Share on other sites

Создайте бридж и добавьте в него все клиентские вланы. На бридж повесьте ваш адрес шлюза, при этом proxy-ARP будет не нужен. Чтобы трафик между клиентами в бридже не ходил установите фильтрацию на нем, в разделе Bridge --+ Filters добавьте правило, где In Bridge и Out Bridge ваш бридж - действие Drop.

 

 

Share this post


Link to post
Share on other sites

breusovok - Чего только не сделают люди, что-бы сумничать и не ответить на заданный вопрос. Сей микротик будет стоять на мачте, где есть только питание 24 вольта.КУДА мне там засунуть циску? По теме: вы сами предложенный мануал читали?

 

Сааб - А честный unnumbered не умеет, да ? Мне надо как раз, что-бы между кастомерами БЫЛ трафик. Мне надо, что-бы они свои адреса не смогли менять.

Share this post


Link to post
Share on other sites

Сааб - А честный unnumbered не умеет, да ? Мне надо как раз, что-бы между кастомерами БЫЛ трафик. Мне надо, что-бы они свои адреса не смогли менять.

 

Фильтрация на бридже нужна для того, чтобы исключить широковешательный трафик и всякого рода мусор. В этом случае каждый клиент может обмениваться данными только с сервером, или только через сервер. С маской /32 все клиенты так и так будут обмениваться данными через сервер - следовательно все будет исправно работать.

 

Что бы они не могли адреса менять - нужно отключить ARP на клиентских вланах. Если для выдачи IP-адресов используется встроенный DHCP сервер микротика - можно его заставить создавать статические ARP записи. Если адреса выдаются сторонним силами - нужно вручную добавлять статические ARP записи.

Share this post


Link to post
Share on other sites

Да, и запретить им таким образом менять сетевые карты/компьютеры, приносить ноутбуки, ставить и заменять роутеры. Нет уж.

 

Еще раз: Нужен аналог технологии ip unnumbered от циски. На линуксе делается на Раз-Два-Три. Неужели микротик так неумеет? Это-же тот-же линукс! Как так? Или задача Уже: надо сделать loopback интерфейс на микротике.

Share this post


Link to post
Share on other sites

поищите "ip unnumbered" на оффициальном англоязычном форуме forum.mikrotik.com

 

Судя по всему - тухляк - "честный ip unnumbered" не умеет и не должен уметь... : )

 

У Вас беспроводная точка доступа?

Но дальше же как-то трафик идет? Оптика? Витуха? Или беспрводный мост, но в итоге приходит в место, где есть питание, где-то же есть биллинг? серверы? Стык с аплинками?

Как-то ж можно юзеров прокинуть прозрачно до "аппаратной" а там поставить свич, который умеет ip unnumbered.

Так не получится?

Может тогда "ну его" ?

Обойтись другими решениями....?

Как-то миллиарды человек обходятся без ip unnumbered : )

Share this post


Link to post
Share on other sites

честный ip unnumbered умеет любой линукс. А в основе микротика - хорошо замаскированный линукс. Должен уметь! Не верю (це)!

 

Решение нужно узко специфичное. Обходными путями не выйдет. Просто пропадает _смысл_ мероприятия. Объяснять долго.

Share this post


Link to post
Share on other sites

Вам Saab95 объяснил как сделать то что вы хотите. Честного как в линуксе не получится. И вообще не проще ли сделать Влан на абонента ?? намного приятнее будет работать. Ато с аннамбередом пролезет пару пакетиков через фильтр бриджа (да, у микротика такое может случится), появится бродкаст шторм и повесит его на вашей мачте...

Поэтому всеже лучше юзать решения которые описаны в доках и официально работают.

Share this post


Link to post
Share on other sites

Блин, сколько-ж умных людей на свете. Вот только топик никто не читает. Или читают выборочно.

 

По теме: Странно, что микротик не умеет такую простую штуку. Всем спасибо, тема закрыта. Будем ставить мамку с атомом и линуксом.

Share this post


Link to post
Share on other sites

Блин, сколько-ж умных людей на свете. Вот только топик никто не читает. Или читают выборочно.

 

По теме: Странно, что микротик не умеет такую простую штуку. Всем спасибо, тема закрыта. Будем ставить мамку с атомом и линуксом.

Тогда уж проще cisco 3550-24 туда запихнуть, размер и потребление будет не больше чем у кучки железа атомовской..

Share this post


Link to post
Share on other sites

О какой "кучке железа" идет речь, если надо только конвертор питания и саму мамку с атомом, потреблением в 10 ватт в большой праздник? И размером 20х20 см. Все можно засунуть в гермобокс и оставить прямо на мачте.

Share this post


Link to post
Share on other sites

Доброго времени суток! С создания темы много воды утекло, куча прошивок на микротик вышло, появилась ли сейчас возможность сделать что-то подобное как описано про циску и ip unnumbered в этой маленькой статейке http://www.opennet.ru/base/cisco/catalyst_ip_unnumber.txt.html ?

Попытки сделать данное я предпринимал, создавал бридж, создавал несколько вланов добавляя их в бридж и соответственно на бридже указывал адрес. Даже находясь во влане я видел адрес бриджа и всё за этим роутером, но при прописывании маршрута типа ip route add "ip адрес клиента" 255.255.255.255 vlan "влан", пинги до клиента тут же пропадали и разрывалась связь по непонятной причине. Вот что ещё можно сделать, чтоб юзеры ip не могли менять..

Share this post


Link to post
Share on other sites

Блин, сколько-ж умных людей на свете. Вот только топик никто не читает. Или читают выборочно.

У умных уже стойкий блевотный рефлекс к слову микротик в топике в сочетании с появлением сааба.

Share this post


Link to post
Share on other sites

Некропостинг... Ну да ладно.

 

АлексейNS - А хрен его знает. Я не пробовал с тех пор. Там трудится Атом и фсе довольны. На линуксе всё это делается без проблем.

 

 

 

myst - Это да. Сложно с саабом, если не понимать, что его интересует не вопрос, обсуждаемый в теме, а индекс цитирования и прочие CEO плюшки в поисковых системах. С ним проще всего пользоваться его-же татктикой демагога. Он просто не замечает неудобные вопросы. Вот и его в топике замечать не надо.

 

http://lurkmore.to/%D0%9F%D1%80%D0%B0%D0%B2%D0%B8%D0%BB%D0%B0_%D0%B4%D0%B5%D0%BC%D0%B0%D0%B3%D0%BE%D0%B3%D0%B0

Edited by sol

Share this post


Link to post
Share on other sites

myst - Это да. Сложно с саабом, если не понимать, что его интересует не вопрос, обсуждаемый в теме, а индекс цитирования и прочие CEO плюшки в поисковых системах. С ним проще всего пользоваться его-же татктикой демагога. Он просто не замечает неудобные вопросы. Вот и его в топике замечать не надо.

Да это понятно, меня просто забавляют такие клинические случаи. :)

Share this post


Link to post
Share on other sites

на микрике делается без проблем полный аналог цисковского аннамберед, работал такой финт както у меня, нужно поискать конфиги..

Share this post


Link to post
Share on other sites
Да это понятно, меня просто забавляют такие клинические случаи. :)
Ну, да. Настырный.

 

на микрике делается без проблем полный аналог цисковского аннамберед, работал такой финт както у меня, нужно поискать конфиги..
Аналог в студию! Если почитать топик с начала, то там будет написано, что именно не получается на микротике.

Share this post


Link to post
Share on other sites

2 sol - я умею читать топики с начала ) Но в тот момент мне нужен был аналог цисковского аннамбереда, и я от безвыходности придумал как его реализовать на микротике.

Share this post


Link to post
Share on other sites

Простите что без подробных объяснений. На примере сразу

1.1.1.1 - адрес шлюза

1.1.1.2 -адрес клиента 1

1.1.1.3 -адрес клиента 2

 

/interface vlan

add arp=proxy-arp disabled=no interface=ether1 l2mtu=9010 mtu=1500 name=Client1 use-service-tag=no vlan-id=100

add arp=proxy-arp disabled=no interface=ether1 l2mtu=9010 mtu=1500 name=Client2 use-service-tag=no vlan-id=101

/ip address

add address=1.1.1.1/32 disabled=no interface=Client1 network=1.1.1.2

add address=1.1.1.1/32 disabled=no interface=Client2 network=1.1.1.3

Маска на клиенте соответсвует реальной маске подсети. Если не хотите, что-бы клиенты могли передавать данные на другие адреса в этой подсети - не включайте proxy-arp.

Edited by f0x

Share this post


Link to post
Share on other sites

Простите что без подробных объяснений. На примере сразу

1.1.1.1 - адрес шлюза

1.1.1.2 -адрес клиента 1

1.1.1.3 -адрес клиента 2

 

/interface vlan

add arp=proxy-arp disabled=no interface=ether1 l2mtu=9010 mtu=1500 name=Client use-service-tag=no vlan-id=100

/ip address

add address=1.1.1.1/32 disabled=no interface=Client1 network=1.1.1.2

add address=1.1.1.1/32 disabled=no interface=Client2 network=1.1.1.3

Маска на клиенте соответсвует реальной маске подсети. Если не хотите, что-бы клиенты могли передавать данные на другие адреса в этой подсети - не включайте proxy-arp.

 

Network то зачем указывать? Когда можно просто маршрут прописать на этот адрес по указанному интерфейсу?

Share this post


Link to post
Share on other sites

Так просто короче. Эффект ровно тот же, проверьте сами.

Share this post


Link to post
Share on other sites

2 f0x - в таком случае клиент будет видеть всех абонов в своем Влане и пойдет через центр, а если влан на дом или свич или на абона - он не увидит ничего кроме щлюза

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this