Jump to content
Калькуляторы

Помогите разобраться с QinQ

Здравствуйте, уважаемые форумчане!

Изучаю схему vlan-per-user. Железо - в ядре cisco 7206VXR, на агрегации D-link DGS 3627G, на доступе D-link DES 3028. Собрали пробную схему cisco-dlink3627g-dlink3028. Хочется реализовать port-based qinq на агрегации, чтобы в ядро уходили кадры под единым vlan. Ниже привожу конфиг, помогите пожалуйста разобраться в чем проблема...я полагаю, что при входе в uni порт, все должно упаковываться в pvid uni порта, каждый клиент должен получить ip по dhcp, ан нет, что-то не так...

 

Cisco 7206VXR:

ip dhcp excluded-address 172.22.196.1 172.22.196.9

ip dhcp pool TEST-QinQ

utilization mark high 85 log

network 172.22.196.0 255.255.252.0

default-router 172.22.196.1

!

interface GigabitEthernet0/1

no ip address

no ip unreachables

no ip proxy-arp

duplex auto

speed 1000

media-type rj45

negotiation auto

vlan-id dot1q 349

pppoe enable group PPPoE

exit-vlan-config

!

no cdp enable

no mop enabled

!

interface GigabitEthernet0/1.349

description test-QinQ

encapsulation dot1Q 349 second-dot1q any

ip address 172.22.196.1 255.255.252.0

no ip redirects

no ip unreachables

no ip proxy-arp

no ip mroute-cache

no snmp trap link-status

no cdp enable

arp authorized

 

DGS 3627G:

 

config vlan default delete 1-27

create vlan qinq tag 349

config vlan qinq add tagged 21-22 (21-ушел в cisco, 22 - des 3028)

 

enable qinq

config qinq ports 21 role nni missdrop disable outer_tpid 0x8100

config qinq ports 22 role uni missdrop disable outer_tpid 0x8100

 

DES3028:

 

Созданы пользовательские vlan, уходят унтегом на пользователей и тегом на аггрегацию.

Edited by proshift

Share this post


Link to post
Share on other sites

create vlan_translation ports <ports> cvid <cvid> add svid <svid>

 

?

Share this post


Link to post
Share on other sites

create vlan_translation ports <ports> cvid <cvid> add svid <svid>

 

?

Думал, что буду использовать create vlan_translation ports <ports> cvid <cvid> replace svid <svid>, для того чтобы vlan ушел в том виде котором необходимо мне, а все остальное должно метиться автоматом

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this