Jump to content
Калькуляторы

Примеры настроек коммутаторов SNR

14 часов назад, VecH сказал:

prolan Ничего умнее посоветовать не мог?

В линуксе я и так смог бы прокинуть, здесь не получается, все пакеты в оптику летят с 1 тегом

Документацию читать не пробовали? Даже на русском вроде есть.

8 часов назад, VecH сказал:

Порты нужные загнать в vlanХ, остальные по дефолту №1

Как их в 25 порт загнать и на другой стороне раскидать опять по lan портам?

Пример конфигурации и покажите пож. Дальше сам разберусь как все это работает

Пример прямо из вышеприведенной документации, коммутаторы подключены 11-ми портами - остальные абонентские:

Цитата

Switch A:
Switch(config)#vlan 2
Switch(Config-Vlan2)#switchport interface ethernet 1/0/2-4
Switch (Config-Vlan2)#exit
Switch (config)#vlan 100
Switch (Config-Vlan100)#switchport interface ethernet 1/0/5-7
Switch (Config-Vlan100)#exit
Switch (config)#vlan 200
Switch (Config-Vlan200)#switchport interface ethernet 1/0/8-10
Switch (Config-Vlan200)#exit
Switch (config)#interface ethernet 1/0/11
Switch (Config-If-Ethernet1/0/11)#switchport mode trunk
Switch (Config-If-Ethernet1/0/11)#exit
Switch(config)#
Switch B:
Switch (config)#vlan 2
Switch (Config-Vlan2)#switchport interface ethernet 1/0/2-4
Switch (Config-Vlan2)#exit
Switch (config)#vlan 100
Switch (Config-Vlan100)#switchport interface ethernet 1/0/5-7
Switch (Config-Vlan100)#exit
Switch (config)#vlan 200
Switch (Config-Vlan200)#switchport interface ethernet 1/0/8-10
Switch (Config-Vlan200)#exit
Switch (config)#interface ethernet 1/0/11
Switch (Config-If-Ethernet1/0/11)#switchport mode trunk
Switch (Config-If-Ethernet1/0/11)#exit

 

Share this post


Link to post
Share on other sites
1 минуту назад, prolan сказал:

Документацию читать не пробовали? Даже на русском вроде есть.

Пробовал, как раз по этому примеру, все равно летит все под одним тегом.

 

Где на русском есть почитать про железки snr и их софт?

Share this post


Link to post
Share on other sites
1 минуту назад, VecH сказал:

Пробовал, как раз по этому примеру, все равно летит все под одним тегом.

Итоговую свою конфигурацию покажите

Share this post


Link to post
Share on other sites

prolan Смогу показать через пару дней

Прошу прощения, был невнимателен, у 2 (из 3) железяк были одинаковые IP адреса, внося изменения в одну, смотрел результат на другой стороне совсем другой железяки

 

Все работает как описано в мануале

 

Возник другой вопрос, как балансировать траффик между VLAN-ами связанных между собой маршрутизаторов оптикой

1 VLAN-у надо отдать гарантированные Х мбит

2 VLAN-у надо отдать приоритет

3 VLAN-у отдать все что останется

в какой мануал глянуть?

Edited by VecH

Share this post


Link to post
Share on other sites

первое - policy map
второе и третье - qos

 

Документацию я уже указывал

Share this post


Link to post
Share on other sites

Как отделить порты 19-22 на одном из коммутаторов что бы работали как свичи без связи с остальными портами?

Тоже через vlan-ы? (пробовал, связь между портами все равно есть)

Скрытый текст

SNR-S2985G-24T#show startup-config
!
no service password-encryption
!
hostname SNR-S2985G-24T
sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia
sysContact support@nag.ru
!
authentication line console login local
!
!
!
!
!
!
!
!
!
!
!
!
vlan 1
!
vlan 2
 name iptv
!
vlan 3
 name lan100
!
Interface Ethernet1/0/1
!
Interface Ethernet1/0/2
!
Interface Ethernet1/0/3
!
Interface Ethernet1/0/4
!
Interface Ethernet1/0/5
!
Interface Ethernet1/0/6
!
Interface Ethernet1/0/7
!
Interface Ethernet1/0/8
!
Interface Ethernet1/0/9
!
Interface Ethernet1/0/10
!
Interface Ethernet1/0/11
!
Interface Ethernet1/0/12
!
Interface Ethernet1/0/13
!
Interface Ethernet1/0/14
!
Interface Ethernet1/0/15
!
Interface Ethernet1/0/16
!
Interface Ethernet1/0/17
!
Interface Ethernet1/0/18
!
Interface Ethernet1/0/19
 switchport access vlan 3
!
Interface Ethernet1/0/20
 switchport access vlan 3
!
Interface Ethernet1/0/21
 switchport access vlan 3
!
Interface Ethernet1/0/22
 switchport access vlan 3
!
Interface Ethernet1/0/23
 switchport access vlan 2
!
Interface Ethernet1/0/24
 switchport access vlan 2
!
Interface Ethernet1/0/25
 switchport mode trunk
!
Interface Ethernet1/0/26
!
Interface Ethernet1/0/27
!
Interface Ethernet1/0/28
!
interface Vlan1
 ip address 10.3.0.1 255.255.255.0
!
!
no login
!
captive-portal
!
end

 

 

Edited by VecH

Share this post


Link to post
Share on other sites

Это мне все порты надо изолировать от 19-22

или как то загонять в группы и уже группы от друг друга изолировать?

не пойму логику

 

я ведь не хочу изолировать порты с 19 по 22 друг от друга, мне надо что бы эта группа портов была изолирована от остальных

 

Скрытый текст

Курс пройду с удовольствием, когда командировки будут оплачивать :) и не придется ехать по много тысяч км с дальнего востока

 

Edited by VecH

Share this post


Link to post
Share on other sites

@VecH, для изоляции трафика группы портов от остальных достаточно выделить их в другой vlan.

 

23 часа назад, VecH сказал:

Interface Ethernet1/0/19
 switchport access vlan 3
!
Interface Ethernet1/0/20
 switchport access vlan 3
!
Interface Ethernet1/0/21
 switchport access vlan 3
!
Interface Ethernet1/0/22
 switchport access vlan 3
!
Interface Ethernet1/0/23
 switchport access vlan 2
!
Interface Ethernet1/0/24
 switchport access vlan 2

В приведенном примере обмен трафиком будет осуществляться только между портами в конкретном vlan.

Share this post


Link to post
Share on other sites

@Victor Tkachenko опять выяснилось что сеть закольцована, от этого сложно было понять почему в изолированных портах в vlan3 почему то проходили пакеты из другой сети (предприятие раскидано по всему населенному пункту и за его пределами, отследить сложно)

 

приведенном моей конфигурации что нужно сделать что бы vlan3 не летел в транковый порт 25

Share this post


Link to post
Share on other sites
1 час назад, VecH сказал:

приведенном моей конфигурации что нужно сделать что бы vlan3 не летел в транковый порт 25

Нужно указать разрешенные для 25 порта vlan, например

switchport trank allowed vlan 1;2

 

Share this post


Link to post
Share on other sites

Как посмотреть список IP, MAC адресов по портам/vlan?

(какой день не могу догнать хулиганское устройство в сети)

Share this post


Link to post
Share on other sites

День добрый. Подскажите по конфигурации. Есть  

SNR-S2990G-48TX Device, Compiled on Feb 26 10:11:23 2018
  SoftWare Version 7.0.3.5(R0102.0269)
  BootRom Version 7.1.41
  HardWare Version 1.0.1
 

Хочется организовать его работу в качестве граничного маршрутизатора оспф 

router ospf 10
 ospf router-id 10.10.254.99
 network 10.0.0.61 0.0.0.0 area 0
 network 10.0.0.65 0.0.0.0 area 0
 network 10.10.0.33 0.0.0.0 area 1
 redistribute connected
!

С первого взгляда все хорошо. Есть соседи и со стороны ареи1 и ареи0. В таблице маршрутизации ареи1 есть маршруты с маршрутизаторов ареи 0 и наоборот. Сам коммутатор пингует вся и все, что есть включенного. В ареи 0 есть дефолтный маршрут наружу, анонсированный одним из роутеров.

Если смотреть прохождение пакета  с клиента, подключенного к  другому маршрутизатору из ареи 1 , пакет благополучно добирается до адреса назначения клиента в ареи 0.

А в обратную сторону получается петля маршрутизации между рассматриваемым снр и ближайшим хопом в сторону дефолтного маршрута. Получается что снр не перенаправляет пакет в интерфейс арии1 к нужному маршрутизатору (по маршруту который у него присутствует в таблице )

Routing entry for 10.10.254.18/32
  Known via "ospf", distance 110, metric 21, best
  Last update 00:05:13 ago
  * 10.10.0.39, via Vlan10

 а отправляет его по полученному из оспф дефолтному маршруту

Routing entry for 0.0.0.0/0
  Known via "ospf", distance 110, metric 1, best
  Last update 00:02:36 ago
  * 10.0.0.62, via Vlan13

 

 

 Что ещё надо донастроить,  чтобы это заработало как надо? Подобная конфигурация была протестирована еще на 

SNR-S2990-16X Device, Compiled on Oct 18 21:09:28 2017
  SoftWare Package Version 7.5.3.0(R0016.0034)
  BootRom Version 7.4.5
  HardWare Version 1.0.1
  CPLD Version 0.3

тоже не срослось. Общее количество маршрутов прокручиваемых по оспф около 1000.

 

Share this post


Link to post
Share on other sites

@labusman, добрый!

 

S2990G-48TX - это в первую очередь коммутатор, размер аппаратной таблицы маршрутизации на нем ограничен 128 записями. Эффективного использовать его как ABR не удастся, скорее как Internal Router в stub.

C S2990-16X ситуация аналогичная, размер аппаратной таблицы маршрутизации ограничен 64 записями.

Share this post


Link to post
Share on other sites

@Victor Tkachenko Немножко не по теме. А что посоветуете из линейки что бы "держало" подобную конфигурацию, плюс с минимум 4-мя оптичискими 10г портами на борту и портами 20-ю меди под общее количество маршрутов в 8к+, возможностью подьема 4+ lacp линков, vrp а лучше полным стекированием для резервирования и с общей пропускной соответствующей. В сторону l2+ я так понимаю вообще смотреть не стоит?

Share this post


Link to post
Share on other sites

@labusman, в вашем случае нужен L3-коммутатор с хорошим запасом по ресурсу L3.

Модель под ваш запрос у нас будет ориентировочно в Q4 2018. На данный момент ближайшим по требованиям является SNR-S300G-24FX, но у него медных портов всего 16 (16 1G combo, 8 1G SFP, 4 10G SFP+).

Share this post


Link to post
Share on other sites

Еще вопросик возник. На этот раз работаем с 

  SNR-S300G-24FX Device, Compiled on Mar 05 13:25:02 2018
  SoftWare Package Version 7.5.3.0(R0010.0154)
  BootRom Version 7.3.126
  HardWare Version 1.0.3
  CPLD Version R7

Задачи те-же, что и выше, но захотелось немного оптимизировать и просуммировать маршруты на границе:

router ospf
 area 1 range 172.20.0.0/16
 network 10.0.0.61 0.0.0.0 area 0
 network 10.0.0.65 0.0.0.0 area 0
 network 10.10.0.33 0.0.0.0 area 1

Подсети 172.20 прилетают от других маршрутизаторов в ареа 1 и не хочется их выпускать в арею 0 ибо они там прилетают мелкими сетками.

Так вот по этому конфигу не создался ни статический роут на Null - ну и на других маршрутизаторах ареи 0 - полный "букет" маршрутов. 

Добавил вручную "ip route 172.20.0.0/16 null0" и привел к виду 

router ospf
 area 1 range 172.20.0.0/16 not-advertise
 network 10.0.0.61 0.0.0.0 area 0
 network 10.0.0.65 0.0.0.0 area 0
 network 10.10.0.33 0.0.0.0 area 1
 redistribute static

Все равно букет виден. Как ограничить пересылку? (пробовал и summary-address 172.20...... not-advertiseтож как то не очень)?

 

UPD (проверка результатов через clear ip ospf process) - Запускать отдельные процессы роутинга для каждой ареи не пробовал.

 

Edited by labusman

Share this post


Link to post
Share on other sites
В 11.04.2018 в 19:04, labusman сказал:

[...]

Все равно букет виден. Как ограничить пересылку? (пробовал и summary-address 172.20...... not-advertiseтож как то не очень)?

 

UPD (проверка результатов через clear ip ospf process) - Запускать отдельные процессы роутинга для каждой ареи не пробовал.

 

 

Добрый день.

Пожалуйста, создайте обращение в support. К обращению отдельным файлом приложите вывод "show run", "show ver" и "show ip ospf database" с коммутатора.

Share this post


Link to post
Share on other sites
В 16.04.2018 в 10:36, Ivan Tarasenko сказал:

Добрый день.

Пожалуйста, создайте обращение в support. К обращению отдельным файлом приложите вывод "show run", "show ver" и "show ip ospf database" с коммутатора.

Не обращался -- я не настолько хорошо знаю, как использовать опции not-advertise что б утверждать, что что то не так. Хотелось конечно чуть более "разжеванной" инструкции по настройке оспф в часности на этих снр. По моей беде - вынес арею 1 в отдельный процесс оспф -- без явного redistribute - ничего лишнего между ареями не светится. Все короче хорошо. Спасибо за помощь.

Share this post


Link to post
Share on other sites

Добрый день.

Имеем:

SNR-S2990G-24FX Device, Compiled on Jan 09 17:26:07 2017

SoftWare Version 7.0.3.5(R0102.0193)
  BootRom Version 7.1.41
  HardWare Version 1.0.1
 

Порты настроены в гибрид режиме. Каждый в своем влан и плюс пропускают дальше еще по парочке вланов.

Требуется порезать весь трафик в части вланов кроме пппое.

 

Share this post


Link to post
Share on other sites

@Sacrament, добрый!

Опишите, пожалуйста, задачу подробнее. Можете создать обращение на support и приложить к нему полную конфигурацию коммутатора.

Share this post


Link to post
Share on other sites
6 часов назад, Victor Tkachenko сказал:

@Sacrament, добрый!

Опишите, пожалуйста, задачу подробнее. Можете создать обращение на support и приложить к нему полную конфигурацию коммутатора.

К примеру:

Interface Ethernet1/0/1
 storm-control broadcast pps 120
 storm-control multicast pps 120
 switchport flood-control bcast
 switchport flood-control mcast
 switchport mode hybrid
 switchport hybrid allowed vlan 123 tag
 switchport hybrid allowed vlan 1402 untag
 switchport hybrid native vlan 1402
 loopback-detection specified-vlan 1-4094
 loopback-detection control shutdown
Как мне в влан 1402 заблокировать весь трафик кроме PPPoE 

При этом эти правила не должны задевать влан 123

 

Share this post


Link to post
Share on other sites

@Sacrament, при помощи MAC ACL, например, так:

mac-access-list extended PPPoE_and_vlan123
  permit any-source-mac any-destination-mac vlanId 123
  permit any-source-mac any-destination-mac ethertype 34915
  permit any-source-mac any-destination-mac ethertype 34916
  deny any-source-mac any-destination-mac
  exit
!
Interface Ethernet1/0/1
 mac access-group PPPoE_and_vlan123 in
!

 

Share this post


Link to post
Share on other sites
13 часов назад, Victor Tkachenko сказал:

@Sacrament, при помощи MAC ACL, например, так:


mac-access-list extended PPPoE_and_vlan123
  permit any-source-mac any-destination-mac vlanId 123
  permit any-source-mac any-destination-mac ethertype 34915
  permit any-source-mac any-destination-mac ethertype 34916
  deny any-source-mac any-destination-mac
  exit
!
Interface Ethernet1/0/1
 mac access-group PPPoE_and_vlan123 in
!

 

То что нужно. Эти правила не заденут работу loopback-detection?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now