Jump to content
Калькуляторы

Примеры настроек коммутаторов SNR

Здравствуйте, raveren!

 

В трапе приходит engine ID в кодировке ASCII.

Точнее в HEX-кодах символов ASCII таблицы.

 

Это нормально и исправлять не надо?

Share this post


Link to post
Share on other sites

Как через SNMP отключить функцию am port, если нет IP-адреса?

SNR-S2965-24T#sh am
AM is enabled

Interface Ethernet1/0/5
   am port

Share this post


Link to post
Share on other sites

Что по поводу моего сообщения?

Будет такой функционал или в сторону D-Link'а смотреть?

Share this post


Link to post
Share on other sites

Что по поводу моего сообщения?

Будет такой функционал или в сторону D-Link'а смотреть?

Такой функционал сейчас не поддерживается

И всё же не совсем понятна ваша схема , на каждом коммутаторе доступа включен igmp querier ? с какой целью ? Обычно одного igmp querier на PIM интерфейсе достаточно .

Для того чтобы проверять настроен коммутатор или нет, можно по SNMP другие OID запрашивать, включен ли igmp snooping в vlan и.т.п., почему именно querier source ?

Share this post


Link to post
Share on other sites

Такой функционал сейчас не поддерживается

И всё же не совсем понятна ваша схема , на каждом коммутаторе доступа включен igmp querier ? с какой целью ? Обычно одного igmp querier на PIM интерфейсе достаточно .

Для того чтобы проверять настроен коммутатор или нет, можно по SNMP другие OID запрашивать, включен ли igmp snooping в vlan и.т.п., почему именно querier source ?

Ни на одном коммутаторе доступа не включен igmp querier, как Вы правильно заметили его достаточно на PIM интерфейсе.

У нас одно время была проблема. Если на магистральных коммутаторах серии D-Link DGS-3100 включен IGMP Snooping на управляющем VLAN'е (по случайности), то какого-то лешего его IP-адрес управления становился querier для коммутаторов на доступе. Появлялись жалобы на услугу IPTV. Рассыпалась картинка. Если бы не было видно querier'а то мы бы очень долго искали бы проблему.

 

В общем можно долго дискутировать для чего и почему. Если запрошенный функционал реализовать для вас очень сложно, то мне проще оставаться на том оборудовании, которое его поддерживает. Хоть мне и понравился этот коммутатор.

Share this post


Link to post
Share on other sites

Добрый день,

Данный функционал в ближайшее время реализован не будет.

Не проще ли мониторить на DGS-3100, не включен ли igmp snooping в управляющем vlan ?

Share this post


Link to post
Share on other sites

На транковом порту по умолчанию пропускаются все созданные vlan, по этому команда switchport trunk allowed vlan all не отображается в конфигурации.

Но для того чтобы трафик проходил в vlan, его надо создать, можно создать сразу все vlan командой "vlan 1-4094"

Share this post


Link to post
Share on other sites

прикольно )

Спасибо.

 

Странно, что в 99% случаев транк порт пропускает и без создания вланов.

Ну да ладно....

Share this post


Link to post
Share on other sites

Добрый день!

 

Взял несколько коммутаторов SNR-2965-24T.

Пока впечатления положительные, но, в связи с отсутствием документации (то, что есть - quickstart guides, с мини-описанием технологии, к которой раздел относится) есть вопросы и появились замечания.

 

Итак.

1. Классика жанра: ip dhcp snooping и опция 82

Схема стандартная: VLAN управления с ip-адресом, VLAN для пользователей без ip-адреса, один аплинк в режиме транк, default-gateway в наличии, DHCP-сервер пингуется.

Snooping настроен, пользователи получают ip-адреса, всё работает, нареканий нет.

Как только добавляю команду добавить опцию 82 (SNR(config)#ip dhcp snooping information enable) - на DHCP-сервер даже никаких запросов не отправляется:

!service dhcp
!
ip forward-protocol udp bootps
ip dhcp relay information option
!
ip dhcp snooping enable
ip dhcp snooping binding enable
!
ip dhcp snooping information enable
!
anti-arpscan enable
!
vlan 103
name mgmt
!
vlan 196
name clients
!
Interface Ethernet1/0/1
switchport access vlan 196
loopback-detection specified-vlan 196
loopback-detection control block
switchport mac-address dynamic maximum 8
!
...
!
Interface Ethernet1/0/24
switchport mode trunk
switchport trunk allowed vlan 103;196
ip dhcp snooping trust
!

 

Никаких фильтров от транкового порта до сервера точно нет, проверил не один раз. На сервере от другого DLink есть запросы и ответы, через него всё работает, в логи добавил информацию из опции 82, корректно указаны порты и Switch ID.

 

Сначала работал с прошивкой 67 (SoftWare Version 7.0.3.5(R0241.0067)), потом залил 102 - ситуация та же. В ченж-логе много исправлений по опции 82.

 

Может быть, я что-то не так делаю? Почему перестают идти запросы?

 

P.S. Столкнулся ещё с одним неприятным моментом. Пока всё на столе, выставил exec-timeout 0 0 и захожу по ssh. Всё замечательно. Но! при переключении витых пар произошёл обрыв сессии, в которой ползователь admin находился в режиме конфигурирования. Итого: подключиться к коммутатору я могу, а что-либо изменить (кроме перезагрузки) - нет, т.к. "другой пользователь производит настройку". Специально подождал два часа - зависшая сессия так и не "отпала", информации о том, как её сбросить принудительно - не нашёл, clear line vty xx - для telnet-сессий.

 

Заранее всем спасибо за ответы/советы.

Share this post


Link to post
Share on other sites

Добрый день,

1) Конфиг коммутатора правильный, ваш DHCP сервер копирует опцию 82 в ответы ?

Включите дебаг:

debug ip dhcp snooping packet

debug ip dhcp snooping event

terminal monitor

и приложите вывод дебага в момент получения адреса.

отключается дебаг командой no debug all .

 

2) Проверил команду clear line vty - сбрасывает как telnet, так и ssh сессии. Для того чтобы несколько пользователей могли находится в режиме конфигурирования, примените команду "multi config access"

 

P.S. Рекомендую зарегистрироваться и завести обращение на support.nag.ru, поможем с любыми вопросами по нашему оборудованию.

Share this post


Link to post
Share on other sites

Время настраивается clock set.

А как настроить дату?

Share this post


Link to post
Share on other sites

Подскажите, как на SNR-S2950-24G запретить доступ в сеть по МАС адресу.

спасибо

Share this post


Link to post
Share on other sites

Время настраивается clock set.

А как настроить дату?

 

Нет никакого смысла вообще настраивать на таком оборудовании дату-время вручную. Используйте SNTP.

 

Подскажите, как на SNR-S2950-24G запретить доступ в сеть по МАС адресу.

спасибо

Аксес листы на портах, плюс надо сервис фаервола включить.

Share this post


Link to post
Share on other sites

Добрый день.

Имеется snr-s2960-24G

проблема в том что не работают модули snr-sfp-w36-20

при подключении оптики, линк просто не появляется.

Оптика проверена, при подключении обычного конвертера TX 1310 линк появляется. SFP модули проверены на другом оборудовании, работают исправно.

Есть подозрение что нужно переключить комбо порты в настройках с Ethernet на SFP или коммутатор просто не работает с этими модулями.

Прошу помогите советом, спасибо.

Share this post


Link to post
Share on other sites

Интересует когда появится возможность получать l2-general-querier-source адрес по SNMP на S2965 или будет ли такая возможность в принципе? Нужно по зарез.

Share this post


Link to post
Share on other sites

С такими железками дела не имел, но исходя из общей логики:

SNR-S2960-24G(config-if-vlan1)#ip default-gateway 192.168.5.1

Неправильный контекст, шлюз - настройка не влана а глобальная, должно быть

SNR-S2960-24G([b]config[/b])#ip default-gateway 192.168.5.1

 

Да это я не доглядел. Уже несколько дней мучаюсь пытаясь понять логику, сильно от длинка отличается. Решил сделать буква в букву по инструкции, а там пунк перехода в глабольный пропущен :)

 

SNR-S2950-24G(config-if-vlan1)#ip address 10.10.10.1 255.255.255.0

Пропишем маршрут по умолчению

Switch(config)#ip default-gateway 10.10.10.254

Включаем интерфейс vlan 1

SNR-S2950-24G(config-if-vlan1)#no shu

Возвращаемся в "глобальный конфиг"

SNR-S2950-24G(config-if-vlan1)#exi

 

SNR-S2960-24G#copy tftp://192.168.5.111/2960-24g.mib

% Incomplete command.

Не хватает второго параметра, куда копировать, что-то типа

SNR-S2960-24G#copy tftp://192.168.5.111/2960-24g.mib image-1

ЗЫ mib - оригинальное расширение для файла прошивки =)

Или это всё-таки SNMP-MIBs, но тогда зачем их заливать в коммутатор?

 

Понял, что не тот файл схватил :) а про параметры опять же в инструкции ни слова:

 

Обновление ПО коммутатора производится командой

SNR-S2950-24G#copy tftp://10.10.10.10/nos.img nos.img

Confirm to overwrite the existed destination file? [Y/N]:y

Begin to receive file, please wait...

 

как я понял из веб интерфейса тут все таки нет параметра куда заливать. тут нужно указать путь/название файла от куда и название файла в свиче?

 

Дружище, подскажи где найти эти инструкции?

купили эту (SNR-2985G-48T) неведому зверушку... ну половина непонятно как настроить.

в даташите почему то спек лист.

где искать нормальную документацию совсем непонятно.

где прочитать, что умеет и какие ограничения тоже неизвестно =(

Share this post


Link to post
Share on other sites

наткнулся на странный глюк.

SNR-S2985G-48T

loopback detection при попытке настроить порт ничего не происходит.

состояние не изменяется.

рандомно раз из скольки то попыткок команда проходит (1\10-20)

SW1# config t

SW1(config)# interface Ethernet1/0/2

SW1(config-if-ethernet1/0/2)# loopback-detection control block

что делать?

Share this post


Link to post
Share on other sites
что делать?

Написать версию софта и, если не последний, то обновиться.

Share this post


Link to post
Share on other sites

день добрый, как то не понятно с 2990G, сток конфиг из коробки, меняю IP всё норм. При попытке прописать шлюз посылает лесом...

 

SNR-S2990G-24T#conf

SNR-S2990G-24T(config)#ip default-gateway 192.168.60.1

^

% Invalid input detected at '^' marker.

 

SNR-S2990G-24T(config)#

SNR-S2990G-24T#sh ver

SNR-S2990G-24T Device, Compiled on Aug 28 09:47:05 2014

sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia

CPU Mac f8:f0:82:73:64:a2

Vlan MAC f8:f0:82:73:64:a1

SoftWare Version 7.0.3.5(R0102.0089)

BootRom Version 7.1.37

HardWare Version R01

CPLD Version N/A

Serial No.:SW041410EA22001054

Copyright © 2014 NAG LLC

All rights reserved

Last reboot is cold reset.

Uptime is 0 weeks, 2 days, 9 hours, 22 minutes

Edited by nikulich

Share this post


Link to post
Share on other sites

день добрый, как то не понятно с 2990G, сток конфиг из коробки, меняю IP всё норм. При попытке прописать шлюз посылает лесом...

 

SNR-S2990G-24T#conf

SNR-S2990G-24T(config)#ip default-gateway 192.168.60.1

^

% Invalid input detected at '^' marker.

 

SNR-S2990G-24T(config)#

SNR-S2990G-24T#sh ver

SNR-S2990G-24T Device, Compiled on Aug 28 09:47:05 2014

sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia

CPU Mac f8:f0:82:73:64:a2

Vlan MAC f8:f0:82:73:64:a1

SoftWare Version 7.0.3.5(R0102.0089)

BootRom Version 7.1.37

HardWare Version R01

CPLD Version N/A

Serial No.:SW041410EA22001054

Copyright © 2014 NAG LLC

All rights reserved

Last reboot is cold reset.

Uptime is 0 weeks, 2 days, 9 hours, 22 minutes

А так?

 

SNR-S2990G-24T#conf
SNR-S2990G-24T(config)#ip route 0.0.0.0 0.0.0.0 192.168.60.1

Share this post


Link to post
Share on other sites

Добрый день.

 

Подскажите, может я чего-то не понимаю...

 

На сети поднято RSTP

 

Поставили на новый район в качестве магистральника SNR-S2990G-24FX

На район приходит два канала из разных участков сети.

Основной SNR20порт - оптика - DGS3100 ...

Резерв SNR21порт - радиоканал ubnt - DGS1210 ...

 

Раньше за место SNR-S2990G-24FX стоял просто DES1228, когда в том районе было всего пару домов, схема включения была аналогичная. ВСе было ОК.

 

Теперь, когда мы включаем 21 порт на SNR, то наблюдаем такую картину:

 

 

SNR_nov-ivan-11#show spanning-tree

 

-- RSTP Bridge Config Info --

 

Standard : IEEE 802.1w

Bridge MAC : f8:f0:82:75:8b:09

Bridge Times : Max Age 20, Hello Time 2, Forward Delay 15

Force Version: 2

 

#############################################################

Self Bridge Id : 8192.f8:f0:82:75:8b:09

Root Id : 0.00:04:96:82:63:38

Ext.RootPathCost : 20020

Root Port ID : 128.20

 

PortName ID ExtRPC State Role DsgBridge DsgPort

-------------- -------- --------- --- ---- ------------------ -------

Ethernet1/0/1 128.001 20020 FWD DSGN 8192.f8f082758b09 128.001

Ethernet1/0/2 128.002 20020 FWD DSGN 8192.f8f082758b09 128.002

Ethernet1/0/20 128.020 20000 FWD ROOT 16384.1caff7e5b09a 128.015

Ethernet1/0/21 128.021 20020 BLK DSGN 8192.f8f082758b09 128.021

Ethernet1/0/22 128.022 20020 FWD DSGN 8192.f8f082758b09 128.022

Ethernet1/0/23 128.023 20020 FWD DSGN 8192.f8f082758b09 128.023

 

Далее:

Ethernet1/0/20 128.020 20000 FWD ROOT 16384.1caff7e5b09a 128.015

Ethernet1/0/21 128.021 20020 LRN DSGN 8192.f8f082758b09 128.021

 

Далее:

Ethernet1/0/20 128.020 20000 FWD ROOT 16384.1caff7e5b09a 128.015

Ethernet1/0/21 128.021 20020 FWD DSGN 8192.f8f082758b09 128.021

 

 

 

 

На DGS1210 куда приходит радиоканал у нас такое:

п.с. радиоканал включен в 18 порт....

 

56 Oct 27 10:25:28:STP-6:Port state changed (forwarding) [( port: 18)] (это после выключения 21 порта на SNR)

54 Oct 27 10:23:07:STP-6:Port state changed (discarding) [( port: 18)] (это после включения 21 порта на SNR)

 

При включенном 21 порту на SNR

DGS-1210-28/ME:5# show stp instance

Command: show stp instance

 

 

## CIST

Designated Root Bridge 00:04:96:82:63:38 Priority 2048

Port 23 , path cost 62000

Regional Root Bridge 9c:d6:43:61:1d:f4 Priority 32768

Path cost 0

Designated Bridge 70:62:b8:4f:6b:00 Priority 32768

Configured Forward delay 15, Max age 20, Max hops 20

Operational Forward delay 15, Max age 20

Topology Changes Count : 1325

Last Topology Change : 483

 

Interface Role Sts Cost Prio.Nbr Type

--------- ---- --- ---- -------- ----

18 Alternate Discarding 200000 128.18 Point to point

23 Root Forwarding 20000 128.23 Point to point

 

 

 

 

И вроде бы все правильно и хорошо.

 

Однако на сети начинается ад...

У нас каждую минуту происходит мониторинг каждого коммутатора ping+snmp.

В итоге часть DES1228, DES-3200, DGS1210 становится недоступно, при детальном изучении - они перестают отвечать на arp запросы.... если поставить их на arping то через секунд 10 ответы пойдут, но с задержкой 100-300мс...

 

Собственно вопрос, что за кабздец? :)

 

Конфиги:

DGS1210:

 

enable stp

config stp version rstp

config stp priority 32768 instance_id 0

config stp txholdcount 6 maxage 20 hellotime 2 forwarddelay 15 maxhops 20

config stp fbpdu disable

config stp ports 18 externalcost auto edge false restricted_tcn false restricted_role false p2p auto state enable priority 128 fbpdu enable

config stp ports 23 externalcost auto edge false restricted_tcn false restricted_role false p2p auto state enable priority 128 fbpdu enable

config stp mst_config_id name 00:12:34:56:78:90 revision_level 0

 

SNR:

 

spanning-tree

spanning-tree mode rstp

spanning-tree priority 8192

 

Interface Ethernet1/0/20

spanning-tree cost 20

switchport mode trunk

switchport trunk allowed vlan 7-8;15;100;515;1201;2354-2356;2608

switchport trunk allowed vlan add 2625-2626

!

Interface Ethernet1/0/21

description wifi

shutdown

spanning-tree cost 99999999

switchport mode trunk

switchport trunk allowed vlan 7;15;100;515;1201;2354-2356;2608 (8 vlan тут отсутствует ибо мультикаст!)

switchport trunk allowed vlan add 2625-2626

Share this post


Link to post
Share on other sites

Доброго времени суток много Уважаемые.

Нужна консультация.

есть 2 коммутатора SNR2965 соединенны меду собой через wi-fi мост на ubiquiti,

также на коммутаторах подключены еще парочка мостов на ubiquiti.

на SNR-ах управляющий Vlan5 выбран на антеннах управляющий Vlan7.

соединяющие порты в режиме trunk.

набираю на коммутаторе команду: sh mac-address-table vlan 1

то получаю на портах где подключены ubiquiti, мак-адреса антенн.

временно использую native на нужных портах. но считаю что данный вариант не совсем правильный.

вопрос: Возможно ли как-то исключить vlan1? понимаю что дефолтовый vlan не как не убрать.

или как на порту указать дефолтовый vlan например управления антенны?

Share this post


Link to post
Share on other sites

или как на порту указать дефолтовый vlan например управления антенны?

 

swtichport trunk native vlan x

Share this post


Link to post
Share on other sites

swtichport trunk native vlan x

 

Спасибо. но это не то Тех поддержка порекомендовала на trunk портах добавить вот этот параметр.

switchport discard packet untag

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now