Jump to content
Калькуляторы

2 провайдера по PPPoE + раздача Internet (PPPoE server)

Здравствуйте уважаемые!

 

Cisco 881-k9

Есть 2 канала.

Один подключение к сети Internet, 2-й к VPN сети филиалов. Ниже в конфиге маршрутизация опущена.

Оба подключения осуществляются посредством DSL PPPoE

Кроме этого хочется раздавать Интернет в локальной сети только аутентифицированным для этого пользователям посредством сконфигурированного на этом же маршрутизаторе pppoe сервера.

 

Ввод команды "pppoe enable group global" ни для int vlan 1, ни для int fa 4 не дает результатов. Ошибки не выдает, но и в конфиге не отображается! :?

Буду признателен за любую подсказку.

Заранее спасибо!

 

Далее конфиг ...

 

version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication ppp default local
aaa authorization network default local
!
!
!
!
!
aaa session-id common
!
!
!
memory-size iomem 10
!
!
ip dhcp excluded-address 10.37.125.1 10.37.125.20
ip dhcp excluded-address 10.37.225.1 10.37.225.20
!
ip dhcp pool ccp-pool
  import all
  network 10.37.125.0 255.255.255.0
  dns-server 10.37.125.1
  default-router 10.37.125.1
  lease 0 2
!
ip dhcp pool PPPoEpool
  network 10.37.225.0 255.255.255.0
  default-router 10.37.225.1
  dns-server 10.37.225.1
!
!
ip cef
ip domain lookup source-interface Dialer0
ip domain name yourdomain.com
no ipv6 cef
!
!
username user privilege 15 secret 5 XXXXXXXX
username pppoeuser privilege 0 password 7 XXXXXXXX
!
!
!
!
bba-group pppoe global
virtual-template 1
sessions max limit 100
sessions per-mac limit 1
sessions auto cleanup
!
!

interface FastEthernet0
description -= Internet =-
switchport access vlan 2
!
!
interface FastEthernet1
description -= MPSL VPN =-
switchport access vlan 3
!
!
interface FastEthernet2
!
!
interface FastEthernet3
!
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
!
interface Virtual-Template1
ip address 10.37.225.1 255.255.255.0
ip nat inside
ip virtual-reassembly
peer default ip address dhcp-pool PPPoEpool
ppp authentication chap ms-chap
!
!
interface Vlan1
ip address 10.37.125.1 255.255.255.0
ip virtual-reassembly
ip tcp adjust-mss 1452
!
!
interface Vlan2
no ip address
pppoe-client dial-pool-number 1
!
!
interface Vlan3
no ip address
pppoe-client dial-pool-number 2
!
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username user_int password 7 xxxxxxxxxxxx
ppp ipcp dns request
no cdp enable
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip virtual-reassembly
encapsulation ppp
dialer pool 2
ppp authentication pap callin
ppp pap sent-username user_mpls password 7 XXXXXXXXXXXXXXXXX
ppp ipcp dns request
no cdp enable
!
!
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip dns server
ip nat inside source list NAT_TRAFIC interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip access-list extended NAT_TRAFIC
permit ip 10.37.225.0 0.0.0.255 any
!
access-list 23 permit 10.37.125.0 0.0.0.255
access-list 23 permit 10.37.225.0 0.0.0.255
no cdp run

!
!
!
!
!
control-plane
!
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
logging synchronous
transport input telnet ssh
!
scheduler max-task-time 5000
end

Edited by TkIgor

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this